# Re: \[PATCH 0/25\] Replace DEFINE\_PCI\_DEVICE\_TABLE macro use

- From: John W. Linville \<hidden\>
- Date: 2014-07-18 16:30:50 
- List: linux-fbdev
- Page: https://ratatoskr.run/linux-fbdev/2014/07/4298796
- Thread: https://ratatoskr.run/linux-pci/2014/07/4298753/t.md

```text
On Fri, Jul 18, 2014 at 05:26:47PM +0200, Benoit Taine wrote:
> We should prefer `const struct pci_device_id` over
> `DEFINE_PCI_DEVICE_TABLE` to meet kernel coding style guidelines.
> This issue was reported by checkpatch.

Honestly, I prefer the macro -- it stands-out more.  Maybe the style
guidelines and/or checkpatch should change instead?

John
-- 
John W. Linville		Someday the world will need a hero, and you
linville@tuxdriver.com			might be all we have.  Be ready.
```
