Re: [PATCH 6/9] ARM i.MX51: Add IPU device support
From: Arnaud Patard (Rtp) <hidden>
Date: 2010-12-15 16:25:49
Arnd Bergmann [off-list ref] writes: Hi,
On Thursday 09 December 2010, Sascha Hauer wrote:quoted
+#define imx51_add_ipuv3(pdata) \ + imx_add_ipuv3(&imx51_ipuv3_data, pdata)This looks like a pointless abstraction, it does not make the code smaller or easier to read. I know it's sometimes tempting to use macros, but in most cases, you should try not to.
it's how things have been handled atm in the imx code. I don't have any preference on this at all but at least either we go on with it or we get rid of all theses #defines. It's a matter of consistency. The thing is that I would consider removing the imx*add* stuff to be a cleanup and should be done in a different patch, not in a patchset adding IPU support for imx51. Anyway, let's wait for Sascha's point of view, he knows the imx stuff far better than me. Arnaud