Re: [BK FBDEV] A few more updates.
From: Petr Vandrovec <hidden>
Date: 2003-03-26 10:42:32
Also in:
lkml
On 26 Mar 03 at 11:42, Petr Vandrovec wrote:
accel_cursor unconditionally sets FB_CUR_SETPOS. Can you write it down to the TODO list to eliminate this? Cursor position lives in different registers than cursor enable/disable on my hardware...
And if we could rename FB_CUR_SETCUR to FB_CUR_SETVISIBILITY and leave cursor->enable setting on accel_cursor's caller, it would be even better.
I just noticed that softcursor.c contains copy of FB_CUR_SETCUR ->
cursor->enable code from accel_cursor(). Either 'enable' field has
no bussiness in the fb_cursor structure (as it can be always infered from
set flags, and if softcursor needs some internal bookkeeping, it should
use some other variable and not fb_cursor's field), or this conversion
should disappear from softcursor.c, and FB_CUR_SETCUR semantic should
change.
Petr
-------------------------------------------------------
This SF.net email is sponsored by:
The Definitive IT and Networking Event. Be There!
NetWorld+Interop Las Vegas 2003 -- Register today!
http://ads.sourceforge.net/cgi-bin/redirect.pl?keyn0001en