# Re: \[PATCH 25/30\] block: add a sb\_bdev\_nr\_blocks helper

- From: Kees Cook \<hidden\>
- Date: 2021-10-15 16:58:12 
- List: linux-ext4
- Page: https://ratatoskr.run/linux-ext4/2021/10/216143
- Thread: https://ratatoskr.run/linux-block/2021/10/216086/t.md

```text
On Fri, Oct 15, 2021 at 03:26:38PM +0200, Christoph Hellwig wrote:
> Add a helper to return the size of sb->s_bdev in sb->s_blocksize_bits
> based unites.  Note that SECTOR_SHIFT has to be open coded due to
> include dependency issues for now, but I have a plan to sort that out
> eventually.
> 
> Signed-off-by: Christoph Hellwig <hch@lst.de>

You can adjust this changelog to remove the note about SECTOR_SHIFT
now. :)

Reviewed-by: Kees Cook <redacted>

-- 
Kees Cook
```
