thermal · Supported
Maintainers
- M Rafael J. Wysocki <rafael@kernel.org>
- M Daniel Lezcano <daniel.lezcano@kernel.org>
- R Zhang Rui <rui.zhang@intel.com>
- R Lukasz Luba <lukasz.luba@arm.com>
Paths
- F
Documentation/ABI/testing/sysfs-class-thermal - F
Documentation/admin-guide/thermal/ - F
Documentation/devicetree/bindings/thermal/ - F
Documentation/driver-api/thermal/ - F
drivers/thermal/ - F
include/dt-bindings/thermal/ - F
include/linux/cpu_cooling.h - F
include/linux/thermal.h - F
include/uapi/linux/thermal.h - F
tools/lib/thermal/ - F
tools/thermal/
Last 30 days
Recent patches
Most-recent 18 patches in this subsystem on linux-edac, ordered by date desc.
-
WARM3d
[PATCH 31/32] treewide: convert rdmsrq() from a macro to an inline function
2026-06-29 · Juergen Gross <jgross@suse.com> -
COLD32d
REVIEWED: 4 (4M) [PATCH v3 05/11] x86/msr: Switch wrmsr_on_cpu() users to wrmsrq_on_cpu()
2026-06-08 · Juergen Gross <jgross@suse.com> -
COLD32d
REVIEWED: 4 (4M) [PATCH v3 03/11] x86/msr: Switch rdmsr_on_cpu() users to rdmsrq_on_cpu()
2026-06-08 · Juergen Gross <jgross@suse.com> -
COLD33d
[PATCH v2 05/10] x86/msr: Switch wrmsr_on_cpu() users to wrmsrq_on_cpu()
2026-06-05 · Juergen Gross <jgross@suse.com> -
COLD33d
[PATCH v2 03/10] x86/msr: Switch rdmsr_on_cpu() users to rdmsrq_on_cpu()
2026-06-05 · Juergen Gross <jgross@suse.com> -
COLD35d
[PATCH 3/8] x86/msr: Switch wrmsr_on_cpu() to use a 64-bit quantity
2026-06-05 · Juergen Gross <jgross@suse.com> -
COLD35d
[PATCH 1/8] x86/msr: Switch rdmsr_on_cpu() to return a 64-bit quantity
2026-06-05 · Juergen Gross <jgross@suse.com> -
STALE73d
[PATCH RFC 03/11] x86/msr: Switch wrmsr_on_cpu() to use a 64-bit quantity
2026-04-28 · Juergen Gross <jgross@suse.com> -
STALE73d
[PATCH RFC 01/11] x86/msr: Switch rdmsr_on_cpu() to return a 64-bit quantity
2026-04-28 · Juergen Gross <jgross@suse.com> -
STALE350d
[PATCH v7 07/10] x86/nmi: Prepare for the new NMI-source vector encoding
2025-06-12 · Sohil Mehta <hidden> -
STALE393d
[PATCH v6 6/9] x86/nmi: Prepare for the new NMI-source vector encoding
2025-05-13 · Sohil Mehta <hidden> -
STALE427d
[PATCH v5 6/9] x86/nmi: Prepare for the new NMI-source vector encoding
2025-05-07 · Sohil Mehta <hidden> -
STALE433d
LANDED: 28 (28M) [PATCH v4A 01/15] x86/msr: Add missing includes of <asm/msr.h>
2025-05-01 · "Xin Li (Intel)" <xin@zytor.com> -
STALE433d
REVIEWED: 21 (21M) [PATCH v4 01/15] x86/msr: Add missing includes of <asm/msr.h>
2025-04-27 · "Xin Li (Intel)" <xin@zytor.com> -
STALE757d
LANDED [PATCH] tracing/treewide: Remove second parameter of __assign_str()
2024-05-16 · Steven Rostedt <rostedt@goodmis.org> -
STALE847d
[FYI][PATCH] tracing/treewide: Remove second parameter of __assign_str()
2024-02-23 · Steven Rostedt <rostedt@goodmis.org> -
STALE1626d
[PATCH] driver core: platform: Rename platform_get_irq_optional() to platform_get_irq_silent()
2022-01-13 · Uwe Kleine-König <hidden> -
STALE1626d
[PATCH 1/2] platform: make platform_get_irq_optional() optional
2022-01-10 · Sergey Shtylyov <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE73d
[PATCH RFC 01/11] x86/msr: Switch rdmsr_on_cpu() to return a 64-bit quantity
2026-04-28 · Juergen Gross <jgross@suse.com> -
STALE73d
[PATCH RFC 03/11] x86/msr: Switch wrmsr_on_cpu() to use a 64-bit quantity
2026-04-28 · Juergen Gross <jgross@suse.com> -
COLD35d
[PATCH 1/8] x86/msr: Switch rdmsr_on_cpu() to return a 64-bit quantity
2026-06-05 · Juergen Gross <jgross@suse.com> -
COLD35d
[PATCH 3/8] x86/msr: Switch wrmsr_on_cpu() to use a 64-bit quantity
2026-06-05 · Juergen Gross <jgross@suse.com> -
COLD33d
[PATCH v2 03/10] x86/msr: Switch rdmsr_on_cpu() users to rdmsrq_on_cpu()
2026-06-05 · Juergen Gross <jgross@suse.com> -
COLD33d
[PATCH v2 05/10] x86/msr: Switch wrmsr_on_cpu() users to wrmsrq_on_cpu()
2026-06-05 · Juergen Gross <jgross@suse.com>