superh · Maintained
Maintainers
- M Yoshinori Sato <ysato@users.sourceforge.jp>
- M Rich Felker <dalias@libc.org>
- M John Paul Adrian Glaubitz <glaubitz@physik.fu-berlin.de>
Paths
- F
Documentation/arch/sh/ - F
arch/sh/ - F
drivers/sh/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-doc (capped at 30), ordered by date desc.
-
COLD43d
Re: [PATCH v2 5/6] gpio: remove machine hogs
2026-05-20 · Dmitry Torokhov <dmitry.torokhov@gmail.com> -
STALE114d
[PATCH v3 24/29] arch, mm: consolidate initialization of SPARSE memory model
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE114d
[PATCH v3 23/29] arch, mm: consolidate initialization of nodes, zones and memory map
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE114d
[PATCH v3 18/29] sh: introduce arch_zone_limits_init()
2026-01-11 · Mike Rapoport <rppt@kernel.org> -
STALE132d
[PATCH v2 23/28] arch, mm: consolidate initialization of SPARSE memory model
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE132d
[PATCH v2 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE132d
[PATCH v2 17/28] sh: introduce arch_zone_limits_init()
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE180d
[PATCH 23/28] arch, mm: consolidate initialization of SPARSE memory model
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE180d
[PATCH 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE180d
[PATCH 17/28] sh: introduce arch_zone_limits_init()
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE265d
[PATCH RESEND 60/62] init: rename CONFIG_RD_LZO to CONFIG_INITRAMFS_DECOMPRESS_LZO
2025-09-14 · Askar Safin <hidden> -
STALE265d
[PATCH RESEND 58/62] init: rename CONFIG_RD_LZMA to CONFIG_INITRAMFS_DECOMPRESS_LZMA
2025-09-14 · Askar Safin <hidden> -
STALE265d
[PATCH RESEND 57/62] init: rename CONFIG_RD_BZIP2 to CONFIG_INITRAMFS_DECOMPRESS_BZIP2
2025-09-14 · Askar Safin <hidden> -
STALE265d
[PATCH RESEND 55/62] init: rename CONFIG_BLK_DEV_INITRD to CONFIG_INITRAMFS
2025-09-14 · Askar Safin <hidden> -
STALE265d
[PATCH RESEND 42/62] init: rename <linux/initrd.h> to <linux/initramfs.h>
2025-09-14 · Askar Safin <hidden> -
STALE265d
[PATCH RESEND 28/62] init: alpha, arc, arm, arm64, csky, m68k, microblaze, mips, nios2, openrisc, parisc, powerpc, s390, sh, sparc, um, x86, xtensa: rename initrd_{start,end} to virt_external_initramfs_{start,end}
2025-09-13 · Askar Safin <hidden> -
STALE265d
[PATCH RESEND 14/62] init: m68k, mips, powerpc, s390, sh: remove Root_RAM0
2025-09-13 · Askar Safin <hidden> -
STALE265d
[PATCH RESEND 04/62] init: x86, arm, sh, sparc: remove variable rd_image_start, which controls starting block number of initrd
2025-09-13 · Askar Safin <hidden> -
STALE265d
[PATCH RESEND 03/62] init: sh, sparc, x86: remove unused constants RAMDISK_PROMPT_FLAG and RAMDISK_LOAD_FLAG
2025-09-13 · Askar Safin <hidden> -
STALE269d
[PATCH 03/62] init: sh, sparc, x86: remove unused constants RAMDISK_PROMPT_FLAG and RAMDISK_LOAD_FLAG
2025-09-12 · Askar Safin <hidden> -
STALE364d
[PATCH] global: fix misapplications of "awhile"
2025-07-02 · Ahelenia Ziemiańska <hidden> -
STALE433d
Re: [PATCH v12 06/28] riscv/mm : ensure PROT_WRITE leads to VM_READ | VM_WRITE
2025-04-24 · "Arnd Bergmann" <arnd@arndb.de> -
STALE432d
REVIEWED: 2 (0M) [PATCH v4 11/14] sh: Add support for suppressing warning backtraces
2025-03-13 · Alessandro Carminati <hidden> -
STALE432d
[PATCH v4 12/14] sh: Move defines needed for suppressing warning backtraces
2025-03-13 · Alessandro Carminati <hidden> -
STALE581d
REVIEWED: 3 (1M) [PATCH v4 09/26] arch, mm: pull out allocation of NODE_DATA to generic code
2024-08-07 · Mike Rapoport <rppt@kernel.org> -
STALE581d
REVIEWED: 7 (5M) [PATCH v4 07/26] arch, mm: move definition of node_data to generic code
2024-08-07 · Mike Rapoport <rppt@kernel.org> -
STALE695d
REVIEWED: 2 (1M) [PATCH v3 09/26] arch, mm: pull out allocation of NODE_DATA to generic code
2024-08-01 · Mike Rapoport <rppt@kernel.org> -
STALE695d
REVIEWED: 6 (5M) [PATCH v3 08/26] arch, mm: move definition of node_data to generic code
2024-08-01 · Mike Rapoport <rppt@kernel.org> -
STALE706d
REVIEWED: 2 (1M) [PATCH v2 09/25] arch, mm: pull out allocation of NODE_DATA to generic code
2024-07-23 · Mike Rapoport <rppt@kernel.org> -
STALE706d
REVIEWED: 6 (5M) [PATCH v2 08/25] arch, mm: move definition of node_data to generic code
2024-07-23 · Mike Rapoport <rppt@kernel.org>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE180d
[PATCH 17/28] sh: introduce arch_zone_limits_init()
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE180d
[PATCH 22/28] arch, mm: consolidate initialization of nodes, zones and memory map
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE180d
[PATCH 23/28] arch, mm: consolidate initialization of SPARSE memory model
2025-12-28 · Mike Rapoport <rppt@kernel.org> -
STALE132d
[PATCH v2 17/28] sh: introduce arch_zone_limits_init()
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE132d
[PATCH v2 23/28] arch, mm: consolidate initialization of SPARSE memory model
2026-01-02 · Mike Rapoport <rppt@kernel.org> -
STALE114d
[PATCH v3 18/29] sh: introduce arch_zone_limits_init()
2026-01-11 · Mike Rapoport <rppt@kernel.org>