memory mapping · Maintained
Maintainers
- M Andrew Morton <akpm@linux-foundation.org>
- M Liam R. Howlett <liam@infradead.org>
- M Lorenzo Stoakes <ljs@kernel.org>
- R Vlastimil Babka <vbabka@kernel.org>
- R Jann Horn <jannh@google.com>
- R Pedro Falcato <pfalcato@suse.de>
Paths
- F
drivers/char/mem.c - F
include/trace/events/mmap.h - F
fs/proc/task_mmu.c - F
fs/proc/task_nommu.c - F
mm/mincore.c - F
mm/mlock.c - F
mm/mmap.c - F
mm/mprotect.c - F
mm/mremap.c - F
mm/mseal.c - F
mm/msync.c - F
mm/nommu.c - F
mm/vma.c - F
mm/vma.h - F
mm/vma_exec.c - F
mm/vma_init.c - F
mm/vma_internal.h - F
tools/testing/selftests/mm/merge.c - F
tools/testing/vma/
Last 30 days
Most active threads (last 7 days)
-
WARM1d
[PATCH 00/39] mm: make VMA flag semantics explicit, eliminate VM_SPECIAL
2026-09-08 20:19 · 16 replies in 7d · "Lorenzo Stoakes (ARM)" <ljs@kernel.org>
Recent patches
Most-recent 30 patches in this subsystem on linux-doc (capped at 30), ordered by date desc.
-
WARM1d
[PATCH 36/39] mm: eliminate VM_SPECIAL, VMA_SPECIAL_FLAGS
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 27/39] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 26/39] mm: remove hugetlb_inline.h
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 25/39] mm: remove VMA_IO_BIT check in vma[_flags]_is_kernel_owned()
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 24/39] mm/vma: enforce that only kernel-owned mappings may set VMA_IO_BIT
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 23/39] mm/mlock: eliminate weird VMA_IO_BIT abuse and simplify
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 22/39] mm/mlock: clear VMA_LOCKED_MASK over mmap callback
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 16/39] mm/vma: add and use vma_[flags]_is_fixed_mapping
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 15/39] mm/vma: only allow mmap to clear VMA_MAYWRITE_BIT if kernel-owned
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 14/39] mm/vma: add vma[_flags]_is_kernel_owned() predicates
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 07/39] mm: add mmap action for discontiguous kernel page mapping
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 06/39] mm/vma: tidy up map kernel pages enum values
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 04/39] mm/vma: ensure mmap_prepare doesn't set actions on a mergeable vma
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 03/39] mm: consistently validate VMA state after mmap[_prepare] hooks
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 02/39] mm/vma: introduce and use vma_[flags_]can_merge()
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM1d
[PATCH 01/39] mm/vma: predicate setting mmap_prepare VMA fields on new vma alloc
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
COOLING14d
[PATCH 6/6] userfaultfd: collapse VM_UFFD_{MISSING,WP,MINOR,RWP} into single VM_UFFD
2026-08-23 · "Mike Rapoport (Microsoft)" <rppt@kernel.org> -
COOLING14d
[PATCH 4/6] userfaultfd: rename vm_userfaultfd_ctx to vm_uffd_state
2026-08-23 · "Mike Rapoport (Microsoft)" <rppt@kernel.org> -
WARM2d
[PATCH v5 19/36] proc: include N_MEMORY_PRIVATE nodes in numa_maps output
2026-07-20 · Gregory Price <gourry@gourry.net> -
DORMANTno replies
IN MM: 3 (3M) [PATCH v2] mm/mseal: fix mseal documentation for 32-bit kernels
2026-07-15 · Leon Hwang <hidden> -
STALE65d
IN MM: 11 (11M) [PATCH v10 11/15] mm/pagemap: add PAGE_IS_ACCESSED for RWP tracking
2026-07-08 · Kiryl Shutsemau <hidden> -
STALE65d
IN MM: 11 (11M) [PATCH v10 07/15] mm: preserve RWP marker across PTE rewrites
2026-07-08 · Kiryl Shutsemau <hidden> -
STALE65d
IN MM: 12 (12M) [PATCH v10 06/15] mm: add MM_CP_UFFD_RWP change_protection() flag
2026-07-08 · Kiryl Shutsemau <hidden> -
STALE65d
IN MM: 21 (21M) [PATCH v10 05/15] mm: add VM_UFFD_RWP VMA flag
2026-07-08 · Kiryl Shutsemau <hidden> -
STALE65d
IN MM: 12 (12M) [PATCH v10 03/15] mm: rename uffd-wp PTE accessors to uffd
2026-07-08 · Kiryl Shutsemau <hidden> -
STALE68d
REVIEWED: 11 (11M) [PATCH v9 11/15] mm/pagemap: add PAGE_IS_ACCESSED for RWP tracking
2026-07-06 · Kiryl Shutsemau <hidden> -
STALE68d
REVIEWED: 11 (11M) [PATCH v9 07/15] mm: preserve RWP marker across PTE rewrites
2026-07-06 · Kiryl Shutsemau <hidden> -
STALE68d
REVIEWED: 12 (12M) [PATCH v9 06/15] mm: add MM_CP_UFFD_RWP change_protection() flag
2026-07-06 · Kiryl Shutsemau <hidden> -
STALE68d
REVIEWED: 21 (21M) [PATCH v9 05/15] mm: add VM_UFFD_RWP VMA flag
2026-07-06 · Kiryl Shutsemau <hidden> -
STALE68d
REVIEWED: 12 (12M) [PATCH v9 03/15] mm: rename uffd-wp PTE accessors to uffd
2026-07-06 · Kiryl Shutsemau <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE180d
[PATCH 06/15] mm: add mmap_action_simple_ioremap()
2026-03-12 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org> -
STALE180d
[PATCH 12/15] mm: allow handling of stacked mmap_prepare hooks in more drivers
2026-03-12 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org> -
STALE177d
[PATCH v2 01/16] mm: various small mmap_prepare cleanups
2026-03-16 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org> -
STALE177d
[PATCH v2 03/16] mm: document vm_operations_struct->open the same as close()
2026-03-16 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org> -
STALE177d
[PATCH v2 04/16] mm: add vm_ops->mapped hook
2026-03-16 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org> -
STALE177d
[PATCH v4 03/21] mm: swap: add an abstract API for locking out swapoff
2026-03-18 · Nhat Pham <nphamcs@gmail.com> -
STALE176d
[PATCH v3 12/16] mm: allow handling of stacked mmap_prepare hooks in more drivers
2026-03-19 · "Lorenzo Stoakes (Oracle)" <ljs@kernel.org> -
STALE134d
[PATCH v5 03/21] mm: swap: add an abstract API for locking out swapoff
2026-03-20 · Nhat Pham <nphamcs@gmail.com> -
STALE153d
[PATCH RFC 02/13] fs/proc/task_mmu: remove CONFIG_PAGE_MAPCOUNT handling for "mapmax"
2026-04-12 · "David Hildenbrand (Arm)" <david@kernel.org> -
STALE153d
[PATCH RFC 04/13] fs/proc/task_mmu: remove CONFIG_PAGE_MAPCOUNT handling for PM_MMAP_EXCLUSIVE
2026-04-12 · "David Hildenbrand (Arm)" <david@kernel.org>