← All active subsystems in linux-doc
gcc plugins · Maintained
Maintainers
- M Kees Cook <kees@kernel.org>
Paths
- F
Documentation/kbuild/gcc-plugins.rst - F
scripts/Makefile.gcc-plugins - F
scripts/gcc-plugins/
Last 30 days
Recent patches
Most-recent 23 patches in this subsystem on linux-doc, ordered by date desc.
-
STALE449d
LANDED [PATCH v3 03/13] stackleak: Split KSTACK_ERASE_CFLAGS from GCC_PLUGINS_CFLAGS
2025-07-17 · Kees Cook <kees@kernel.org> -
STALE449d
LANDED [PATCH v3 02/13] stackleak: Rename stackleak_track_stack to __sanitizer_cov_stack_depth
2025-07-17 · Kees Cook <kees@kernel.org> -
STALE449d
LANDED [PATCH v3 01/13] stackleak: Rename STACKLEAK to KSTACK_ERASE
2025-07-17 · Kees Cook <kees@kernel.org> -
STALE480d
SUPERSEDED [PATCH v2 03/14] stackleak: Split KSTACK_ERASE_CFLAGS from GCC_PLUGINS_CFLAGS
2025-05-23 · Kees Cook <kees@kernel.org> -
STALE480d
SUPERSEDED [PATCH v2 02/14] stackleak: Rename stackleak_track_stack to __sanitizer_cov_stack_depth
2025-05-23 · Kees Cook <kees@kernel.org> -
STALE480d
SUPERSEDED [PATCH v2 01/14] stackleak: Rename STACKLEAK to KSTACK_ERASE
2025-05-23 · Kees Cook <kees@kernel.org> -
STALE543d
SUPERSEDED [PATCH 5/8] stackleak: Split STACKLEAK_CFLAGS from GCC_PLUGINS_CFLAGS
2025-05-07 · Kees Cook <kees@kernel.org> -
STALE543d
SUPERSEDED [PATCH 4/8] stackleak: Rename stackleak_track_stack to __sanitizer_cov_stack_depth
2025-05-07 · Kees Cook <kees@kernel.org> -
STALE543d
SUPERSEDED [PATCH 3/8] stackleak: Rename CONFIG_GCC_PLUGIN_STACKLEAK to CONFIG_STACKLEAK
2025-05-07 · Kees Cook <kees@kernel.org> -
DORMANTno replies
SUPERSEDED [PATCH RFC 3/4] stackleak: Split STACKLEAK_CFLAGS from GCC_PLUGINS_CFLAGS
2025-05-02 · Kees Cook <kees@kernel.org> -
DORMANTno replies
SUPERSEDED [PATCH RFC 2/4] stackleak: Rename stackleak_track_stack to __sanitizer_cov_stack_depth
2025-05-02 · Kees Cook <kees@kernel.org> -
DORMANTno replies
SUPERSEDED [PATCH RFC 1/4] stackleak: Rename CONFIG_GCC_PLUGIN_STACKLEAK to CONFIG_STACKLEAK
2025-05-02 · Kees Cook <kees@kernel.org> -
STALE535d
[PATCH 1/4] kbuild: require gcc-8 and binutils-2.30
2025-04-07 · Arnd Bergmann <arnd@kernel.org> -
STALE1526d
LANDED [PATCH] docs/core-api: expand Fedora instructions for GCC plugins
2022-08-27 · Robert Elliott <hidden> -
STALE1838d
LANDED [PATCH 2/2] gcc-plugins: Remove cyc_complexity
2021-10-20 · Kees Cook <hidden> -
STALE1838d
LANDED [PATCH 1/2] gcc-plugins: Explicitly document purpose and deprecation schedule
2021-10-20 · Kees Cook <hidden> -
STALE2107d
[PATCH v2] doc: gcc-plugins: drop more stale information
2021-01-23 · Masahiro Yamada <masahiroy@kernel.org> -
DORMANTno replies
[PATCH] doc: gcc-plugins: drop more stale information
2021-01-23 · Masahiro Yamada <masahiroy@kernel.org> -
STALE2109d
[PATCH] Documentation/Kbuild: Remove references to gcc-plugin.sh
2021-01-22 · Robert Karszniewicz <hidden> -
STALE2433d
[PATCH 2/3] docs: move gcc-plugins to the kbuild manual
2020-03-02 · Jonathan Corbet <corbet@lwn.net> -
STALE2318d
[PATCH] gcc-plugins: fix gcc-plugins directory path in documentation
2020-02-13 · Masahiro Yamada <masahiroy@kernel.org> -
STALE2653d
[PATCH 42/43] docs: move gcc_plugins.txt to core-api and rename to .rst
2019-06-28 · Mauro Carvalho Chehab <mchehab+samsung@kernel.org> -
STALE2687d
[PATCH v1 12/22] docs: driver-api: add .rst files from the main dir
2019-06-18 · Mauro Carvalho Chehab <mchehab+samsung@kernel.org>