Reviews by ziy@nvidia.com
· linux-doc
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-doc archive.
100 attestations · capped at 100 most-recent. (21 Acked-by, 79 Reviewed-by)
-
COLD31d
REVIEWED: 3 (3M) Re: [PATCH mm-unstable v19 05/14] mm/khugepaged: require collapse_huge_page to enter/exit with the lock dropped
2026-06-05 · Reviewed-by -
COLD31d
REVIEWED: 3 (3M) Re: [PATCH mm-unstable v19 04/14] mm/khugepaged: generalize __collapse_huge_page_* for mTHP support
2026-06-05 · Reviewed-by -
COLD31d
IN MM: 32 (31M) [PATCH mm-unstable v19 03/14] mm/khugepaged: rework max_ptes_* handling with helper functions
2026-06-05 · Reviewed-by -
COLD31d
IN MM: 35 (33M) [PATCH mm-unstable v19 02/14] mm/khugepaged: generalize alloc_charge_folio()
2026-06-05 · Reviewed-by -
COLD31d
IN MM: 35 (33M) [PATCH mm-unstable v19 01/14] mm/khugepaged: generalize hugepage_vma_revalidate for mTHP support
2026-06-05 · Reviewed-by -
COLD35d
REVIEWED: 3 (3M) Re: [PATCH mm-unstable v18 03/14] mm/khugepaged: rework max_ptes_* handling with helper functions
2026-06-05 · Reviewed-by -
COLD35d
REVIEWED: 35 (33M) [PATCH mm-unstable v18 02/14] mm/khugepaged: generalize alloc_charge_folio()
2026-05-22 · Reviewed-by -
COLD35d
REVIEWED: 35 (33M) [PATCH mm-unstable v18 01/14] mm/khugepaged: generalize hugepage_vma_revalidate for mTHP support
2026-05-22 · Reviewed-by -
COLD46d
REVIEWED: 35 (33M) [PATCH mm-unstable v17 02/14] mm/khugepaged: generalize alloc_charge_folio()
2026-05-11 · Reviewed-by -
COLD46d
REVIEWED: 35 (33M) [PATCH mm-unstable v17 01/14] mm/khugepaged: generalize hugepage_vma_revalidate for mTHP support
2026-05-11 · Reviewed-by -
COLD17d
REVIEWED: 3 (3M) Re: [PATCH] docs/mm: clarify that we are not looking for LLM generated content
2026-04-21 · Acked-by -
STALE63d
REVIEWED: 34 (33M) [PATCH 7.2 v16 02/13] mm/khugepaged: generalize alloc_charge_folio()
2026-04-19 · Reviewed-by -
STALE63d
REVIEWED: 34 (33M) [PATCH 7.2 v16 01/13] mm/khugepaged: generalize hugepage_vma_revalidate for mTHP support
2026-04-19 · Reviewed-by -
STALE121d
REVIEWED: 15 (15M) [PATCH v2] docs: filesystems: clarify KernelPageSize vs. MMUPageSize in smaps
2026-03-06 · Reviewed-by -
STALE127d
REVIEWED: 3 (3M) Re: [PATCH v1] docs: filesystems: clarify KernelPageSize vs. MMUPageSize in smaps
2026-03-04 · Reviewed-by -
STALE72d
REVIEWED: 22 (21M) [PATCHv7 16/18] mm: Remove the branch from compound_head()
2026-02-27 · Reviewed-by -
STALE72d
REVIEWED: 3 (3M) [PATCHv7 08/18] mm/sparse: Check memmap alignment for compound_info_has_mask()
2026-02-27 · Acked-by -
STALE72d
REVIEWED: 23 (21M) [PATCHv7 07/18] mm: Rework compound_head() for power-of-2 sizeof(struct page)
2026-02-27 · Reviewed-by -
STALE72d
REVIEWED: 22 (21M) [PATCHv7 04/18] mm: Move set/clear_compound_head() next to compound_head()
2026-02-27 · Reviewed-by -
STALE72d
REVIEWED: 22 (21M) [PATCHv7 03/18] mm: Rename the 'compound_head' field in the 'struct page' to 'compound_info'
2026-02-27 · Reviewed-by -
STALE72d
REVIEWED: 22 (21M) [PATCHv7 02/18] mm: Change the interface of prep_compound_tail()
2026-02-27 · Reviewed-by -
STALE72d
REVIEWED: 23 (21M) [PATCHv7 01/18] mm: Move MAX_FOLIO_ORDER definition to mmzone.h
2026-02-27 · Acked-by -
STALE72d
REVIEWED: 22 (21M) [PATCHv7 16/18] mm: Remove the branch from compound_head()
2026-02-27 · Reviewed-by -
STALE72d
REVIEWED: 3 (3M) [PATCHv7 08/18] mm/sparse: Check memmap alignment for compound_info_has_mask()
2026-02-27 · Acked-by -
STALE72d
REVIEWED: 23 (21M) [PATCHv7 07/18] mm: Rework compound_head() for power-of-2 sizeof(struct page)
2026-02-27 · Reviewed-by -
STALE72d
REVIEWED: 22 (21M) [PATCHv7 04/18] mm: Move set/clear_compound_head() next to compound_head()
2026-02-27 · Reviewed-by -
STALE72d
REVIEWED: 22 (21M) [PATCHv7 03/18] mm: Rename the 'compound_head' field in the 'struct page' to 'compound_info'
2026-02-27 · Reviewed-by -
STALE72d
REVIEWED: 22 (21M) [PATCHv7 02/18] mm: Change the interface of prep_compound_tail()
2026-02-27 · Reviewed-by -
STALE72d
REVIEWED: 23 (21M) [PATCHv7 01/18] mm: Move MAX_FOLIO_ORDER definition to mmzone.h
2026-02-27 · Acked-by -
STALE85d
REVIEWED: 10 (8M) [PATCH mm-unstable v15 02/13] mm/khugepaged: generalize alloc_charge_folio()
2026-02-26 · Reviewed-by -
STALE85d
REVIEWED: 10 (8M) [PATCH mm-unstable v15 01/13] mm/khugepaged: generalize hugepage_vma_revalidate for mTHP support
2026-02-26 · Reviewed-by -
STALE72d
REVIEWED: 6 (6M) [PATCHv6 15/17] mm: Remove the branch from compound_head()
2026-02-02 · Reviewed-by -
STALE72d
REVIEWED: 3 (3M) [PATCHv6 09/17] mm/sparse: Check memmap alignment for compound_info_has_mask()
2026-02-02 · Acked-by -
STALE72d
REVIEWED: 3 (3M) [PATCHv6 08/17] mm: Make page_zonenum() use head page
2026-02-02 · Acked-by -
STALE72d
REVIEWED: 6 (6M) [PATCHv6 07/17] mm: Rework compound_head() for power-of-2 sizeof(struct page)
2026-02-02 · Reviewed-by -
STALE72d
REVIEWED: 6 (6M) [PATCHv6 04/17] mm: Move set/clear_compound_head() next to compound_head()
2026-02-02 · Reviewed-by -
STALE72d
REVIEWED: 6 (6M) [PATCHv6 03/17] mm: Rename the 'compound_head' field in the 'struct page' to 'compound_info'
2026-02-02 · Reviewed-by -
STALE72d
REVIEWED: 6 (6M) [PATCHv6 02/17] mm: Change the interface of prep_compound_tail()
2026-02-02 · Reviewed-by -
STALE72d
REVIEWED: 21 (21M) [PATCHv6 01/17] mm: Move MAX_FOLIO_ORDER definition to mmzone.h
2026-02-02 · Acked-by -
STALE162d
REVIEWED: 6 (6M) [PATCHv5 15/17] mm: Remove the branch from compound_head()
2026-01-28 · Reviewed-by -
STALE162d
REVIEWED: 3 (3M) [PATCHv5 09/17] mm/sparse: Check memmap alignment for compound_info_has_mask()
2026-01-28 · Acked-by -
STALE162d
REVIEWED: 3 (3M) [PATCHv5 08/17] mm: Make page_zonenum() use head page
2026-01-28 · Acked-by -
STALE162d
REVIEWED: 6 (6M) [PATCHv5 07/17] mm: Rework compound_head() for power-of-2 sizeof(struct page)
2026-01-28 · Reviewed-by -
STALE162d
REVIEWED: 6 (6M) [PATCHv5 04/17] mm: Move set/clear_compound_head() next to compound_head()
2026-01-28 · Reviewed-by -
STALE162d
REVIEWED: 6 (6M) [PATCHv5 03/17] mm: Rename the 'compound_head' field in the 'struct page' to 'compound_info'
2026-01-28 · Reviewed-by -
STALE162d
REVIEWED: 6 (6M) [PATCHv5 02/17] mm: Change the interface of prep_compound_tail()
2026-01-28 · Reviewed-by -
STALE162d
REVIEWED: 21 (21M) [PATCHv5 01/17] mm: Move MAX_FOLIO_ORDER definition to mmzone.h
2026-01-28 · Acked-by -
STALE144d
REVIEWED: 11 (8M) [PATCH mm-unstable v14 05/16] khugepaged: generalize alloc_charge_folio()
2026-01-22 · Reviewed-by -
STALE144d
REVIEWED: 11 (8M) [PATCH mm-unstable v14 04/16] khugepaged: generalize hugepage_vma_revalidate for mTHP support
2026-01-22 · Reviewed-by -
STALE144d
REVIEWED: 11 (8M) [PATCH mm-unstable v14 03/16] introduce collapse_single_pmd to unify khugepaged and madvise_collapse
2026-01-22 · Reviewed-by -
STALE144d
REVIEWED: 12 (8M) [PATCH mm-unstable v14 02/16] khugepaged: rename hpage_collapse_* to collapse_*
2026-01-22 · Reviewed-by -
STALE163d
REVIEWED: 3 (3M) Re: [PATCHv4 13/14] mm: Remove the branch from compound_head()
2026-01-21 · Reviewed-by -
STALE163d
REVIEWED: 3 (3M) Re: [PATCHv4 07/14] mm/sparse: Check memmap alignment for compound_info_has_mask()
2026-01-21 · Acked-by -
STALE163d
REVIEWED: 3 (3M) Re: [PATCHv4 05/14] mm: Rework compound_head() for power-of-2 sizeof(struct page)
2026-01-21 · Reviewed-by -
STALE163d
REVIEWED: 3 (3M) Re: [PATCHv4 04/14] mm: Move set/clear_compound_head() next to compound_head()
2026-01-21 · Reviewed-by -
STALE163d
REVIEWED: 3 (3M) Re: [PATCHv4 03/14] mm: Rename the 'compound_head' field in the 'struct page' to 'compound_info'
2026-01-21 · Reviewed-by -
STALE163d
REVIEWED: 3 (3M) Re: [PATCHv4 02/14] mm: Change the interface of prep_compound_tail()
2026-01-21 · Reviewed-by -
STALE163d
REVIEWED: 3 (3M) Re: [PATCHv4 01/14] mm: Move MAX_FOLIO_ORDER definition to mmzone.h
2026-01-21 · Acked-by -
STALE163d
REVIEWED: 3 (3M) Re: [PATCHv4 06/14] mm: Make page_zonenum() use head page
2026-01-21 · Acked-by -
STALE178d
REVIEWED: 12 (8M) [PATCH v13 mm-new 01/16] khugepaged: rename hpage_collapse_* to collapse_*
2025-12-01 · Reviewed-by -
STALE226d
REVIEWED: 11 (8M) [PATCH v12 mm-new 01/15] khugepaged: rename hpage_collapse_* to collapse_*
2025-10-22 · Reviewed-by -
STALE298d
REVIEWED: 11 (8M) [PATCH v11 01/15] khugepaged: rename hpage_collapse_* to collapse_*
2025-09-12 · Reviewed-by -
STALE302d
REVIEWED: 7 (5M) [PATCH v10 01/13] khugepaged: rename hpage_collapse_* to collapse_*
2025-08-19 · Reviewed-by -
STALE305d
REVIEWED: 4 (3M) [PATCH v5 5/7] selftest/mm: Extract sz2ord function into vm_util.h
2025-08-15 · Reviewed-by -
STALE305d
REVIEWED: 4 (3M) [PATCH v5 4/7] docs: transhuge: document process level THP controls
2025-08-15 · Reviewed-by -
STALE305d
REVIEWED: 6 (5M) [PATCH v5 3/7] mm/huge_memory: respect MADV_COLLAPSE with PR_THP_DISABLE_EXCEPT_ADVISED
2025-08-15 · Reviewed-by -
STALE305d
REVIEWED: 7 (5M) [PATCH v5 2/7] mm/huge_memory: convert "tva_flags" to "enum tva_type"
2025-08-15 · Reviewed-by -
STALE305d
REVIEWED: 6 (3M) [PATCH v5 1/7] prctl: extend PR_SET_THP_DISABLE to optionally exclude VM_HUGEPAGE
2025-08-15 · Acked-by -
STALE329d
REVIEWED: 3 (3M) Re: [PATCH v4 2/7] mm/huge_memory: convert "tva_flags" to "enum tva_type"
2025-08-14 · Reviewed-by -
STALE329d
REVIEWED: 6 (3M) [PATCH v4 1/7] prctl: extend PR_SET_THP_DISABLE to optionally exclude VM_HUGEPAGE
2025-08-13 · Acked-by -
STALE331d
REVIEWED: 6 (3M) [PATCH v3 1/6] prctl: extend PR_SET_THP_DISABLE to optionally exclude VM_HUGEPAGE
2025-08-04 · Acked-by -
STALE350d
REVIEWED: 5 (5M) [PATCH v9 01/14] khugepaged: rename hpage_collapse_* to collapse_*
2025-07-14 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 27/29] docs/mm: convert from "Non-LRU page migration" to "movable_ops page migration"
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 26/29] mm: rename PAGE_MAPPING_* to FOLIO_MAPPING_*
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 25/29] mm: simplify folio_expected_ref_count()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 24/29] mm/page-flags: remove folio_mapping_flags()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 23/29] mm/page-alloc: remove PageMappingFlags()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 22/29] mm/page-flags: rename PAGE_MAPPING_MOVABLE to PAGE_MAPPING_ANON_KSM
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 4 (3M) [PATCH v2 20/29] mm: convert "movable" flag in page->mapping to a page flag
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 21/29] mm: rename PG_isolated to PG_movable_ops_isolated
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 19/29] mm: stop storing migration_ops in page->mapping
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 18/29] mm: remove __folio_test_movable()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 17/29] mm/page_isolation: drop __folio_test_movable() check for large folios
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 16/29] mm: rename __PageMovable() to page_has_movable_ops()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 15/29] mm/migration: remove PageMovable()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 14/29] mm/migrate: remove __ClearPageMovable()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 11/29] mm/migrate: move movable_ops page handling out of move_to_new_folio()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 10/29] mm/migrate: remove folio_test_movable() and folio_movable_ops()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 4 (3M) [PATCH v2 09/29] mm/migrate: factor out movable_ops page handling into migrate_movable_ops_page()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 08/29] mm/migrate: rename putback_movable_folio() to putback_movable_ops_page()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 07/29] mm/migrate: rename isolate_movable_page() to isolate_movable_ops_page()
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 10 (8M) [PATCH v2 06/29] mm/zsmalloc: make PageZsmalloc() sticky until the page is freed
2025-07-04 · Acked-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 05/29] mm/balloon_compaction: make PageOffline sticky until the page is freed
2025-07-04 · Acked-by -
STALE364d
REVIEWED: 5 (3M) [PATCH v2 04/29] mm/page_alloc: let page freeing clear any set page type
2025-07-04 · Reviewed-by -
STALE364d
REVIEWED: 10 (8M) [PATCH v2 03/29] mm/zsmalloc: drop PageIsolated() related VM_BUG_ONs
2025-07-04 · Acked-by -
STALE364d
REVIEWED: 4 (3M) [PATCH v2 01/29] mm/balloon_compaction: we cannot have isolated pages in the balloon list
2025-07-04 · Acked-by -
STALE365d
REVIEWED: 5 (5M) [PATCH v8 01/15] khugepaged: rename hpage_collapse_* to khugepaged_*
2025-07-02 · Reviewed-by -
STALE372d
REVIEWED: 3 (3M) Re: [PATCH v1 08/29] mm/migrate: rename putback_movable_folio() to putback_movable_ops_page()
2025-07-01 · Reviewed-by -
STALE372d
REVIEWED: 3 (3M) [PATCH v1 27/29] docs/mm: convert from "Non-LRU page migration" to "movable_ops page migration"
2025-06-30 · Reviewed-by -
STALE372d
REVIEWED: 3 (3M) [PATCH v1 26/29] mm: rename PAGE_MAPPING_* to FOLIO_MAPPING_*
2025-06-30 · Reviewed-by