Reviews by willy@infradead.org
· linux-doc
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-doc archive.
85 attestations . (9 Acked-by, 1 Co-developed-by, 3 Reported-by, 23 Reviewed-by, 49 Suggested-by)
-
COOLING12d
IN LINUX-NEXT: 32 (32M) [PATCH v9 2/3] mm: rename swap.c to folio.c
2026-07-08 · Suggested-by -
COOLING12d
IN LINUX-NEXT: 24 (24M) [PATCH v9 1/3] mm/swap: colocate page-cluster sysctl with swap readahead
2026-07-08 · Suggested-by -
COOLING13d
REVIEWED: 32 (32M) [PATCH v8 2/3] mm: rename swap.c to folio.c
2026-07-07 · Suggested-by -
COOLING14d
REVIEWED: 32 (32M) [PATCH v7 2/3] mm: rename swap.c to folio.c
2026-07-05 · Suggested-by -
COLD27d
[PATCH v2 05/11] hugetlb: Convert the vmf->pgoff to PAGE_SIZE granularity
2026-06-17 · Suggested-by -
COLD27d
[PATCH v2 04/11] hugetlbfs,filemap: replace hugetlbfs_read_iter() with generic_file_read_iter()
2026-06-17 · Suggested-by -
COLD27d
[PATCH v2 03/11] mm/filemap: add hwpoison handling to filemap_read()
2026-06-17 · Suggested-by -
COLD27d
[PATCH v2 02/11] mm: factor out adjust_range_hwpoison() from hugetlbfs
2026-06-17 · Suggested-by -
STALE156d
REVIEWED: 5 (5M) Re: [PATCH v2] Docs/mm: fix typos and grammar in page_tables.rst
2026-02-09 · Reviewed-by -
STALE180d
[PATCH] docs: filesystems: add fs/open.c to api-summary
2026-01-04 · Suggested-by -
STALE195d
REVIEWED: 5 (5M) Re: [PATCH v2] docs: find-unused-docs.sh: fixup directory usage
2026-01-02 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) Re: [PATCH] scatterlist: fix extraneous '@'-sign kernel-doc notation
2025-06-05 · Reviewed-by -
STALE490d
LANDED [PATCH v2] docs: Remove outdated highuid.rst documentation
2025-03-13 · Suggested-by -
STALE514d
[PATCH v10 12/18] mm: replace vm_lock and detached flag with a reference count
2025-02-13 · Suggested-by -
STALE514d
REVIEWED: 6 (4M) [PATCH v10 06/18] types: move struct rcuwait into types.h
2025-02-13 · Suggested-by -
STALE522d
REVIEWED: 1 (0M) [PATCH v9 11/17] mm: replace vm_lock and detached flag with a reference count
2025-01-11 · Suggested-by -
STALE522d
REVIEWED: 5 (4M) [PATCH v9 06/17] types: move struct rcuwait into types.h
2025-01-11 · Suggested-by -
STALE551d
[PATCH v8 11/16] mm: replace vm_lock and detached flag with a reference count
2025-01-09 · Suggested-by -
STALE551d
REVIEWED: 5 (4M) [PATCH v8 06/16] types: move struct rcuwait into types.h
2025-01-09 · Suggested-by -
STALE468d
[PATCH v7 12/17] mm: replace vm_lock and detached flag with a reference count
2024-12-26 · Suggested-by -
STALE468d
[PATCH v7 07/17] types: move struct rcuwait into types.h
2024-12-26 · Suggested-by -
STALE571d
[PATCH v6 10/16] mm: replace vm_lock and detached flag with a reference count
2024-12-16 · Suggested-by -
STALE571d
[PATCH v6 05/16] types: move struct rcuwait into types.h
2024-12-16 · Suggested-by -
STALE721d
REVIEWED: 5 (5M) Re: [PATCH] docs/core-api: memory-allocation: GFP_NOWAIT doesn't need __GFP_NOWARN
2024-07-29 · Reviewed-by -
STALE854d
REVIEWED: 5 (5M) Re: [PATCH] doc: Fix typo in admin-guide/cifs/introduction.rst
2024-03-12 · Reviewed-by -
STALE902d
LANDED [PATCH 2/2] scripts/kernel-doc: Do not process backslash lines in comments
2024-01-22 · Suggested-by -
STALE910d
[RFC PATCH 2/2] scripts/kernel-doc: Do not process backslash lines in comments
2024-01-16 · Suggested-by -
STALE948d
[PATCH] Documentation/mm: Describe folios in physical_memory.rst
2023-12-15 · Suggested-by -
STALE1231d
REVIEWED: 5 (5M) Re: [PATCH] docs: Correct missing "d_" prefix for dentry_operations member d_weak_revalidate
2023-02-27 · Reviewed-by -
DORMANTno replies
REVIEWED: 4 (2M) [PATCH v3] docs: rename Documentation/vm to Documentation/mm
2022-06-27 · Suggested-by -
STALE1485d
REVIEWED: 3 (2M) [PATCH v2] docs: rename Documentation/vm to Documentation/mm
2022-06-26 · Suggested-by -
STALE1484d
[PATCH] docs: rename Documentation/vm to Documentation/mm
2022-06-22 · Suggested-by -
STALE1547d
[PATCH 1/4] mm/highmem: Fix kernel-doc warnings in highmem*.h
2022-04-21 · Suggested-by -
STALE1611d
REVIEWED: 5 (5M) Re: [PATCH] Correct documentation comments for x86 csum_and_copy_...user()
2022-02-18 · Reviewed-by -
STALE1643d
[PATCH v3 01/19] kallsyms: support "big" kernel symbols
2022-01-17 · Co-developed-by -
STALE1729d
[PATCH v2] workqueue: doc: Call out the non-reentrance conditions
2021-10-22 · Suggested-by -
STALE1742d
LANDED [PATCH] scripts: kernel-doc: Ignore __alloc_size() attribute
2021-10-11 · Suggested-by -
STALE1744d
[PATCH v7 2/5] d_path: introduce helper d_path_unsafe()
2021-07-15 · Suggested-by -
STALE1832d
[PATCH v2 1/4] fs: introduce helper d_path_unsafe()
2021-06-23 · Suggested-by -
STALE1852d
[PATCH v5 1/4] fs: introduce helper d_path_unsafe()
2021-06-22 · Suggested-by -
STALE1470d
[PATCH RFCv4 1/4] fs: introduce helper d_path_unsafe()
2021-06-15 · Suggested-by -
STALE1861d
[PATCH RFCv3 1/3] fs: introduce helper d_path_unsafe()
2021-06-11 · Suggested-by -
STALE1862d
[RFC PATCH 2/2] XArray: Remove literal markup from known constants
2021-06-09 · Suggested-by -
STALE1862d
[RFC PATCH 1/2] docs: automarkup.py: Add literal markup of known constants
2021-06-09 · Suggested-by -
STALE1880d
LANDED [PATCH 2/2] iio: ABI: sysfs-bus-iio: avoid a warning when doc is built
2021-05-25 · Reported-by -
STALE1897d
REVIEWED: 5 (5M) Re: [PATCH] Documentation: drop optional BOMs
2021-05-07 · Reviewed-by -
STALE1911d
REVIEWED: 6 (5M) [PATCH v2 1/2] mm/mmzone.h: fix existing kernel-doc comments and link them to core-api
2021-04-26 · Reviewed-by -
STALE1912d
REVIEWED: 5 (5M) Re: [PATCH 1/2] mm/mmzone.h: fix existing kernel-doc comments and link them to core-api
2021-04-24 · Reviewed-by -
STALE1914d
REVIEWED: 5 (5M) Re: [PATCH v3] docs: proc.rst: meminfo: briefly describe gaps in memory accounting
2021-04-21 · Reviewed-by -
STALE1930d
REVIEWED: 5 (5M) Re: [PATCH] printk: clarify the documentation for plain pointer printing
2021-02-25 · Reviewed-by -
STALE2002d
REVIEWED: 4 (4M) [PATCH v3 7/7] bio: don't copy bvec for direct IO
2021-01-09 · Suggested-by -
STALE2023d
[PATCH v2 7/7] bio: don't copy bvec for direct IO
2021-01-02 · Suggested-by -
STALE2034d
[PATCH v1 6/6] block/iomap: don't copy bvec for direct IO
2020-12-15 · Suggested-by -
STALE2091d
LANDED: 5 (5M) [PATCH v3 13/32] mm: pagemap.h: fix two kernel-doc markups
2020-10-27 · Reviewed-by -
STALE2098d
REVIEWED: 5 (5M) Re: [PATCH v2 10/24] mm: pagemap.h: fix two kernel-doc markups
2020-10-21 · Reviewed-by -
STALE2111d
[PATCH v3] script: add a script for checking doc problems with external functions
2020-10-07 · Suggested-by -
STALE2111d
[PATCH v2] script: add a script for checking doc problems with external functions
2020-10-07 · Suggested-by -
STALE2112d
[PATCH RFC] script: add a script for checking doc problems with external functions
2020-10-06 · Suggested-by -
STALE2169d
REVIEWED: 5 (5M) Re: [PATCH] Core-api: Documentation: Replace deprecated :c:func: Usage
2020-08-10 · Reviewed-by -
STALE2198d
REVIEWED: 5 (5M) Re: [PATCH 00/11] Documentation: userspace-api/media: eliminate duplicated words
2020-07-04 · Reviewed-by -
STALE2257d
REVIEWED: 5 (5M) Re: [PATCH v2] doc: Fix some errors in ras.rst
2020-05-06 · Reviewed-by -
STALE2302d
REVIEWED: 5 (5M) Re: [PATCH v3 1/1] A compact idiom to add code examples in kerneldoc comments.
2020-03-26 · Reviewed-by -
STALE2321d
REVIEWED: 5 (5M) Re: [PATCH v2] Document genhd capability flags
2020-03-07 · Reviewed-by -
DORMANTno replies
[PATCH] mm/gup: fixup for ce35133be382 mm/gup: track FOLL_PIN pages
2020-03-07 · Reported-by -
STALE2352d
REVIEWED: 1 (0M) [PATCH v5 01/12] mm: dump_page(): better diagnostics for compound pages
2020-02-07 · Suggested-by -
STALE2357d
REVIEWED: 1 (0M) [PATCH v4 01/12] mm: dump_page(): better diagnostics for compound pages
2020-02-04 · Suggested-by -
STALE2359d
[PATCH v3 01/12] mm: dump_page(): better diagnostics for compound pages
2020-02-01 · Suggested-by -
DORMANTno replies
REVIEWED: 5 (5M) Re: [PATCH v2] Add a maintainer entry profile for documentation
2020-01-23 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) Re: [PATCH v2] Add a document on how to contribute to the documentation
2020-01-23 · Reviewed-by -
STALE2456d
REVIEWED: 5 (5M) Re: [PATCH v3 0/3] docs/core-api: memory-allocation: minor cleanups
2019-10-24 · Reviewed-by -
STALE2562d
REVIEWED: 5 (5M) Re: [PATCH v8] Documentation: filesystem: Convert xfs.txt to ReST
2019-07-15 · Reviewed-by -
STALE2581d
REVIEWED: 5 (5M) [PATCH v3 2/4] docs: remove :c:func: annotations from xarray.rst
2019-06-26 · Acked-by -
STALE2583d
REVIEWED: 5 (5M) [PATCH 2/3] docs: remove :c:func: annotations from xarray.rst
2019-06-21 · Acked-by -
STALE2642d
REVIEWED: 5 (5M) Re: [PATCH 2/2] docs: remove :c:func: annotations from xarray.rst
2019-04-25 · Acked-by -
STALE2665d
REVIEWED: 2 (2M) [RESEND PATCH 2/3] ipc: Conserve sequence numbers in ipcmni_extend mode
2019-03-29 · Suggested-by -
STALE2681d
[PATCH v12 2/3] ipc: Conserve sequence numbers in ipcmni_extend mode
2019-02-28 · Suggested-by -
STALE2705d
[PATCH] Documentation: fix admin-guide/README.rst minimum gcc version requirement
2019-02-21 · Suggested-by -
STALE2710d
[PATCH] docs: kernel-doc: typo "if ... if" -> "if ... is"
2019-02-11 · Reported-by -
STALE2744d
REVIEWED: 5 (5M) [PATCH v2] docs-rst: doc-guide: Minor grammar fixes
2019-01-14 · Acked-by -
STALE2744d
[PATCH] Documentation/sysctl/vm.txt: Fix drop_caches bit number
2019-01-11 · Suggested-by -
STALE2942d
REVIEWED: 5 (5M) [PATCH v3 1/2] Documentation/sphinx: allow "functions" with no parameters
2018-06-29 · Acked-by -
STALE2942d
REVIEWED: 5 (5M) [PATCH v3 2/2] docs/idr: use empty "functions" directive
2018-06-29 · Acked-by -
STALE2946d
REVIEWED: 5 (5M) [PATCH v2 1/2] Documentation/sphinx: allow "functions" with no parameters
2018-06-20 · Acked-by -
STALE2946d
REVIEWED: 5 (5M) [PATCH v2 2/2] docs/idr: use empty "functions" directive
2018-06-20 · Acked-by -
STALE2953d
REVIEWED: 5 (5M) Re: [PATCH 0/2] Documentation/sphinx: add "nodocs" directive
2018-06-18 · Acked-by