Reviews by mark.rutland@arm.com
· linux-doc
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-doc archive.
100 attestations · capped at 100 most-recent. (74 Acked-by, 5 Co-developed-by, 4 Reported-by, 6 Reviewed-by, 9 Suggested-by, 2 Tested-by)
-
HOTtoday
REVIEWED: 7 (7M) Re: [PATCH v13 02/32] arm64/fpsimd: Ensure all of ZCR_EL1 is initialised from idle
2026-07-23 · Acked-by -
WARM3d
[patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
2026-07-07 · Suggested-by -
COLD17d
[PATCH 02/17] arm64: Rework exception masking into abstract logical mask
2026-07-03 · Suggested-by -
HOTtoday
REVIEWED: 7 (7M) [PATCH 04/21] perf: arm_pmuv3: Generalize counter bitmasks
2026-06-12 · Acked-by -
HOTtoday
REVIEWED: 9 (9M) [PATCH 01/21] arm64: cpufeature: Add cpucap for HPMN0
2026-06-12 · Acked-by -
COLD44d
REVIEWED: 7 (7M) Re: [PATCH v1] arm64: errata: Mitigate TLBI errata on NVIDIA Olympus CPU
2026-06-10 · Acked-by -
COLD35d
REVIEWED: 7 (7M) [PATCH v7 04/20] perf: arm_pmuv3: Generalize counter bitmasks
2026-05-04 · Acked-by -
COLD35d
REVIEWED: 9 (9M) [PATCH v7 01/20] arm64: cpufeature: Add cpucap for HPMN0
2026-05-04 · Acked-by -
STALE134d
REVIEWED: 7 (7M) [PATCH v6 05/19] perf: arm_pmuv3: Generalize counter bitmasks
2026-02-09 · Acked-by -
STALE134d
REVIEWED: 9 (9M) [PATCH v6 01/19] arm64: cpufeature: Add cpucap for HPMN0
2026-02-09 · Acked-by -
STALE190d
REVIEWED: 7 (7M) [PATCH v5 08/24] perf: arm_pmuv3: Generalize counter bitmasks
2025-12-09 · Acked-by -
STALE190d
REVIEWED: 7 (7M) [PATCH v5 01/24] arm64: cpufeature: Add cpucap for HPMN0
2025-12-09 · Acked-by -
STALE365d
REVIEWED: 7 (7M) Re: [PATCH] Documentation: core-api: entry: Replace deprecated KVM entry/exit functions
2025-07-23 · Acked-by -
STALE275d
REVIEWED: 7 (7M) [PATCH v4 05/23] perf: arm_pmuv3: Generalize counter bitmasks
2025-07-14 · Acked-by -
STALE275d
REVIEWED: 7 (7M) [PATCH v4 01/23] arm64: cpufeature: Add cpucap for HPMN0
2025-07-14 · Acked-by -
STALE381d
REVIEWED: 7 (7M) Re: [PATCH v3 07/22] perf: arm_pmuv3: Generalize counter bitmasks
2025-07-07 · Acked-by -
STALE381d
REVIEWED: 7 (7M) Re: [PATCH v3 01/22] arm64: cpufeature: Add cpucap for HPMN0
2025-07-07 · Acked-by -
STALE380d
REVIEWED: 7 (7M) Re: [PATCH v23 0/4] arm64/perf: Enable branch stack sampling
2025-07-04 · Acked-by -
STALE380d
LANDED: 3 (3M) [PATCH v23 4/4] perf: arm_pmuv3: Add support for the Branch Record Buffer Extension (BRBE)
2025-06-11 · Co-developed-by -
STALE420d
REVIEWED: 3 (3M) [PATCH v22 5/5] perf: arm_pmuv3: Add support for the Branch Record Buffer Extension (BRBE)
2025-05-20 · Co-developed-by -
STALE434d
REVIEWED: 7 (7M) Re: [PATCH 0/4] Make gcc-8.1 and binutils-2.30 the minimum version
2025-04-08 · Acked-by -
STALE434d
REVIEWED: 7 (7M) Re: [PATCH 4/4] arm64: drop binutils version checks
2025-04-08 · Acked-by -
STALE422d
REVIEWED: 3 (3M) [PATCH v21 4/4] perf: arm_pmuv3: Add support for the Branch Record Buffer Extension (BRBE)
2025-04-07 · Co-developed-by -
STALE476d
[PATCH v20 11/11] perf: arm_pmuv3: Add support for the Branch Record Buffer Extension (BRBE)
2025-02-18 · Co-developed-by -
STALE521d
[PATCH v19 11/11] perf: arm_pmuv3: Add support for the Branch Record Buffer Extension (BRBE)
2025-02-03 · Co-developed-by -
STALE582d
REVIEWED: 7 (7M) Re: [RFC PATCH 02/28] Documentation: Bump minimum GCC version to 8.1
2024-09-27 · Acked-by -
STALE800d
REVIEWED: 8 (8M) [PATCH memory-model 3/4] Documentation/atomic_t: Emphasize that failed atomic operations give no ordering
2024-05-01 · Acked-by -
STALE800d
REVIEWED: 8 (8M) [PATCH memory-model 3/3] Documentation/atomic_t: Emphasize that failed atomic operations give no ordering
2024-04-04 · Acked-by -
STALE875d
LANDED: 1 (1M) [PATCH v6] bpf: Replace bpf_lpm_trie_key 0-length array with flexible array
2024-02-22 · Reported-by -
STALE883d
REVIEWED: 1 (1M) [PATCH v5] bpf: Replace bpf_lpm_trie_key 0-length array with flexible array
2024-02-21 · Reported-by -
STALE883d
REVIEWED: 1 (1M) [PATCH v4] bpf: Replace bpf_lpm_trie_key 0-length array with flexible array
2024-02-20 · Reported-by -
STALE884d
[PATCH v3] bpf: Replace bpf_lpm_trie_key 0-length array with flexible array
2024-02-19 · Reported-by -
STALE890d
REVIEWED: 7 (7M) Re: [PATCH v2] arm64: Subscribe Microsoft Azure Cobalt 100 to ARM Neoverse N2 errata
2024-02-14 · Acked-by -
STALE905d
REVIEWED: 7 (7M) Re: [PATCH doc] Emphasize that failed atomic operations give no ordering
2024-01-30 · Acked-by -
STALE1134d
REVIEWED: 7 (7M) Re: [PATCH v5 1/3] drivers/perf: hisi: Add support for HiSilicon H60PA and PAv3 PMU driver
2023-06-16 · Acked-by -
STALE1134d
LANDED: 9 (9M) [PATCH v5 2/3] drivers/perf: hisi: Add support for HiSilicon UC PMU driver
2023-06-15 · Acked-by -
STALE1134d
LANDED: 9 (8M) [PATCH v5 3/3] docs: perf: Add new description for HiSilicon UC PMU
2023-06-15 · Acked-by -
STALE1123d
REVIEWED: 7 (7M) Re: [PATCH RFC 01/17] arm64: consolidate rox page protection logic
2023-06-12 · Acked-by -
STALE1135d
REVIEWED: 7 (7M) Re: [PATCH v4 3/3] docs: perf: Add new description for HiSilicon UC PMU
2023-06-09 · Acked-by -
STALE1135d
REVIEWED: 7 (7M) Re: [PATCH v4 2/3] drivers/perf: hisi: Add support for HiSilicon UC PMU driver
2023-06-09 · Acked-by -
STALE1141d
REVIEWED: 7 (7M) Re: [PATCH] drivers/perf: hisi: Don't migrate perf to the CPU going to teardown
2023-06-08 · Acked-by -
STALE1141d
REVIEWED: 7 (7M) Re: [PATCH v2 07/12] parisc/percpu: Work around the lack of __SIZEOF_INT128__
2023-06-02 · Tested-by -
STALE1141d
REVIEWED: 14 (14M) Re: [PATCH 00/12] Introduce cmpxchg128() -- aka. the demise of cmpxchg_double()
2023-05-31 · Reviewed-by -
STALE1141d
REVIEWED: 14 (14M) Re: [PATCH 00/12] Introduce cmpxchg128() -- aka. the demise of cmpxchg_double()
2023-05-31 · Tested-by -
STALE1141d
LANDED: 12 (12M) [PATCH 04/12] instrumentation: Wire up cmpxchg128()
2023-05-31 · Acked-by -
STALE1141d
LANDED: 14 (14M) [PATCH 03/12] arch: Introduce arch_{,try_}_cmpxchg128{,_local}()
2023-05-31 · Acked-by -
STALE1150d
REVIEWED: 7 (7M) [PATCH v3 04/11] instrumentation: Wire up cmpxchg128()
2023-05-15 · Acked-by -
STALE1150d
REVIEWED: 9 (9M) [PATCH v3 03/11] arch: Introduce arch_{,try_}_cmpxchg128{,_local}()
2023-05-15 · Acked-by -
STALE1262d
REVIEWED: 7 (7M) Re: [PATCH v2 05/10] percpu: Wire up cmpxchg128
2023-02-03 · Acked-by -
STALE1262d
REVIEWED: 7 (7M) Re: [PATCH v2 04/10] instrumentation: Wire up cmpxchg128()
2023-02-03 · Acked-by -
STALE1262d
REVIEWED: 7 (7M) Re: [PATCH v2 03/10] arch: Introduce arch_{,try_}_cmpxchg128{,_local}()
2023-02-03 · Acked-by -
STALE1619d
REVIEWED: 7 (7M) Re: [PATCH 1/2] arm64: booting.rst: Clarify on requiring non-secure EL2
2022-01-07 · Reviewed-by -
STALE1695d
LANDED [PATCH v2] arm64: update PAC description for kernel
2021-12-01 · Suggested-by -
STALE1690d
REVIEWED: 7 (7M) [PATCH v3 02/25] kcsan: Remove redundant zero-initialization of globals
2021-11-30 · Acked-by -
STALE1690d
REVIEWED: 7 (7M) [PATCH v3 01/25] kcsan: Refactor reading of instrumented memory
2021-11-30 · Acked-by -
STALE1697d
REVIEWED: 7 (7M) Re: [PATCH v2 02/23] kcsan: Remove redundant zero-initialization of globals
2021-11-18 · Acked-by -
STALE1697d
REVIEWED: 7 (7M) Re: [PATCH v2 01/23] kcsan: Refactor reading of instrumented memory
2021-11-18 · Acked-by -
STALE1855d
REVIEWED: 7 (7M) Re: [PATCH v2 3/3] Kconfig: add ARCH_WANTS_NO_INSTR+CC_HAS_NO_PROFILE_FN_ATTR, depend on for GCOV and PGO
2021-06-22 · Acked-by -
STALE2053d
REVIEWED: 7 (7M) Re: [PATCH v4 06/26] psci: Add accessor for psci_0_1_function_ids
2020-12-03 · Acked-by -
STALE2053d
REVIEWED: 7 (7M) Re: [PATCH v4 05/26] psci: Replace psci_function_id array with a struct
2020-12-03 · Acked-by -
STALE2053d
REVIEWED: 7 (7M) Re: [PATCH v4 04/26] psci: Split functions to v0.1 and v0.2+ variants
2020-12-03 · Acked-by -
STALE2053d
LANDED: 7 (7M) [PATCH v4 03/26] psci: Support psci_ops.get_version for v0.1
2020-12-02 · Acked-by -
STALE2059d
REVIEWED: 7 (7M) Re: [PATCH v3 01/23] psci: Support psci_ops.get_version for v0.1
2020-11-26 · Acked-by -
STALE2088d
REVIEWED: 7 (7M) Re: [PATCH v7 3/9] arm64, kfence: enable KFENCE for ARM64
2020-11-04 · Reviewed-by -
STALE2382d
REVIEWED: 15 (15M) [PATCH v4 09/10] locking/atomics, kcsan: Add KCSAN instrumentation
2019-11-14 · Reviewed-by -
STALE2443d
REVIEWED: 7 (7M) [PATCH v3 8/9] locking/atomics, kcsan: Add KCSAN instrumentation
2019-11-04 · Reviewed-by -
STALE2464d
REVIEWED: 7 (7M) Re: [PATCH v2 7/8] locking/atomics, kcsan: Add KCSAN instrumentation
2019-10-22 · Reviewed-by -
STALE2598d
REVIEWED: 7 (7M) [PATCH v4 1/3] lib/test_kasan: Add bitops tests
2019-06-13 · Acked-by -
STALE2598d
REVIEWED: 8 (7M) [PATCH v4 3/3] asm-generic, x86: Add bitops instrumentation for KASAN
2019-06-13 · Acked-by -
STALE2594d
REVIEWED: 8 (7M) [PATCH v5 1/3] lib/test_kasan: Add bitops tests
2019-06-13 · Acked-by -
STALE2594d
REVIEWED: 8 (7M) [PATCH v5 3/3] asm-generic, x86: Add bitops instrumentation for KASAN
2019-06-13 · Acked-by -
STALE2598d
REVIEWED: 7 (7M) Re: [PATCH v3 3/3] asm-generic, x86: Add bitops instrumentation for KASAN
2019-05-31 · Acked-by -
STALE2598d
REVIEWED: 7 (7M) Re: [PATCH v3 1/3] lib/test_kasan: Add bitops tests
2019-05-31 · Acked-by -
STALE2775d
REVIEWED: 7 (7M) [PATCH v13 09/25] arm64: move untagged_addr macro from uaccess.h to memory.h
2018-12-06 · Acked-by -
STALE2775d
[PATCH v13 07/25] kasan: rename kasan_zero_page to kasan_early_shadow_page
2018-12-06 · Suggested-by -
STALE2775d
[PATCH v13 13/25] kasan, arm64: fix up fault handling logic
2018-12-06 · Suggested-by -
STALE2787d
REVIEWED: 7 (7M) [PATCH v12 09/25] arm64: move untagged_addr macro from uaccess.h to memory.h
2018-11-27 · Acked-by -
STALE2787d
[PATCH v12 07/25] kasan: rename kasan_zero_page to kasan_early_shadow_page
2018-11-27 · Suggested-by -
STALE2787d
[PATCH v12 13/25] kasan, arm64: fix up fault handling logic
2018-11-27 · Suggested-by -
STALE2796d
REVIEWED: 7 (7M) Re: [PATCH v11 09/24] arm64: move untagged_addr macro from uaccess.h to memory.h
2018-11-23 · Acked-by -
STALE2796d
[PATCH v11 13/24] kasan, arm64: fix up fault handling logic
2018-11-19 · Suggested-by -
STALE2796d
[PATCH v11 07/24] kasan: rename kasan_zero_page to kasan_early_shadow_page
2018-11-19 · Suggested-by -
STALE2817d
REVIEWED: 8 (7M) [PATCH V8 10/11] misc/pvpanic: convert to SPDX license tags
2018-11-06 · Acked-by -
STALE2817d
REVIEWED: 7 (7M) [PATCH V8 05/11] misc/pvpanic: add support to get pvpanic device info FDT
2018-11-06 · Acked-by -
STALE2817d
REVIEWED: 8 (7M) [PATCH V8 03/11] misc/pvpanic: add MMIO support
2018-11-06 · Acked-by -
STALE2817d
REVIEWED: 8 (7M) [PATCH v8 02/11] misc/pvpanic: simplify the code using acpi_dev_resource_io
2018-11-06 · Acked-by -
STALE2817d
REVIEWED: 8 (7M) [PATCH V8 11/11] misc/pvpanic: remove a redundant comma
2018-11-06 · Acked-by -
STALE2817d
REVIEWED: 7 (7M) [PATCH V8 04/11] dt-bindings: misc/pvpanic: add document for pvpanic-mmio
2018-11-06 · Acked-by -
STALE2817d
REVIEWED: 8 (7M) [PATCH V8 08/11] misc/pvpanic: remove unnecessary header file
2018-11-06 · Acked-by -
STALE2817d
REVIEWED: 8 (7M) [PATCH V8 01/11] pvpanic: move pvpanic to misc as common driver
2018-11-06 · Acked-by -
STALE2818d
REVIEWED: 7 (7M) [PATCH V7 4/9] dt-bindings: misc/pvpanic: add document for pvpanic-mmio
2018-11-05 · Acked-by -
STALE2818d
REVIEWED: 8 (7M) [PATCH V7 3/9] misc/pvpanic: add MMIO support
2018-11-05 · Acked-by -
STALE2818d
REVIEWED: 7 (7M) [PATCH V7 9/9] misc/pvpanic: remove a redundant comma
2018-11-05 · Acked-by -
STALE2818d
REVIEWED: 8 (7M) [PATCH V7 1/9] pvpanic: move pvpanic to misc as common driver
2018-11-05 · Acked-by -
STALE2818d
REVIEWED: 8 (7M) [PATCH V7 7/9] misc/pvpanic: remove unnecessary header file
2018-11-05 · Acked-by -
STALE2818d
REVIEWED: 8 (7M) [PATCH V7 8/9] misc/pvpanic: convert to SPDX license tags
2018-11-05 · Acked-by -
STALE2818d
REVIEWED: 7 (7M) [PATCH V7 5/9] misc/pvpanic: add support to get pvpanic device info by FDT
2018-11-05 · Acked-by -
STALE2818d
REVIEWED: 8 (7M) [PATCH V7 2/9] misc/pvpanic: simplify the code using acpi_dev_resource_io
2018-11-05 · Acked-by -
STALE2821d
REVIEWED: 8 (7M) [PATCH V6 6/8] misc/pvpanic: remove unnecessary header file
2018-11-02 · Acked-by -
STALE2821d
REVIEWED: 8 (7M) [PATCH V6 7/8] misc/pvpanic: convert to SPDX license tags
2018-11-02 · Acked-by