Not all OPP entries fit into a single word. In particular NVIDIA Tegra OPP
tables use multi-word names where first part is freq and second voltage
because different hardware versions use different voltages for the same
freqs. Allow OPP entry to have multi-worded name separated by hyphen.
This silences DT checker warnings about wrong naming scheme.
Reviewed-by: David Heidelberg <david@ixit.cz>
Signed-off-by: Dmitry Osipenko <digetx@gmail.com>
---
Changelog:
v3: - Viresh Kumar suggested that we shouldn't support postfix variant.
I dropped variant with postfix naming scheme and multi-wording
support of table names.
v2: - In addition to a multi-wording support, support of the postfix
*-opp-table naming scheme is added to the updated pattern.
Documentation/devicetree/bindings/opp/opp-v2-base.yaml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@@ -33,7 +33,7 @@ properties:type:booleanpatternProperties:-'^opp-?[0-9]+$':+'^opp(-[0-9]+)*$':type:objectdescription:One or more OPP nodes describing voltage-current-frequency combinations.
Not all OPP entries fit into a single word. In particular NVIDIA Tegra OPP
tables use multi-word names where first part is freq and second voltage
because different hardware versions use different voltages for the same
freqs. Allow OPP entry to have multi-worded name separated by hyphen.
This silences DT checker warnings about wrong naming scheme.
Reviewed-by: David Heidelberg <david@ixit.cz>
Signed-off-by: Dmitry Osipenko <digetx@gmail.com>
---
Changelog:
v3: - Viresh Kumar suggested that we shouldn't support postfix variant.
I dropped variant with postfix naming scheme and multi-wording
support of table names.
v2: - In addition to a multi-wording support, support of the postfix
*-opp-table naming scheme is added to the updated pattern.
Documentation/devicetree/bindings/opp/opp-v2-base.yaml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@@ -33,7 +33,7 @@ properties:type:booleanpatternProperties:-'^opp-?[0-9]+$':+'^opp(-[0-9]+)*$':type:objectdescription:One or more OPP nodes describing voltage-current-frequency combinations.
From: Rob Herring <robh@kernel.org> Date: 2021-10-27 21:21:21
On Mon, Oct 25, 2021 at 12:57:18AM +0300, Dmitry Osipenko wrote:
quoted hunk
Not all OPP entries fit into a single word. In particular NVIDIA Tegra OPP
tables use multi-word names where first part is freq and second voltage
because different hardware versions use different voltages for the same
freqs. Allow OPP entry to have multi-worded name separated by hyphen.
This silences DT checker warnings about wrong naming scheme.
Reviewed-by: David Heidelberg <david@ixit.cz>
Signed-off-by: Dmitry Osipenko <digetx@gmail.com>
---
Changelog:
v3: - Viresh Kumar suggested that we shouldn't support postfix variant.
I dropped variant with postfix naming scheme and multi-wording
support of table names.
v2: - In addition to a multi-wording support, support of the postfix
*-opp-table naming scheme is added to the updated pattern.
Documentation/devicetree/bindings/opp/opp-v2-base.yaml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
This drops support for cases like 'opp1' which there are a ton of. It
should be '^opp(-?[0-9]+)*$' if we want to keep that support.
I'd love to be stricter, but trying to find a balance.
Rob
On Mon, Oct 25, 2021 at 12:57:18AM +0300, Dmitry Osipenko wrote:
quoted
Not all OPP entries fit into a single word. In particular NVIDIA Tegra OPP
tables use multi-word names where first part is freq and second voltage
because different hardware versions use different voltages for the same
freqs. Allow OPP entry to have multi-worded name separated by hyphen.
This silences DT checker warnings about wrong naming scheme.
Reviewed-by: David Heidelberg <david@ixit.cz>
Signed-off-by: Dmitry Osipenko <digetx@gmail.com>
---
Changelog:
v3: - Viresh Kumar suggested that we shouldn't support postfix variant.
I dropped variant with postfix naming scheme and multi-wording
support of table names.
v2: - In addition to a multi-wording support, support of the postfix
*-opp-table naming scheme is added to the updated pattern.
Documentation/devicetree/bindings/opp/opp-v2-base.yaml | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
This drops support for cases like 'opp1' which there are a ton of. It
should be '^opp(-?[0-9]+)*$' if we want to keep that support.
I'd love to be stricter, but trying to find a balance.