[PATCH] of: fdt: Rename reserve_elfcorehdr() to fdt_reserve_elfcorehdr()

Subsystems: open firmware and flattened device tree, the rest

STALE1876d LANDED

Landed in mainline as 2fcf9a178ba1 on 2021-08-25.

5 messages, 4 authors, 2021-08-25 · open the first message on its own page

[PATCH] of: fdt: Rename reserve_elfcorehdr() to fdt_reserve_elfcorehdr()

From: Geert Uytterhoeven <geert+renesas@glider.be>
Date: 2021-08-25 09:40:49

On ia64/allmodconfig:

    drivers/of/fdt.c:609:20: error: conflicting types for 'reserve_elfcorehdr'; have 'void(void)'
      609 | static void __init reserve_elfcorehdr(void)
	  |                    ^~~~~~~~~~~~~~~~~~
    arch/ia64/include/asm/meminit.h:43:12: note: previous declaration of 'reserve_elfcorehdr' with type 'int(u64 *, u64 *)' {aka 'int(long long unsigned int *, long long unsigned int *)'}
       43 | extern int reserve_elfcorehdr(u64 *start, u64 *end);
	  |            ^~~~~~~~~~~~~~~~~~

Fix this by prefixing the FDT function name with "fdt_".

Fixes: f7e7ce93aac13118 ("of: fdt: Add generic support for handling elf core headers property")
Reported-by: kernel test robot <redacted>
Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
---
This change was planned for v6.
Feel free to fold into the original.
---
 drivers/of/fdt.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/of/fdt.c b/drivers/of/fdt.c
index a26199022d2fc54d..4546572af24bbf14 100644
--- a/drivers/of/fdt.c
+++ b/drivers/of/fdt.c
@@ -599,14 +599,14 @@ static int __init __fdt_scan_reserved_mem(unsigned long node, const char *uname,
 }
 
 /*
- * reserve_elfcorehdr() - reserves memory for elf core header
+ * fdt_reserve_elfcorehdr() - reserves memory for elf core header
  *
  * This function reserves the memory occupied by an elf core header
  * described in the device tree. This region contains all the
  * information about primary kernel's core image and is used by a dump
  * capture kernel to access the system memory on primary kernel.
  */
-static void __init reserve_elfcorehdr(void)
+static void __init fdt_reserve_elfcorehdr(void)
 {
 	if (!IS_ENABLED(CONFIG_CRASH_DUMP) || !elfcorehdr_size)
 		return;
@@ -647,7 +647,7 @@ void __init early_init_fdt_scan_reserved_mem(void)
 
 	of_scan_flat_dt(__fdt_scan_reserved_mem, NULL);
 	fdt_init_reserved_mem();
-	reserve_elfcorehdr();
+	fdt_reserve_elfcorehdr();
 }
 
 /**
-- 
2.25.1

Re: [PATCH] of: fdt: Rename reserve_elfcorehdr() to fdt_reserve_elfcorehdr()

From: Rob Herring <robh+dt@kernel.org>
Date: 2021-08-25 12:21:01

On Wed, Aug 25, 2021 at 4:40 AM Geert Uytterhoeven
[off-list ref] wrote:
On ia64/allmodconfig:

    drivers/of/fdt.c:609:20: error: conflicting types for 'reserve_elfcorehdr'; have 'void(void)'
      609 | static void __init reserve_elfcorehdr(void)
          |                    ^~~~~~~~~~~~~~~~~~
    arch/ia64/include/asm/meminit.h:43:12: note: previous declaration of 'reserve_elfcorehdr' with type 'int(u64 *, u64 *)' {aka 'int(long long unsigned int *, long long unsigned int *)'}
       43 | extern int reserve_elfcorehdr(u64 *start, u64 *end);
          |            ^~~~~~~~~~~~~~~~~~
There's no need for the ia64 version to be non-static. Just needs a
forward declaration.

arch/ia64/include/asm/meminit.h:extern int reserve_elfcorehdr(u64
*start, u64 *end);
arch/ia64/kernel/setup.c:       if (reserve_elfcorehdr(&rsvd_region[n].start,
arch/ia64/kernel/setup.c:int __init reserve_elfcorehdr(u64 *start, u64 *end)

Rob

Re: [PATCH] of: fdt: Rename reserve_elfcorehdr() to fdt_reserve_elfcorehdr()

From: Geert Uytterhoeven <geert@linux-m68k.org>
Date: 2021-08-25 12:44:17

Hi Rob,

On Wed, Aug 25, 2021 at 2:21 PM Rob Herring [off-list ref] wrote:
On Wed, Aug 25, 2021 at 4:40 AM Geert Uytterhoeven
[off-list ref] wrote:
quoted
On ia64/allmodconfig:

    drivers/of/fdt.c:609:20: error: conflicting types for 'reserve_elfcorehdr'; have 'void(void)'
      609 | static void __init reserve_elfcorehdr(void)
          |                    ^~~~~~~~~~~~~~~~~~
    arch/ia64/include/asm/meminit.h:43:12: note: previous declaration of 'reserve_elfcorehdr' with type 'int(u64 *, u64 *)' {aka 'int(long long unsigned int *, long long unsigned int *)'}
       43 | extern int reserve_elfcorehdr(u64 *start, u64 *end);
          |            ^~~~~~~~~~~~~~~~~~
There's no need for the ia64 version to be non-static. Just needs a
forward declaration.

arch/ia64/include/asm/meminit.h:extern int reserve_elfcorehdr(u64
*start, u64 *end);
arch/ia64/kernel/setup.c:       if (reserve_elfcorehdr(&rsvd_region[n].start,
arch/ia64/kernel/setup.c:int __init reserve_elfcorehdr(u64 *start, u64 *end)
I know ;-)

https://lore.kernel.org/r/fe236cd73b64abc4abd03dd808cb015c907f4c8c.1629884459.git.geert+renesas@glider.be/

Gr{oetje,eeting}s,

                        Geert

-- 
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

Re: [PATCH] of: fdt: Rename reserve_elfcorehdr() to fdt_reserve_elfcorehdr()

From: Rob Herring <robh+dt@kernel.org>
Date: 2021-08-25 12:49:25

On Wed, Aug 25, 2021 at 7:44 AM Geert Uytterhoeven [off-list ref] wrote:
Hi Rob,

On Wed, Aug 25, 2021 at 2:21 PM Rob Herring [off-list ref] wrote:
quoted
On Wed, Aug 25, 2021 at 4:40 AM Geert Uytterhoeven
[off-list ref] wrote:
quoted
On ia64/allmodconfig:

    drivers/of/fdt.c:609:20: error: conflicting types for 'reserve_elfcorehdr'; have 'void(void)'
      609 | static void __init reserve_elfcorehdr(void)
          |                    ^~~~~~~~~~~~~~~~~~
    arch/ia64/include/asm/meminit.h:43:12: note: previous declaration of 'reserve_elfcorehdr' with type 'int(u64 *, u64 *)' {aka 'int(long long unsigned int *, long long unsigned int *)'}
       43 | extern int reserve_elfcorehdr(u64 *start, u64 *end);
          |            ^~~~~~~~~~~~~~~~~~
There's no need for the ia64 version to be non-static. Just needs a
forward declaration.

arch/ia64/include/asm/meminit.h:extern int reserve_elfcorehdr(u64
*start, u64 *end);
arch/ia64/kernel/setup.c:       if (reserve_elfcorehdr(&rsvd_region[n].start,
arch/ia64/kernel/setup.c:int __init reserve_elfcorehdr(u64 *start, u64 *end)
I know ;-)

https://lore.kernel.org/r/fe236cd73b64abc4abd03dd808cb015c907f4c8c.1629884459.git.geert+renesas@glider.be/
Ah, too much mail sorting...

I guess applying this too doesn't hurt.

Rob

Re: [PATCH] of: fdt: Rename reserve_elfcorehdr() to fdt_reserve_elfcorehdr()

From: Rob Herring <robh@kernel.org>
Date: 2021-08-25 16:06:00

On Wed, 25 Aug 2021 11:40:40 +0200, Geert Uytterhoeven wrote:
On ia64/allmodconfig:

    drivers/of/fdt.c:609:20: error: conflicting types for 'reserve_elfcorehdr'; have 'void(void)'
      609 | static void __init reserve_elfcorehdr(void)
	  |                    ^~~~~~~~~~~~~~~~~~
    arch/ia64/include/asm/meminit.h:43:12: note: previous declaration of 'reserve_elfcorehdr' with type 'int(u64 *, u64 *)' {aka 'int(long long unsigned int *, long long unsigned int *)'}
       43 | extern int reserve_elfcorehdr(u64 *start, u64 *end);
	  |            ^~~~~~~~~~~~~~~~~~

Fix this by prefixing the FDT function name with "fdt_".

Fixes: f7e7ce93aac13118 ("of: fdt: Add generic support for handling elf core headers property")
Reported-by: kernel test robot <redacted>
Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
---
This change was planned for v6.
Feel free to fold into the original.
---
 drivers/of/fdt.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
Applied, thanks!
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help