[PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500 node

Subsystems: arm/freescale imx / mxc / layerscape arm architecture, the rest

STALE2741d

6 messages, 3 authors, 2019-04-15 · open the first message on its own page

[PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500 node

From: Wen He <hidden>
Date: 2019-03-28 03:51:52

The LS1028A has a LCD controller and Displayport interface that
connects to eDP and Displayport connectors on the LS1028A board.

This patch enables the LCD controller driver on the LS1028A.

Signed-off-by: Alison Wang <alison.wang@nxp.com>
Signed-off-by: Wen He <redacted>
---
 .../arm64/boot/dts/freescale/fsl-ls1028a.dtsi | 37 +++++++++++++++++++
 1 file changed, 37 insertions(+)
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
index 8dd3501b1333..0d5963bb46c5 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
@@ -70,6 +70,27 @@
 		clock-output-names = "sysclk";
 	};
 
+	dpclk: dpclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <27000000>;
+		clock-output-names= "dpclk";
+	};
+
+	aclk: aclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <650000000>;
+		clock-output-names= "aclk";
+	};
+
+	pclk: pclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <650000000>;
+		clock-output-names= "pclk";
+	};
+
 	reboot {
 		compatible ="syscon-reboot";
 		regmap = <&dcfg>;
@@ -433,4 +454,20 @@
 			};
 		};
 	};
+
+	dp0: malidp@f080000 {
+		compatible = "arm,mali-dp500";
+		reg = <0x0 0xf080000 0x0 0x10000>;
+		interrupts = <0 222 IRQ_TYPE_LEVEL_HIGH>,
+			     <0 223 IRQ_TYPE_LEVEL_HIGH>;
+		interrupt-names = "DE", "SE";
+		clocks = <&dpclk>, <&aclk>, <&aclk>, <&pclk>;
+		clock-names = "pxlclk", "mclk", "aclk", "pclk";
+		arm,malidp-output-port-lines = /bits/ 8 <8 8 8>;
+		port {
+			dp0_out: endpoint {
+
+			};
+		};
+	};
 };
-- 
2.17.1

Re: [PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500 node

From: "liviu.dudau@arm.com" <liviu.dudau@arm.com>
Date: 2019-03-28 16:17:36

On Thu, Mar 28, 2019 at 03:51:46AM +0000, Wen He wrote:
The LS1028A has a LCD controller and Displayport interface that
connects to eDP and Displayport connectors on the LS1028A board.

This patch enables the LCD controller driver on the LS1028A.

Signed-off-by: Alison Wang <alison.wang@nxp.com>
Signed-off-by: Wen He <redacted>
Reviewed-by: Liviu Dudau <liviu.dudau@arm.com>

Best regards,
Liviu
quoted hunk
---
 .../arm64/boot/dts/freescale/fsl-ls1028a.dtsi | 37 +++++++++++++++++++
 1 file changed, 37 insertions(+)
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
index 8dd3501b1333..0d5963bb46c5 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
@@ -70,6 +70,27 @@
 		clock-output-names = "sysclk";
 	};
 
+	dpclk: dpclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <27000000>;
+		clock-output-names= "dpclk";
+	};
+
+	aclk: aclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <650000000>;
+		clock-output-names= "aclk";
+	};
+
+	pclk: pclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <650000000>;
+		clock-output-names= "pclk";
+	};
+
 	reboot {
 		compatible ="syscon-reboot";
 		regmap = <&dcfg>;
@@ -433,4 +454,20 @@
 			};
 		};
 	};
+
+	dp0: malidp@f080000 {
+		compatible = "arm,mali-dp500";
+		reg = <0x0 0xf080000 0x0 0x10000>;
+		interrupts = <0 222 IRQ_TYPE_LEVEL_HIGH>,
+			     <0 223 IRQ_TYPE_LEVEL_HIGH>;
+		interrupt-names = "DE", "SE";
+		clocks = <&dpclk>, <&aclk>, <&aclk>, <&pclk>;
+		clock-names = "pxlclk", "mclk", "aclk", "pclk";
+		arm,malidp-output-port-lines = /bits/ 8 <8 8 8>;
+		port {
+			dp0_out: endpoint {
+
+			};
+		};
+	};
 };
-- 
2.17.1
-- 
====================
| I would like to |
| fix the world,  |
| but they're not |
| giving me the   |
 \ source code!  /
  ---------------
    ¯\_(ツ)_/¯

Re: [PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500 node

From: Shawn Guo <shawnguo@kernel.org>
Date: 2019-04-03 10:14:18

On Thu, Mar 28, 2019 at 03:51:46AM +0000, Wen He wrote:
quoted hunk
The LS1028A has a LCD controller and Displayport interface that
connects to eDP and Displayport connectors on the LS1028A board.

This patch enables the LCD controller driver on the LS1028A.

Signed-off-by: Alison Wang <alison.wang@nxp.com>
Signed-off-by: Wen He <redacted>
---
 .../arm64/boot/dts/freescale/fsl-ls1028a.dtsi | 37 +++++++++++++++++++
 1 file changed, 37 insertions(+)
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
index 8dd3501b1333..0d5963bb46c5 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
@@ -70,6 +70,27 @@
 		clock-output-names = "sysclk";
 	};
 
+	dpclk: dpclk {
Please follow the naming convention "clock-xxx".
quoted hunk
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <27000000>;
+		clock-output-names= "dpclk";
+	};
+
+	aclk: aclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <650000000>;
+		clock-output-names= "aclk";
+	};
+
+	pclk: pclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <650000000>;
+		clock-output-names= "pclk";
+	};
+
 	reboot {
 		compatible ="syscon-reboot";
 		regmap = <&dcfg>;
@@ -433,4 +454,20 @@
 			};
 		};
 	};
+
+	dp0: malidp@f080000 {
The node name should be something generic.  The recommendation from
Devicetree Specification is 'display'.
quoted hunk
+		compatible = "arm,mali-dp500";
+		reg = <0x0 0xf080000 0x0 0x10000>;
+		interrupts = <0 222 IRQ_TYPE_LEVEL_HIGH>,
+			     <0 223 IRQ_TYPE_LEVEL_HIGH>;
+		interrupt-names = "DE", "SE";
+		clocks = <&dpclk>, <&aclk>, <&aclk>, <&pclk>;
+		clock-names = "pxlclk", "mclk", "aclk", "pclk";
+		arm,malidp-output-port-lines = /bits/ 8 <8 8 8>;
Please have a newline between properties and child node.

Shawn
+		port {
+			dp0_out: endpoint {
+
+			};
+		};
+	};
 };
-- 
2.17.1

RE: [PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500 node

From: Wen He <hidden>
Date: 2019-04-03 13:03:24

-----Original Message-----
From: Shawn Guo [mailto:shawnguo@kernel.org]
Sent: 2019年4月3日 18:14
To: Wen He <redacted>
Cc: devicetree@vger.kernel.org; Leo Li <redacted>;
liviu.dudau@arm.com; brian.starkey@arm.com
Subject: Re: [PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500
node

On Thu, Mar 28, 2019 at 03:51:46AM +0000, Wen He wrote:
quoted
The LS1028A has a LCD controller and Displayport interface that
connects to eDP and Displayport connectors on the LS1028A board.

This patch enables the LCD controller driver on the LS1028A.

Signed-off-by: Alison Wang <alison.wang@nxp.com>
Signed-off-by: Wen He <redacted>
---
 .../arm64/boot/dts/freescale/fsl-ls1028a.dtsi | 37
+++++++++++++++++++
 1 file changed, 37 insertions(+)
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
index 8dd3501b1333..0d5963bb46c5 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
@@ -70,6 +70,27 @@
 		clock-output-names = "sysclk";
 	};

+	dpclk: dpclk {
Please follow the naming convention "clock-xxx".
quoted
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <27000000>;
+		clock-output-names= "dpclk";
+	};
+
+	aclk: aclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <650000000>;
+		clock-output-names= "aclk";
+	};
+
+	pclk: pclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <650000000>;
+		clock-output-names= "pclk";
+	};
+
 	reboot {
 		compatible ="syscon-reboot";
 		regmap = <&dcfg>;
@@ -433,4 +454,20 @@
 			};
 		};
 	};
+
+	dp0: malidp@f080000 {
The node name should be something generic.  The recommendation from
Devicetree Specification is 'display'.
That definition following by malidp Devicetree bindings file.
If use name is 'display', how to define display port controller? this only is LCD controller dts node.
quoted
+		compatible = "arm,mali-dp500";
+		reg = <0x0 0xf080000 0x0 0x10000>;
+		interrupts = <0 222 IRQ_TYPE_LEVEL_HIGH>,
+			     <0 223 IRQ_TYPE_LEVEL_HIGH>;
+		interrupt-names = "DE", "SE";
+		clocks = <&dpclk>, <&aclk>, <&aclk>, <&pclk>;
+		clock-names = "pxlclk", "mclk", "aclk", "pclk";
+		arm,malidp-output-port-lines = /bits/ 8 <8 8 8>;
Please have a newline between properties and child node.

Shawn
Sure, but I see the mail devicetree binding doesn't have a blank line. So I removed it.
Is need to add a newline?

Best Regards,
Wen
quoted
+		port {
+			dp0_out: endpoint {
+
+			};
+		};
+	};
 };
--
2.17.1

Re: [PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500 node

From: Shawn Guo <shawnguo@kernel.org>
Date: 2019-04-11 02:15:56

On Wed, Apr 03, 2019 at 01:03:17PM +0000, Wen He wrote:
quoted
-----Original Message-----
From: Shawn Guo [mailto:shawnguo@kernel.org]
Sent: 2019年4月3日 18:14
To: Wen He <redacted>
Cc: devicetree@vger.kernel.org; Leo Li <redacted>;
liviu.dudau@arm.com; brian.starkey@arm.com
Subject: Re: [PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500
node

On Thu, Mar 28, 2019 at 03:51:46AM +0000, Wen He wrote:
quoted
The LS1028A has a LCD controller and Displayport interface that
connects to eDP and Displayport connectors on the LS1028A board.

This patch enables the LCD controller driver on the LS1028A.

Signed-off-by: Alison Wang <alison.wang@nxp.com>
Signed-off-by: Wen He <redacted>
---
 .../arm64/boot/dts/freescale/fsl-ls1028a.dtsi | 37
+++++++++++++++++++
 1 file changed, 37 insertions(+)
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
index 8dd3501b1333..0d5963bb46c5 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
@@ -70,6 +70,27 @@
 		clock-output-names = "sysclk";
 	};

+	dpclk: dpclk {
Please follow the naming convention "clock-xxx".
quoted
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <27000000>;
+		clock-output-names= "dpclk";
+	};
+
+	aclk: aclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <650000000>;
+		clock-output-names= "aclk";
+	};
+
+	pclk: pclk {
+		compatible = "fixed-clock";
+		#clock-cells = <0>;
+		clock-frequency = <650000000>;
+		clock-output-names= "pclk";
+	};
+
 	reboot {
 		compatible ="syscon-reboot";
 		regmap = <&dcfg>;
@@ -433,4 +454,20 @@
 			};
 		};
 	};
+
+	dp0: malidp@f080000 {
The node name should be something generic.  The recommendation from
Devicetree Specification is 'display'.
That definition following by malidp Devicetree bindings file.
If use name is 'display', how to define display port controller? this only is LCD controller dts node.
We can use some sort of suffix to define multiple nodes:

 - display-0, display-1 ...
 - display-dp, display-lcd, ...

Whatever suffix works for you, but begin with a generic name.
quoted
quoted
+		compatible = "arm,mali-dp500";
+		reg = <0x0 0xf080000 0x0 0x10000>;
+		interrupts = <0 222 IRQ_TYPE_LEVEL_HIGH>,
+			     <0 223 IRQ_TYPE_LEVEL_HIGH>;
+		interrupt-names = "DE", "SE";
+		clocks = <&dpclk>, <&aclk>, <&aclk>, <&pclk>;
+		clock-names = "pxlclk", "mclk", "aclk", "pclk";
+		arm,malidp-output-port-lines = /bits/ 8 <8 8 8>;
Please have a newline between properties and child node.

Shawn
Sure, but I see the mail devicetree binding doesn't have a blank line. So I removed it.
Is need to add a newline?
Different bindings use different conventions, but we have a set of
conventions for devicetree sources I maintain.

Shawn

RE: [EXT] Re: [PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali DP500 node

From: Wen He <hidden>
Date: 2019-04-15 07:19:01

-----Original Message-----
From: Shawn Guo [mailto:shawnguo@kernel.org]
Sent: 2019年4月11日 10:16
To: Wen He <redacted>
Cc: devicetree@vger.kernel.org; Leo Li <redacted>;
liviu.dudau@arm.com; brian.starkey@arm.com
Subject: [EXT] Re: [PATCH 1/2] arm64: dts: ls1028a: Add properties for Mali
DP500 node

WARNING: This email was created outside of NXP. DO NOT CLICK links or
attachments unless you recognize the sender and know the content is safe.



On Wed, Apr 03, 2019 at 01:03:17PM +0000, Wen He wrote:
quoted
quoted
-----Original Message-----
From: Shawn Guo [mailto:shawnguo@kernel.org]
Sent: 2019年4月3日 18:14
To: Wen He <redacted>
Cc: devicetree@vger.kernel.org; Leo Li <redacted>;
liviu.dudau@arm.com; brian.starkey@arm.com
Subject: Re: [PATCH 1/2] arm64: dts: ls1028a: Add properties for
Mali DP500 node

On Thu, Mar 28, 2019 at 03:51:46AM +0000, Wen He wrote:
quoted
The LS1028A has a LCD controller and Displayport interface that
connects to eDP and Displayport connectors on the LS1028A board.

This patch enables the LCD controller driver on the LS1028A.

Signed-off-by: Alison Wang <alison.wang@nxp.com>
Signed-off-by: Wen He <redacted>
---
 .../arm64/boot/dts/freescale/fsl-ls1028a.dtsi | 37
+++++++++++++++++++
 1 file changed, 37 insertions(+)
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
index 8dd3501b1333..0d5963bb46c5 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
@@ -70,6 +70,27 @@
          clock-output-names = "sysclk";
  };

+ dpclk: dpclk {
Please follow the naming convention "clock-xxx".
quoted
+         compatible = "fixed-clock";
+         #clock-cells = <0>;
+         clock-frequency = <27000000>;
+         clock-output-names= "dpclk"; };
+
+ aclk: aclk {
+         compatible = "fixed-clock";
+         #clock-cells = <0>;
+         clock-frequency = <650000000>;
+         clock-output-names= "aclk"; };
+
+ pclk: pclk {
+         compatible = "fixed-clock";
+         #clock-cells = <0>;
+         clock-frequency = <650000000>;
+         clock-output-names= "pclk"; };
+
  reboot {
          compatible ="syscon-reboot";
          regmap = <&dcfg>;
@@ -433,4 +454,20 @@
                  };
          };
  };
+
+ dp0: malidp@f080000 {
The node name should be something generic.  The recommendation from
Devicetree Specification is 'display'.
That definition following by malidp Devicetree bindings file.
If use name is 'display', how to define display port controller? this only is LCD
controller dts node.

We can use some sort of suffix to define multiple nodes:

 - display-0, display-1 ...
 - display-dp, display-lcd, ...

Whatever suffix works for you, but begin with a generic name.
Understood,
quoted
quoted
quoted
+         compatible = "arm,mali-dp500";
+         reg = <0x0 0xf080000 0x0 0x10000>;
+         interrupts = <0 222 IRQ_TYPE_LEVEL_HIGH>,
+                      <0 223 IRQ_TYPE_LEVEL_HIGH>;
+         interrupt-names = "DE", "SE";
+         clocks = <&dpclk>, <&aclk>, <&aclk>, <&pclk>;
+         clock-names = "pxlclk", "mclk", "aclk", "pclk";
+         arm,malidp-output-port-lines = /bits/ 8 <8 8 8>;
Please have a newline between properties and child node.

Shawn
Sure, but I see the mail devicetree binding doesn't have a blank line. So I
removed it.
quoted
Is need to add a newline?
Different bindings use different conventions, but we have a set of conventions
for devicetree sources I maintain.
Got it, will sent another patch. Thank you.

Best Regards,
Wen
Shawn
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help