RFC: board dts-file naming scheme
From: Antony Pavlov <hidden>
Date: 2016-08-16 15:13:21
Hi all!
I have not found any recomendation on board dts-file naming scheme
in linux.git/Documentation/devicetree/.
ARM/ARM64 Linux mostly uses <soc-name>-<board-name>.dts board dts-file
naming scheme (also see slide "Adding the support for a new ARM board" from [1]).
arch/arm/boot/dts/am335x-baltos-ir5221.dts
arch/arm/boot/dts/at91-ariag25.dts
arch/arm/boot/dts/exynos5250-arndale.dts
arch/arm/boot/dts/imx6dl-gw54xx.dts
arch/arm/boot/dts/sun9i-a80-cubieboard4.dts
arch/arm/boot/dts/tegra30-colibri-eval-v3.dts
arm64/boot/dts/qcom/apq8016-sbc.dts
arm64/boot/dts/cavium/thunder-88xx.dts
arm64/boot/dts/broadcom/ns2-svk.dts
arm64/boot/dts/rockchip/rk3368-r88.dts
arm64/boot/dts/mediatek/mt8173-evb.dts
MIPS Linux mostly uses <soc-name>_<board-name>.dts naming scheme:
arch/mips/boot/dts/netlogic/xlp_gvp.dts
arch/mips/boot/dts/qca/ar9132_tl_wr1043nd_v1.dts
arch/mips/boot/dts/ralink/mt7620a_eval.dts
Can we elaborate some common rule on board dts-file naming scheme
and add it into linux.git/Documentation/devicetree/?
[1] Linux Kernel and Driver Development Training by free electrons
http://free-electrons.com/doc/training/linux-kernel/linux-kernel-slides.pdf
--
Best regards,
Antony Pavlov
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at http://vger.kernel.org/majordomo-info.html