This patch add missing dt data of Exynos4x12 to bring up kernel feature and
code clean.
exynos4x12/exynos4412/exynos4212.dtsi
- Add ADC (Analog and Digital Converter) to get raw data
- Add PMU (Performance Monitoring Unit) for perf event
- Add gps_alive power domain to remove power leakage when gps-alive isn't used
- Remove duplicate dt data of interrput combiner controller
exynos4412-trats.dts
- Add ADC dt data with ntc thermistor child to read temperature
Chanwoo Choi (5):
ARM: dts: exynos4x12: Add ADC's dt data to read raw data
ARM: dts: exynos4x12: Add PMU dt data to support PMU(Perforamnce Monitoring Unit)
ARM: dts: exynos4x12: Add GPS_ALIVE power domain
ARM: dts: exynos: Move common dt data for interrupt combiner controller
ARM: dts: exynos4412-trats2: Add ADC's dt data to get temperature of SoC/battery
arch/arm/boot/dts/exynos4212.dtsi | 13 ++++---------
arch/arm/boot/dts/exynos4412-trats2.dts | 21 +++++++++++++++++++++
arch/arm/boot/dts/exynos4412.dtsi | 14 ++++----------
arch/arm/boot/dts/exynos4x12.dtsi | 31 +++++++++++++++++++++++++++++++
4 files changed, 60 insertions(+), 19 deletions(-)
--
1.8.0
ARM CPU has its own performance profiling unit(PMU, Perforamnce Monitoring Unit).
This patch add PMU dt data to support PMU which count cache hit and miss events.
PMU interrput list of Exynos4212
- <2 2> : INTG2[2] - PMUIRQ[0] for CPU0
- <3 2> : INTG3[2] - PMUIRQ[1] for CPU1
PMU interrput list of Exynos4412
- <2 2> : INTG2[2], PMUIRQ[0] for CPU0
- <3 2> : INTG3[2], PMUIRQ[1] for CPU1
- <18 2> : INTG18[2], PMUIRQ[2] : CPU2
- <19 2> : INTG19[2], PMUIRQ[3] : CPU3
Signed-off-by: Chanwoo Choi <cw00.choi@samsung.com>
Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
---
arch/arm/boot/dts/exynos4x12.dtsi | 6 ++++++
1 file changed, 6 insertions(+)
This patch move common dt data of interrupt combiner controller to
exynos4x12.dtsi. Each Exynos4x12 SoC has different number of interrput combiner
as following:
- Exynos4212 : interrput combiner 18(0 ~ 17)
- Exynos4412 : interrput combiner 20(0 ~ 19)
The exynos combiner driver initialize interrupt according to specific number
of interrput combiner.
- samsung,combiner-nr : The number of interrput combiners supported.
Also,
This patch arrange again the dt data according to register address
in exynos4212/exynos4412.dtsi.
Signed-off-by: Chanwoo Choi <cw00.choi@samsung.com>
Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
---
arch/arm/boot/dts/exynos4212.dtsi | 13 ++++---------
arch/arm/boot/dts/exynos4412.dtsi | 14 ++++----------
arch/arm/boot/dts/exynos4x12.dtsi | 8 ++++++++
3 files changed, 16 insertions(+), 19 deletions(-)
This patch add ADC(Analog to Digital Converter)'s dt data to get raw data
with IIO subsystem. Usually, ADC is used to check temperature, jack type, and
so on.
Register map
- <0x126C0000 0x100> : ADC register's base address
- <0x10020718 0x4> : ADC_PHY_CONTROL, TS-ADC control register address
Clock
- <&clock 326> : ADC clock (clock name :'tsadc')
Interrupt
- INTG10[3] : ADC for General ADC
Signed-off-by: Chanwoo Choi <cw00.choi@samsung.com>
Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
---
arch/arm/boot/dts/exynos4x12.dtsi | 12 ++++++++++++
1 file changed, 12 insertions(+)
This patch use ADC to get the temperature of SoC/battery by using NTC thermistor
driver in hwmon. NTC thermistor driver covnvert ADC's raw data to temperature
by using following variables:
- pullup-uv : Voltage
- pullup-ohm : Pull-up resistance
- pulldown-ohm : Pull-down resistance
- io-channels : It means ADC channel.
Signed-off-by: Chanwoo Choi <redacted>
---
arch/arm/boot/dts/exynos4412-trats2.dts | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
@@ -106,6 +106,27 @@};};+adc:adc@126C0000{+vdd-supply=<&ldo3_reg>;+status="okay";++ncp15wb473@0{+compatible="ntc,ncp15wb473";+pullup-uv=<1800000>;/* VCC_1.8V_AP */+pullup-ohm=<100000>;/* 100K */+pulldown-ohm=<100000>;/* 100K */+io-channels=<&adc1>;/* AP temperature */+};++ncp15wb473@1{+compatible="ntc,ncp15wb473";+pullup-uv=<1800000>;/* VCC_1.8V_AP */+pullup-ohm=<100000>;/* 100K */+pulldown-ohm=<100000>;/* 100K */+io-channels=<&adc2>;/* Battery temperature */+};+};+i2c@13890000{samsung,i2c-sda-delay=<100>;samsung,i2c-slave-addr=<0x10>;
--
1.8.0
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
This patch add GPS_ALIVE power domain for Exynos4x12 SoC. GPS_ALIVE power domain
include GPS_BLK for GPS IP. Exynos SoC used generic power-domain driver to
control power domain. After completed kernel booting, Exynos power-domain driver
disable un-used power domain to reduce power-consumption/leak.
If GPS_ALIVE power domain isn't registered to Exynos power-domain driver,
happen power-leakage because GPS_ALIVE_CONFIGURATION is default power on state.
- 0x10023D00 : GPS_ALIVE_CONFIGURATION register address
Signed-off-by: Chanwoo Choi <redacted>
Signed-off-by: Kyungmin Park <redacted>
---
arch/arm/boot/dts/exynos4x12.dtsi | 5 +++++
1 file changed, 5 insertions(+)
--
1.8.0
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
From: Tomasz Figa <hidden> Date: 2014-03-11 12:20:36
Hi Chanwoo,
On 11.03.2014 08:54, Chanwoo Choi wrote:
This patch add ADC(Analog to Digital Converter)'s dt data to get raw data
with IIO subsystem. Usually, ADC is used to check temperature, jack type, and
so on.
8< ---
Register map
- <0x126C0000 0x100> : ADC register's base address
- <0x10020718 0x4> : ADC_PHY_CONTROL, TS-ADC control register address
Clock
- <&clock 326> : ADC clock (clock name :'tsadc')
Interrupt
- INTG10[3] : ADC for General ADC
--- >8
I don't think there is a need to include such data in commit message. A
commit message should say what is done and why it's done (and sometimes
how it's done, in case of some complex code being added) and I guess
that's all.
From: Tomasz Figa <hidden> Date: 2014-03-11 12:21:39
Hi Chanwoo,
On 11.03.2014 08:54, Chanwoo Choi wrote:
ARM CPU has its own performance profiling unit(PMU, Perforamnce Monitoring Unit).
This patch add PMU dt data to support PMU which count cache hit and miss events.
PMU interrput list of Exynos4212
- <2 2> : INTG2[2] - PMUIRQ[0] for CPU0
- <3 2> : INTG3[2] - PMUIRQ[1] for CPU1
PMU interrput list of Exynos4412
- <2 2> : INTG2[2], PMUIRQ[0] for CPU0
- <3 2> : INTG3[2], PMUIRQ[1] for CPU1
- <18 2> : INTG18[2], PMUIRQ[2] : CPU2
- <19 2> : INTG19[2], PMUIRQ[3] : CPU3
Signed-off-by: Chanwoo Choi <cw00.choi@samsung.com>
Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
---
arch/arm/boot/dts/exynos4x12.dtsi | 6 ++++++
1 file changed, 6 insertions(+)
Reviewed-by: Tomasz Figa <redacted>
Best regards,
Tomasz
From: Tomasz Figa <hidden> Date: 2014-03-11 12:28:23
Hi Chanwoo,
On 11.03.2014 08:54, Chanwoo Choi wrote:
quoted hunk
This patch add GPS_ALIVE power domain for Exynos4x12 SoC. GPS_ALIVE power domain
include GPS_BLK for GPS IP. Exynos SoC used generic power-domain driver to
control power domain. After completed kernel booting, Exynos power-domain driver
disable un-used power domain to reduce power-consumption/leak.
If GPS_ALIVE power domain isn't registered to Exynos power-domain driver,
happen power-leakage because GPS_ALIVE_CONFIGURATION is default power on state.
- 0x10023D00 : GPS_ALIVE_CONFIGURATION register address
Signed-off-by: Chanwoo Choi <cw00.choi@samsung.com>
Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
---
arch/arm/boot/dts/exynos4x12.dtsi | 5 +++++
1 file changed, 5 insertions(+)
From: Tomasz Figa <hidden> Date: 2014-03-11 12:34:11
Hi Chanwoo,
On 11.03.2014 08:54, Chanwoo Choi wrote:
This patch move common dt data of interrupt combiner controller to
exynos4x12.dtsi. Each Exynos4x12 SoC has different number of interrput combiner
as following:
- Exynos4212 : interrput combiner 18(0 ~ 17)
- Exynos4412 : interrput combiner 20(0 ~ 19)
The exynos combiner driver initialize interrupt according to specific number
of interrput combiner.
- samsung,combiner-nr : The number of interrput combiners supported.
Also,
This patch arrange again the dt data according to register address
in exynos4212/exynos4412.dtsi.
Signed-off-by: Chanwoo Choi <cw00.choi@samsung.com>
Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
---
arch/arm/boot/dts/exynos4212.dtsi | 13 ++++---------
arch/arm/boot/dts/exynos4412.dtsi | 14 ++++----------
arch/arm/boot/dts/exynos4x12.dtsi | 8 ++++++++
3 files changed, 16 insertions(+), 19 deletions(-)
Reviewed-by: Tomasz Figa <redacted>
Best regards,
Tomasz
From: Tomasz Figa <hidden> Date: 2014-03-11 13:09:19
Hi Chanwoo,
On 11.03.2014 08:54, Chanwoo Choi wrote:
This patch use ADC to get the temperature of SoC/battery by using NTC thermistor
driver in hwmon. NTC thermistor driver covnvert ADC's raw data to temperature
by using following variables:
- pullup-uv : Voltage
- pullup-ohm : Pull-up resistance
- pulldown-ohm : Pull-down resistance
- io-channels : It means ADC channel.
Those properties are well-defined in "ntc,ncp15wb473" DT bindings
documentation. There is no need to repeat them here.
style: Nodes should have generic names, e.g. thermistor@0.
Also if node name is suffixed with @unit-address, then the node should
have a reg property with its first entry corresponding to the
unit-address. Now there is no physical unit-address definition for those
thermistors, so they shouldn't use this naming pattern, but rather
something like "thermistor-0" or "thermistor-ap".
Anyway, I don't think it is correct to place IIO consumers under IIO
provider node, because IIO is not a control bus, but rather a resource
provider, like GPIO, clock, etc. So both thermistor nodes should be
placed outside the adc node. (They might be grouped in a simple-bus
subnode, though, to improve readability.)
Best regards,
Tomasz
Hi Tomasz,
On 03/11/2014 09:28 PM, Tomasz Figa wrote:
Hi Chanwoo,
On 11.03.2014 08:54, Chanwoo Choi wrote:
quoted
This patch add GPS_ALIVE power domain for Exynos4x12 SoC. GPS_ALIVE power domain
include GPS_BLK for GPS IP. Exynos SoC used generic power-domain driver to
control power domain. After completed kernel booting, Exynos power-domain driver
disable un-used power domain to reduce power-consumption/leak.
If GPS_ALIVE power domain isn't registered to Exynos power-domain driver,
happen power-leakage because GPS_ALIVE_CONFIGURATION is default power on state.
- 0x10023D00 : GPS_ALIVE_CONFIGURATION register address
Signed-off-by: Chanwoo Choi <cw00.choi@samsung.com>
Signed-off-by: Kyungmin Park <kyungmin.park@samsung.com>
---
arch/arm/boot/dts/exynos4x12.dtsi | 5 +++++
1 file changed, 5 insertions(+)
Hi Tomasz,
On 03/11/2014 09:20 PM, Tomasz Figa wrote:
quoted hunk
Hi Chanwoo,
On 11.03.2014 08:54, Chanwoo Choi wrote:
quoted
This patch add ADC(Analog to Digital Converter)'s dt data to get raw data
with IIO subsystem. Usually, ADC is used to check temperature, jack type, and
so on.
8< ---
quoted
Register map
- <0x126C0000 0x100> : ADC register's base address
- <0x10020718 0x4> : ADC_PHY_CONTROL, TS-ADC control register address
Clock
- <&clock 326> : ADC clock (clock name :'tsadc')
Interrupt
- INTG10[3] : ADC for General ADC
--- >8
I don't think there is a need to include such data in commit message. A commit message should say what is done and why it's done (and sometimes how it's done, in case of some complex code being added) and I guess that's all.
Hi Tomasz,
On 03/11/2014 10:09 PM, Tomasz Figa wrote:
Hi Chanwoo,
On 11.03.2014 08:54, Chanwoo Choi wrote:
quoted
This patch use ADC to get the temperature of SoC/battery by using NTC thermistor
driver in hwmon. NTC thermistor driver covnvert ADC's raw data to temperature
by using following variables:
- pullup-uv : Voltage
- pullup-ohm : Pull-up resistance
- pulldown-ohm : Pull-down resistance
- io-channels : It means ADC channel.
Those properties are well-defined in "ntc,ncp15wb473" DT bindings documentation. There is no need to repeat them here.
style: Nodes should have generic names, e.g. thermistor@0.
Also if node name is suffixed with @unit-address, then the node should have a reg property with its first entry corresponding to the unit-address. Now there is no physical unit-address definition for those thermistors, so they shouldn't use this naming pattern, but rather something like "thermistor-0" or "thermistor-ap".
Anyway, I don't think it is correct to place IIO consumers under IIO provider node, because IIO is not a control bus, but rather a resource provider, like GPIO, clock, etc. So both thermistor nodes should be placed outside the adc node. (They might be grouped in a simple-bus subnode, though, to improve readability.)
OK, I'll move ntc_thermistor node outside of ADC dt node.
Best Regards,
Chanwoo Choi
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at http://vger.kernel.org/majordomo-info.html