security subsystem · Supported
Maintainers
- M Paul Moore <paul@paul-moore.com>
- M James Morris <jmorris@namei.org>
- M "Serge E. Hallyn" <serge@hallyn.com>
Paths
- F
include/linux/lsm/ - F
include/linux/lsm_audit.h - F
include/linux/lsm_hook_defs.h - F
include/linux/lsm_hooks.h - F
include/linux/security.h - F
include/uapi/linux/lsm.h - F
security/ - F
tools/testing/selftests/lsm/ - F
rust/kernel/security.rs - X
security/selinux/
Last 30 days
Recent patches
Most-recent 29 patches in this subsystem on linux-btrfs, ordered by date desc.
-
STALE79d
[PATCH 20/61] apparmor: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden> -
STALE257d
[PATCH v7 04/14] Coccinelle-based conversion to use ->i_state accessors
2025-10-09 · Mateusz Guzik <hidden> -
STALE270d
[PATCH v6 2/4] Convert the kernel to use ->i_state accessors
2025-09-23 · Mateusz Guzik <hidden> -
STALE285d
[PATCH v5 2/4] Convert the kernel to use ->i_state accessors
2025-09-19 · Mateusz Guzik <hidden> -
STALE288d
[PATCH v4 02/12] fs: use ->i_state accessors in core kernel
2025-09-16 · Mateusz Guzik <hidden> -
STALE292d
[PATCH v3 2/4] fs: hide ->i_state handling behind accessors
2025-09-11 · Mateusz Guzik <hidden> -
STALE298d
[PATCH v2 10/10] fs: retire the I_WILL_FREE flag
2025-09-09 · Mateusz Guzik <hidden> -
STALE298d
[PATCH v2 02/10] fs: hide ->i_state handling behind accessors
2025-09-09 · Mateusz Guzik <hidden> -
STALE292d
[WIP RFC PATCH] fs: retire I_WILL_FREE
2025-09-02 · Mateusz Guzik <hidden> -
STALE298d
[PATCH v2 42/54] landlock: remove I_FREEING|I_WILL_FREE check
2025-08-26 · Josef Bacik <josef@toxicpanda.com> -
STALE298d
LANDED [PATCH v2 02/54] fs: add an icount_read helper
2025-08-26 · Josef Bacik <josef@toxicpanda.com> -
STALE312d
[PATCH 40/50] landlock: remove I_FREEING|I_WILL_FREE check
2025-08-21 · Josef Bacik <josef@toxicpanda.com> -
STALE312d
[PATCH 20/50] fs: convert i_count to refcount_t
2025-08-21 · Josef Bacik <josef@toxicpanda.com> -
STALE563d
[RFC v2] lsm: fs: Use inode_free_callback to free i_security in RCU callback
2024-12-18 · Song Liu <song@kernel.org> -
STALE564d
[RFC] lsm: fs: Use i_callback to free i_security in RCU callback
2024-12-16 · Song Liu <song@kernel.org> -
STALE1817d
[PATCH 01/24] namei: handle mappings in lookup_one_len()
2021-07-13 · Christian Brauner <brauner@kernel.org> -
STALE2208d
REVIEWED: 19 (19M) [PATCH v4 2/3] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-06-16 · Waiman Long <longman@redhat.com> -
STALE2210d
[PATCH 1/2] mm, treewide: Rename kzfree() to kfree_sensitive()
2020-04-13 · Waiman Long <longman@redhat.com> -
STALE3098d
[PATCH v4 15/19] IMA: switch IMA over to new i_version API
2017-12-22 · Jeff Layton <jlayton@kernel.org> -
STALE3117d
[PATCH v3 15/19] IMA: switch IMA over to new i_version API
2017-12-18 · Jeff Layton <jlayton@kernel.org> -
STALE3122d
[PATCH v2 15/19] IMA: switch IMA over to new i_version API
2017-12-16 · Jeff Layton <jlayton@kernel.org> -
STALE3317d
[PATCH 10/12] apparmorfs: Replace CURRENT_TIME with current_time()
2017-04-08 · Deepa Dinamani <hidden> -
STALE3169d
[RFC PATCH v1 24/30] IMA: switch IMA over to new i_version API
2016-12-21 · Jeff Layton <hidden> -
STALE4302d
REVIEWED: 6 (4M) [PATCH v4 11/12] security, crypto: LLVMLinux: Remove VLAIS from ima_crypto.c
2014-09-23 · <hidden> -
STALE4308d
REVIEWED: 2 (0M) [PATCH v3 11/12] security, crypto: LLVMLinux: Remove VLAIS from ima_crypto.c
2014-09-15 · <hidden> -
STALE4323d
[PATCH RFC 5/6] apparmor: LLVMLinux: Remove VLAIS
2014-09-02 · <hidden> -
DORMANTno replies
[PATCH] security: new security_inode_init_security API adds function callback
2011-06-23 · Mimi Zohar <hidden> -
STALE5475d
[PATCH] fs/vfs/security: pass last path component to LSM on inode creation
2010-12-08 · Eric Paris <eparis@redhat.com> -
STALE5730d
[PATCH 6/6] Btrfs: allow subvol deletion by owner
2010-10-25 · Sage Weil <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE79d
[PATCH 20/61] apparmor: Prefer IS_ERR_OR_NULL over manual NULL check
2026-03-10 · Philipp Hahn <hidden>