Reviews by jack@suse.cz
· linux-bcache
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-bcache archive.
100 attestations · capped at 100 most-recent. (100 Reviewed-by)
-
STALE860d
REVIEWED: 9 (9M) Re: [PATCH RFC v3 for-6.8/block 14/17] buffer: add a new helper to read sb block
2024-01-04 · Reviewed-by -
STALE860d
REVIEWED: 9 (9M) Re: [PATCH RFC v3 for-6.8/block 13/17] jbd2: use bdev apis
2024-01-04 · Reviewed-by -
STALE860d
REVIEWED: 9 (9M) [PATCH RFC v3 for-6.8/block 17/17] ext4: use bdev apis
2023-12-21 · Reviewed-by -
STALE860d
REVIEWED: 13 (13M) [PATCH RFC v3 for-6.8/block 16/17] ext4: remove block_device_ejected()
2023-12-21 · Reviewed-by -
STALE860d
REVIEWED: 9 (9M) [PATCH RFC v3 for-6.8/block 15/17] ext4: use new helper to read sb block
2023-12-21 · Reviewed-by -
STALE980d
REVIEWED: 9 (9M) Re: [PATCH RFC v2 for-6.8/block 16/18] ext4: use new helper to read sb block
2023-12-11 · Reviewed-by -
STALE980d
REVIEWED: 9 (9M) Re: [PATCH RFC v2 for-6.8/block 17/18] ext4: remove block_device_ejected()
2023-12-11 · Reviewed-by -
STALE980d
REVIEWED: 9 (9M) Re: [PATCH RFC v2 for-6.8/block 18/18] ext4: use bdev apis
2023-12-11 · Reviewed-by -
STALE1766d
LANDED: 17 (16M) [PATCH 26/30] ext4: use sb_bdev_nr_blocks
2021-10-18 · Reviewed-by -
STALE1766d
LANDED: 10 (9M) [PATCH 29/30] reiserfs: use sb_bdev_nr_blocks
2021-10-18 · Reviewed-by -
STALE1766d
LANDED: 10 (9M) [PATCH 30/30] udf: use sb_bdev_nr_blocks
2021-10-18 · Reviewed-by -
STALE1766d
LANDED: 11 (10M) [PATCH 24/30] block: use bdev_nr_bytes instead of open coding it in blkdev_fallocate
2021-10-18 · Reviewed-by -
STALE1766d
LANDED: 11 (10M) [PATCH 22/30] reiserfs: use bdev_nr_bytes instead of open coding it
2021-10-18 · Reviewed-by -
STALE1766d
LANDED: 11 (10M) [PATCH 09/30] fs: use bdev_nr_bytes instead of open coding it in blkdev_max_block
2021-10-18 · Reviewed-by -
STALE1766d
LANDED: 10 (9M) [PATCH 10/30] fs: simplify init_page_buffers
2021-10-18 · Reviewed-by -
STALE1766d
LANDED: 11 (10M) [PATCH 01/30] block: move the SECTOR_SIZE related definitions to blk_types.h
2021-10-18 · Reviewed-by -
STALE1767d
REVIEWED: 9 (9M) Re: [PATCH 01/30] block: move the SECTOR_SIZE related definitions to blk_types.h
2021-10-15 · Reviewed-by -
STALE1767d
REVIEWED: 10 (9M) [PATCH 29/30] reiserfs: use sb_bdev_nr_blocks
2021-10-15 · Reviewed-by -
STALE1767d
REVIEWED: 10 (9M) [PATCH 30/30] udf: use sb_bdev_nr_blocks
2021-10-15 · Reviewed-by -
STALE1767d
REVIEWED: 16 (15M) [PATCH 26/30] ext4: use sb_bdev_nr_blocks
2021-10-15 · Reviewed-by -
STALE1767d
REVIEWED: 10 (10M) [PATCH 24/30] block: use bdev_nr_bytes instead of open coding it in blkdev_fallocate
2021-10-15 · Reviewed-by -
STALE1767d
REVIEWED: 9 (9M) [PATCH 22/30] reiserfs: use bdev_nr_bytes instead of open coding it
2021-10-15 · Reviewed-by -
STALE1767d
REVIEWED: 10 (9M) [PATCH 10/30] fs: simplify init_page_buffers
2021-10-15 · Reviewed-by -
STALE1767d
REVIEWED: 10 (10M) [PATCH 09/30] fs: use bdev_nr_bytes instead of open coding it in blkdev_max_block
2021-10-15 · Reviewed-by -
STALE1770d
REVIEWED: 9 (9M) Re: [PATCH 29/29] udf: use sb_bdev_nr_blocks
2021-10-13 · Reviewed-by -
STALE1770d
REVIEWED: 9 (9M) Re: [PATCH 25/29] ext4: use sb_bdev_nr_blocks
2021-10-13 · Reviewed-by -
STALE1770d
REVIEWED: 9 (9M) Re: [PATCH 28/29] reiserfs: use sb_bdev_nr_blocks
2021-10-13 · Reviewed-by -
STALE1770d
REVIEWED: 9 (9M) Re: [PATCH 23/29] block: use bdev_nr_sectors instead of open coding it in blkdev_fallocate
2021-10-13 · Reviewed-by -
STALE1770d
REVIEWED: 9 (9M) Re: [PATCH 21/29] reiserfs: use bdev_nr_sectors instead of open coding it
2021-10-13 · Reviewed-by -
STALE1770d
REVIEWED: 9 (9M) Re: [PATCH 08/29] fs: use bdev_nr_sectors instead of open coding it in blkdev_max_block
2021-10-13 · Reviewed-by -
STALE1770d
REVIEWED: 9 (9M) Re: [PATCH 09/29] fs: simplify init_page_buffers
2021-10-13 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) Re: [PATCH 30/45] block: remove the nr_sects field in struct hd_struct
2020-11-30 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) Re: [PATCH 44/45] block: merge struct block_device and struct hd_struct
2020-11-30 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) Re: [PATCH 42/45] block: switch disk_part_iter_* to use a struct block_device
2020-11-30 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) Re: [PATCH 37/45] block: allocate struct hd_struct as part of struct bdev_inode
2020-11-30 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) Re: [PATCH 25/45] block: simplify bdev/disk lookup in blkdev_get
2020-11-30 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) Re: [PATCH 16/45] block: switch bdgrab to use igrab
2020-11-30 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 22/45] block: move bdput() to the callers of __blkdev_get
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 05/45] mtip32xx: remove the call to fsync_bdev on removal
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 15 (15M) [PATCH 21/45] block: refactor blkdev_get
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 33/45] block: move the partition_meta_info to struct block_device
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 11 (11M) [PATCH 03/45] fs: remove get_super_thawed and get_super_exclusive_thawed
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 35 (34M) [PATCH 17/45] init: refactor name_to_dev_t
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 34 (34M) [PATCH 20/45] block: refactor __blkdev_put
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 34 (34M) [PATCH 26/45] block: remove ->bd_contains
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 17 (17M) [PATCH 11/45] block: remove a superflous check in blkpg_do_ioctl
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 07/45] loop: do not call set_blocksize
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 15 (15M) [PATCH 23/45] block: opencode devcgroup_inode_permission
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 32/45] block: move the start_sect field to struct block_device
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 15 (15M) [PATCH 29/45] block: initialize struct block_device in bdev_alloc
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 04/45] fs: simplify freeze_bdev/thaw_bdev
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 15 (15M) [PATCH 28/45] block: simplify part_to_disk
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 34 (34M) [PATCH 27/45] block: simplify the block device claiming interface
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 37 (36M) [PATCH 01/45] blk-cgroup: fix a hd_struct leak in blkcg_fill_root_iostats
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 34 (34M) [PATCH 15/45] block: change the hash used for looking up block devices
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 37 (36M) [PATCH 10/45] block: remove a duplicate __disk_get_part prototype
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 35 (34M) [PATCH 14/45] block: use put_device in put_disk
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 15 (15M) [PATCH 24/45] block: remove i_bdev
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 35 (34M) [PATCH 19/45] init: cleanup match_dev_by_uuid and match_dev_by_label
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 37 (36M) [PATCH 13/45] block: use disk_part_iter_exit in disk_part_iter_next
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 31/45] block: move disk stat accounting to struct block_device
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 34 (34M) [PATCH 18/45] init: refactor devt_from_partuuid
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 37 (36M) [PATCH 12/45] block: add a bdev_kobj helper
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 35/45] block: move make_it_fail to struct block_device
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 16 (16M) [PATCH 02/45] filemap: consistently use ->f_mapping over ->i_mapping
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 34/45] block: move holder_dir to struct block_device
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 36/45] block: move the policy field to struct block_device
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 40/45] block: pass a block_device to blk_alloc_devt
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 39/45] block: remove the partno field from struct hd_struct
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 41/45] block: pass a block_device to invalidate_partition
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 38/45] block: switch partition lookup to use struct block_device
2020-11-28 · Reviewed-by -
STALE2086d
REVIEWED: 9 (9M) [PATCH 45/45] block: stop using bdget_disk for partition 0
2020-11-28 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 44/44] block: stop using bdget_disk for partition 0
2020-11-27 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 40/44] block: pass a block_device to invalidate_partition
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 39/44] block: pass a block_device to blk_alloc_devt
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 38/44] block: remove the partno field from struct hd_struct
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 37/44] block: switch partition lookup to use struct block_device
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 36/44] block: allocate struct hd_struct as part of struct bdev_inode
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 35/44] block: move the policy field to struct block_device
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 34/44] block: move make_it_fail to struct block_device
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 33/44] block: move holder_dir to struct block_device
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 32/44] block: move the partition_meta_info to struct block_device
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 31/44] block: move the start_sect field to struct block_device
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 30/44] block: move disk stat accounting to struct block_device
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 28/44] block: initialize struct block_device in bdev_alloc
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 27/44] block: simplify part_to_disk
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 23/44] block: remove i_bdev
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 22/44] block: opencode devcgroup_inode_permission
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 21/44] block: move bdput() to the callers of __blkdev_get
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 20/44] block: refactor blkdev_get
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) Re: [PATCH 04/44] fs: simplify freeze_bdev/thaw_bdev
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 34 (34M) [PATCH 25/44] block: remove ->bd_contains
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 34 (34M) [PATCH 26/44] block: simplify the block device claiming interface
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 34 (34M) [PATCH 19/44] block: refactor __blkdev_put
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 35 (34M) [PATCH 18/44] init: cleanup match_dev_by_uuid and match_dev_by_label
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 35 (34M) [PATCH 16/44] init: refactor name_to_dev_t
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 34 (34M) [PATCH 17/44] init: refactor devt_from_partuuid
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 34 (34M) [PATCH 15/44] block: change the hash used for looking up block devices
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 9 (9M) [PATCH 05/44] mtip32xx: remove the call to fsync_bdev on removal
2020-11-26 · Reviewed-by -
STALE2091d
REVIEWED: 35 (34M) [PATCH 14/44] block: use put_device in put_disk
2020-11-26 · Reviewed-by