sparse checker · Maintained
Maintainers
- M Chris Li <sparse@chrisli.org>
Paths
- F
include/linux/compiler.h
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-arm-kernel (capped at 30), ordered by date desc.
-
STALE147d
[PATCH v2 2/5] compiler.h: Add generic support for 'autoterminating nested for() loops'
2026-03-02 · <hidden> -
STALE160d
Re: [PATCH v3 2/3] arm64: Optimize __READ_ONCE() with CONFIG_LTO=y
2026-02-02 · Peter Zijlstra <peterz@infradead.org> -
STALE242d
[PATCH v4 7/9] include: Replace __ASSEMBLY__ with __ASSEMBLER__ in non-uapi headers
2025-11-21 · Thomas Huth <hidden> -
STALE297d
[PATCH v4 03/11 6.1.y] minmax: improve macro expansion and type checking
2025-10-03 · Eliav Farber <hidden> -
STALE300d
[PATCH v3 03/11 6.1.y] minmax: improve macro expansion and type checking
2025-10-02 · Eliav Farber <hidden> -
STALE328d
REVIEWED: 1 (0M) [PATCH v2 8/9] kcfi: Rename CONFIG_CFI_CLANG to CONFIG_CFI
2025-09-04 · Kees Cook <kees@kernel.org> -
STALE289d
[PATCH 5/5] kcfi: Rename CONFIG_CFI_CLANG to CONFIG_CFI
2025-08-25 · Kees Cook <kees@kernel.org> -
STALE597d
[PATCH 10/10] compiler.h: remove __is_constexpr()
2024-12-02 · Vincent Mailhol via B4 Relay <devnull+mailhol.vincent.wanadoo.fr@kernel.org> -
STALE597d
[PATCH 01/10] compiler.h: add statically_false()
2024-12-02 · Vincent Mailhol via B4 Relay <devnull+mailhol.vincent.wanadoo.fr@kernel.org> -
STALE597d
[PATCH 03/10] compiler.h: add is_const_true() and is_const_false()
2024-12-02 · Vincent Mailhol via B4 Relay <devnull+mailhol.vincent.wanadoo.fr@kernel.org> -
STALE597d
[PATCH 02/10] compiler.h: add is_const() as a replacement of __is_constexpr()
2024-12-02 · Vincent Mailhol via B4 Relay <devnull+mailhol.vincent.wanadoo.fr@kernel.org> -
STALE980d
[PATCH v2 1/6] compiler.h: Introduce helpers for identifying array and pointer types
2023-11-21 · Raag Jadav <raag.jadav@intel.com> -
STALE982d
[PATCH v1 1/6] compiler.h: Introduce helpers for identifying array and pointer types
2023-11-20 · Raag Jadav <raag.jadav@intel.com> -
STALE1401d
LANDED: 7 (5M) [PATCH v5 13/22] treewide: Drop function_nocfi
2022-09-08 · Sami Tolvanen <samitolvanen@google.com> -
STALE1401d
LANDED: 7 (5M) [PATCH v5 04/22] cfi: Drop __CFI_ADDRESSABLE
2022-09-08 · Sami Tolvanen <samitolvanen@google.com> -
STALE1426d
REVIEWED: 1 (0M) [PATCH v4 13/21] treewide: Drop function_nocfi
2022-08-30 · Sami Tolvanen <samitolvanen@google.com> -
STALE1426d
REVIEWED: 1 (0M) [PATCH v4 04/21] cfi: Drop __CFI_ADDRESSABLE
2022-08-30 · Sami Tolvanen <samitolvanen@google.com> -
STALE1491d
[PATCH v6 14/33] objtool: arm64: Add annotate_reachable() for objtools
2022-06-23 · Chen Zhongjin <hidden> -
STALE1498d
[PATCH v5 14/33] objtool: arm64: Add annotate_reachable() for objtools
2022-06-22 · Chen Zhongjin <hidden> -
STALE1465d
REVIEWED: 1 (0M) [RFC PATCH v3 12/20] treewide: Drop function_nocfi
2022-06-10 · Sami Tolvanen <samitolvanen@google.com> -
STALE1465d
REVIEWED: 1 (0M) [RFC PATCH v3 04/20] cfi: Drop __CFI_ADDRESSABLE
2022-06-10 · Sami Tolvanen <samitolvanen@google.com> -
STALE1526d
[RFC PATCH v2 12/21] treewide: Drop function_nocfi
2022-05-13 · Sami Tolvanen <samitolvanen@google.com> -
STALE1526d
[RFC PATCH v2 05/21] cfi: Drop __CFI_ADDRESSABLE
2022-05-13 · Sami Tolvanen <samitolvanen@google.com> -
STALE1546d
[RFC PATCH 10/21] treewide: Drop function_nocfi
2022-04-29 · Sami Tolvanen <samitolvanen@google.com> -
STALE1546d
[RFC PATCH 05/21] cfi: Drop __CFI_ADDRESSABLE
2022-04-29 · Sami Tolvanen <samitolvanen@google.com> -
STALE1545d
[RFC PATCH v4 16/37] arm64: Add annotate_reachable() for objtools
2022-04-29 · Chen Zhongjin <hidden> -
STALE1883d
LANDED [PATCH] CFI: Move function_nocfi() into compiler.h
2021-06-02 · Mark Rutland <mark.rutland@arm.com> -
STALE2192d
REVIEWED: 8 (8M) [PATCH v3 02/19] compiler.h: Split {READ,WRITE}_ONCE definitions out into rwonce.h
2020-07-10 · Will Deacon <will@kernel.org> -
STALE2212d
REVIEWED: 8 (8M) [PATCH 02/18] compiler.h: Split {READ,WRITE}_ONCE definitions out into rwonce.h
2020-06-30 · Will Deacon <will@kernel.org> -
STALE2136d
[PATCH 05/22] kbuild: lto: postpone objtool
2020-06-24 · Sami Tolvanen <samitolvanen@google.com>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE147d
[PATCH v2 2/5] compiler.h: Add generic support for 'autoterminating nested for() loops'
2026-03-02 · <hidden>