kasan · Maintained
Maintainers
- M Andrey Ryabinin <ryabinin.a.a@gmail.com>
- R Alexander Potapenko <glider@google.com>
- R Andrey Konovalov <andreyknvl@gmail.com>
- R Dmitry Vyukov <dvyukov@google.com>
- R Vincenzo Frascino <vincenzo.frascino@arm.com>
Paths
- F
Documentation/dev-tools/kasan.rst - F
arch/*/include/asm/*kasan.h - F
arch/*/mm/kasan_init* - F
include/linux/kasan*.h - F
lib/Kconfig.kasan - F
mm/kasan/ - F
scripts/Makefile.kasan
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-arm-kernel (capped at 30), ordered by date desc.
-
COOLING12d
[PATCH v15 7/9] arm64: introduce copy_mc_to_kernel() implementation
2026-06-18 · Ruidong Tian <hidden> -
COOLING6d
[RFC PATCH 2/2] kasan: hw_tags: Add boot option to elide free time poisoning
2026-06-12 · Dev Jain <dev.jain@arm.com> -
COOLING6d
[RFC PATCH 1/2] kasan: hw_tags: Use KASAN_PAGE_REDZONE for vmalloc redzoning
2026-06-12 · Dev Jain <dev.jain@arm.com> -
COOLING14d
[PATCH v2 2/5] kasan: Move generic KASAN page tables out of BSS too
2026-06-04 · Ard Biesheuvel <hidden> -
COLD26d
[PATCH 1/4] arm64: Move generic KASAN page tables out of BSS too
2026-06-03 · Ard Biesheuvel <hidden> -
COLD25d
[PATCH v14 7/8] arm64: introduce copy_mc_to_kernel() implementation
2026-05-18 · Ruidong Tian <hidden> -
STALE62d
[RFC PATCH v1 5/9] uaccess: Switch to copy_{to/from}_user_partial() when relevant
2026-04-27 · "Christophe Leroy (CS GROUP)" <chleroy@kernel.org> -
COLD26d
[PATCH RFC bpf-next 1/8] kasan: expose generic kasan helpers
2026-04-13 · Alexis Lothoré (eBPF Foundation) <hidden> -
COLD35d
[PATCH v12 01/15] kasan: sw_tags: Use arithmetic shift for shadow computation
2026-03-30 · Maciej Wieczor-Retman <hidden> -
STALE105d
Re: [PATCH v5 14/15] mm/kasan: add document into kernel-parameters.txt
2026-03-17 · Baoquan He <hidden> -
STALE111d
[PATCH v11 01/15] kasan: sw_tags: Use arithmetic shift for shadow computation
2026-03-10 · Maciej Wieczor-Retman <hidden> -
STALE117d
Re: [PATCH v10 01/13] kasan: sw_tags: Use arithmetic shift for shadow computation
2026-03-05 · Andrey Ryabinin <ryabinin.a.a@gmail.com> -
STALE105d
[PATCH v5 15/15] mm/kasan: clean up unneeded ARCH_DEFER_KASAN and kasan_arch_is_ready
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 14/15] mm/kasan: add document into kernel-parameters.txt
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 05/15] mm/kasan/sw_tags: don't initialize kasan if it's disabled
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 04/15] mm/kasan: make kasan=on|off take effect for all three modes
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 03/15] mm/kasan: mm/kasan: move kasan= code to common place
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 02/15] mm/kasan: rename 'kasan_arg' to 'kasan_arg_disabled'
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 01/15] mm/kasan: add conditional checks in functions to return directly if kasan is disabled
2026-02-25 · Baoquan He <hidden> -
STALE117d
[PATCH v10 01/13] kasan: sw_tags: Use arithmetic shift for shadow computation
2026-02-04 · Maciej Wieczor-Retman <hidden> -
STALE125d
[PATCH v9 01/13] kasan: sw_tags: Use arithmetic shift for shadow computation
2026-01-20 · Maciej Wieczor-Retman <hidden> -
STALE159d
REVIEWED: 3 (3M) [PATCH v8 01/14] kasan: sw_tags: Use arithmetic shift for shadow computation
2026-01-12 · Maciej Wieczor-Retman <hidden> -
STALE167d
REVIEWED: 2 (0M) [PATCH v6 07/14] mm: introduce generic lazy_mmu helpers
2025-12-15 · Kevin Brodsky <hidden> -
STALE172d
REVIEWED: 3 (3M) [PATCH v7 01/15] kasan: sw_tags: Use arithmetic shift for shadow computation
2025-12-10 · Maciej Wieczor-Retman <hidden> -
STALE207d
REVIEWED: 1 (0M) [PATCH v5 06/12] mm: introduce generic lazy_mmu helpers
2025-11-24 · Kevin Brodsky <hidden> -
STALE218d
[PATCH v4 06/12] mm: introduce generic lazy_mmu helpers
2025-10-29 · Kevin Brodsky <hidden> -
STALE245d
[PATCH v3 06/13] mm: introduce generic lazy_mmu helpers
2025-10-15 · Kevin Brodsky <hidden> -
STALE280d
REVIEWED: 4 (4M) [PATCH v8 2/2] kasan: apply write-only mode in kasan kunit testcases
2025-09-16 · Yeoreum Yun <hidden> -
STALE280d
REVIEWED: 3 (3M) [PATCH v8 1/2] kasan/hw-tags: introduce kasan.write_only option
2025-09-16 · Yeoreum Yun <hidden> -
STALE288d
REVIEWED: 11 (11M) [PATCH v2 2/7] mm: introduce local state for lazy_mmu sections
2025-09-08 · Kevin Brodsky <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE105d
[PATCH v5 01/15] mm/kasan: add conditional checks in functions to return directly if kasan is disabled
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 02/15] mm/kasan: rename 'kasan_arg' to 'kasan_arg_disabled'
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 03/15] mm/kasan: mm/kasan: move kasan= code to common place
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 04/15] mm/kasan: make kasan=on|off take effect for all three modes
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 05/15] mm/kasan/sw_tags: don't initialize kasan if it's disabled
2026-02-25 · Baoquan He <hidden> -
STALE105d
[PATCH v5 15/15] mm/kasan: clean up unneeded ARCH_DEFER_KASAN and kasan_arch_is_ready
2026-02-25 · Baoquan He <hidden>