Reviews by elver@google.com
· linux-arm-kernel
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-arm-kernel archive.
100 attestations · capped at 100 most-recent. (22 Acked-by, 54 Reviewed-by, 23 Suggested-by, 1 Tested-by)
-
STALE106d
REVIEWED: 5 (5M) Re: [patch 19/38] kcsan: Replace get_cycles() usage
2026-04-10 · Reviewed-by -
STALE300d
REVIEWED: 6 (5M) [PATCH v2 35/37] kfence: drop nth_page() usage
2025-09-01 · Reviewed-by -
STALE338d
REVIEWED: 5 (5M) Re: [PATCH v1 34/36] kfence: drop nth_page() usage
2025-08-28 · Reviewed-by -
STALE360d
REVIEWED: 5 (5M) [PATCH v3 10/13] init.h: Disable sanitizer coverage for __init and __head
2025-07-17 · Acked-by -
STALE391d
REVIEWED: 5 (5M) [PATCH v2 11/14] init.h: Disable sanitizer coverage for __init and __head
2025-05-23 · Acked-by -
STALE448d
REVIEWED: 5 (5M) Re: [PATCH 2/8] init.h: Disable sanitizer coverage for __init and __head
2025-05-08 · Acked-by -
DORMANTno replies
REVIEWED: 5 (5M) Re: [PATCH] [v2] kasan: use internal prototypes matching gcc-13 builtins
2023-04-24 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) Re: [PATCH v2 5/5] kasan: suppress recursive reports for HW_TAGS
2023-03-30 · Reviewed-by -
STALE1227d
LANDED: 6 (5M) [PATCH v12] mm,kfence: decouple kfence from page granularity mapping judgement
2023-03-17 · Reviewed-by -
STALE1237d
REVIEWED: 5 (5M) Re: [PATCH v11] mm,kfence: decouple kfence from page granularity mapping judgement
2023-03-16 · Reviewed-by -
STALE1465d
REVIEWED: 5 (5M) Re: [PATCH v2 1/1] mm: kfence: apply kmemleak_ignore_phys on early allocated pool
2022-06-28 · Reviewed-by -
STALE1465d
[PATCH v2 1/1] mm: kfence: apply kmemleak_ignore_phys on early allocated pool
2022-06-28 · Suggested-by -
STALE1504d
REVIEWED: 5 (5M) Re: [PATCH v4 1/2] asm-generic: Add memory barrier dma_mb()
2022-05-23 · Reviewed-by -
STALE1504d
LANDED: 5 (5M) [PATCH v4 2/2] arm64: kcsan: Support detecting more missing memory barriers
2022-05-23 · Acked-by -
STALE1535d
REVIEWED: 5 (5M) [PATCH v4 2/2] arm64: kcsan: Support detecting more missing memory barriers
2022-05-23 · Acked-by -
STALE1535d
REVIEWED: 5 (5M) Re: [PATCH v3 2/2] arm64: kcsan: Support detecting more missing memory barriers
2022-05-23 · Acked-by -
STALE1540d
REVIEWED: 5 (5M) Re: [PATCH] [v2] Kbuild: move to -std=gnu11
2022-02-28 · Acked-by -
STALE1626d
REVIEWED: 5 (5M) Re: [PATCH v2] perf test: Skip Sigtrap test for arm+aarch64
2022-02-18 · Acked-by -
STALE1560d
[PATCH v6 33/39] kasan: mark kasan_arg_stacktrace as __initdata
2022-01-24 · Suggested-by -
STALE1560d
[PATCH v6 06/39] kasan: drop skip_kasan_poison variable in free_pages_prepare
2022-01-24 · Suggested-by -
STALE1560d
REVIEWED: 5 (5M) [PATCH v6 00/39] kasan, vmalloc, arm64: add vmalloc tagging support for SW/HW_TAGS
2022-01-24 · Acked-by -
STALE1674d
[PATCH mm v5 33/39] kasan: mark kasan_arg_stacktrace as __initdata
2021-12-30 · Suggested-by -
STALE1674d
[PATCH mm v5 06/39] kasan: drop skip_kasan_poison variable in free_pages_prepare
2021-12-30 · Suggested-by -
STALE1674d
REVIEWED: 5 (5M) [PATCH mm v5 00/39] kasan, vmalloc, arm64: add vmalloc tagging support for SW/HW_TAGS
2021-12-30 · Acked-by -
STALE1679d
REVIEWED: 5 (5M) Re: [PATCH mm v4 00/39] kasan, vmalloc, arm64: add vmalloc tagging support for SW/HW_TAGS
2021-12-22 · Acked-by -
STALE1679d
[PATCH mm v4 33/39] kasan: mark kasan_arg_stacktrace as __initdata
2021-12-20 · Suggested-by -
STALE1679d
[PATCH mm v4 06/39] kasan: drop skip_kasan_poison variable in free_pages_prepare
2021-12-20 · Suggested-by -
STALE1689d
[PATCH mm v3 32/38] kasan: mark kasan_arg_stacktrace as __initdata
2021-12-13 · Suggested-by -
STALE1689d
[PATCH mm v3 06/38] kasan: drop skip_kasan_poison variable in free_pages_prepare
2021-12-13 · Suggested-by -
STALE1668d
REVIEWED: 5 (5M) Re: [PATCH v4 1/7] include: split out uaccess instrumentation into a separate header
2021-12-10 · Reviewed-by -
STALE1696d
[PATCH v2 29/34] kasan: mark kasan_arg_stacktrace as __initdata
2021-12-06 · Suggested-by -
STALE1696d
[PATCH v2 06/34] kasan: drop skip_kasan_poison variable in free_pages_prepare
2021-12-06 · Suggested-by -
STALE1710d
REVIEWED: 5 (5M) [PATCH Resend v2 3/3] ARM: Support KFENCE for ARM
2021-11-15 · Acked-by -
STALE1710d
REVIEWED: 5 (5M) [PATCH Resend v2 2/3] ARM: mm: Provide is_write_fault()
2021-11-15 · Acked-by -
STALE1710d
REVIEWED: 5 (5M) [PATCH Resend v2 1/3] ARM: mm: Provide set_memory_valid()
2021-11-15 · Acked-by -
STALE1735d
REVIEWED: 5 (5M) Re: [PATCH v2 0/3] ARM: Support KFENCE feature
2021-11-04 · Acked-by -
STALE1748d
REVIEWED: 5 (5M) Re: [PATCH v3] kasan: add kasan mode messages when kasan init
2021-10-20 · Reviewed-by -
STALE1787d
REVIEWED: 5 (5M) Re: [PATCH v2] kasan: test: add memcpy test that avoids out-of-bounds write
2021-09-13 · Acked-by -
STALE1827d
REVIEWED: 5 (5M) [PATCH v3 2/2] kasan, slub: reset tag when printing address
2021-08-04 · Reviewed-by -
STALE1827d
REVIEWED: 5 (5M) Re: [PATCH v2 2/2] kasan, slub: reset tag when printing address
2021-08-04 · Reviewed-by -
STALE1827d
[PATCH v2 2/2] kasan, slub: reset tag when printing address
2021-08-04 · Suggested-by -
STALE1826d
REVIEWED: 5 (5M) Re: [PATCH v2 3/3] kasan: arm64: Fix pcpu_page_first_chunk crash with KASAN_VMALLOC
2021-07-22 · Acked-by -
STALE1857d
REVIEWED: 5 (5M) Re: [PATCH v6 2/2] kasan: Add memzero int for unaligned size at DEBUG
2021-07-05 · Reviewed-by -
STALE1857d
[PATCH v6 2/2] kasan: Add memzero int for unaligned size at DEBUG
2021-07-05 · Suggested-by -
STALE1857d
[PATCH v5 2/2] kasan: Add memzero int for unaligned size at DEBUG
2021-07-05 · Suggested-by -
STALE1860d
[PATCH v4 2/2] kasan: Add memzero int for unaligned size at DEBUG
2021-07-02 · Suggested-by -
STALE1861d
[PATCH v3 1/1] kasan: Add memzero init for unaligned size under SLUB debug
2021-06-30 · Suggested-by -
DORMANTno replies
REVIEWED: 5 (5M) Re: [PATCH v4 3/3] kasan: add memory corruption identification support for hardware tag-based mode
2021-06-28 · Reviewed-by -
STALE1864d
REVIEWED: 5 (5M) Re: [PATCH v4 2/3] kasan: integrate the common part of two KASAN tag-based modes
2021-06-28 · Reviewed-by -
STALE1864d
REVIEWED: 5 (5M) Re: [PATCH v4 1/3] kasan: rename CONFIG_KASAN_SW_TAGS_IDENTIFY to CONFIG_KASAN_TAGS_IDENTIFY
2021-06-28 · Reviewed-by -
STALE1864d
[PATCH v4 2/3] kasan: integrate the common part of two KASAN tag-based modes
2021-06-26 · Suggested-by -
STALE1864d
REVIEWED: 8 (8M) [PATCH v4 1/3] kasan: rename CONFIG_KASAN_SW_TAGS_IDENTIFY to CONFIG_KASAN_TAGS_IDENTIFY
2021-06-26 · Suggested-by -
STALE1864d
REVIEWED: 8 (8M) [PATCH v4 3/3] kasan: add memory corruption identification support for hardware tag-based mode
2021-06-26 · Suggested-by -
STALE1869d
[PATCH v2 1/1] kasan: Add memzero init for unaligned size under SLUB debug
2021-06-23 · Suggested-by -
STALE1866d
[PATCH v3 1/3] kasan: rename CONFIG_KASAN_SW_TAGS_IDENTIFY to CONFIG_KASAN_TAGS_IDENTIFY
2021-06-20 · Suggested-by -
STALE1866d
[PATCH v3 3/3] kasan: add memory corruption identification support for hardware tag-based mode
2021-06-20 · Suggested-by -
STALE1866d
[PATCH v3 2/3] kasan: integrate the common part of two KASAN tag-based modes
2021-06-20 · Suggested-by -
STALE1898d
REVIEWED: 5 (5M) Re: [PATCH v2] arm64: mm: don't use CON and BLK mapping if KFENCE is enabled
2021-05-25 · Tested-by -
STALE1898d
LANDED: 12 (12M) [PATCH v2] arm64: mm: don't use CON and BLK mapping if KFENCE is enabled
2021-05-25 · Acked-by -
STALE1899d
REVIEWED: 5 (5M) Re: [PATCH] arm64: mm: don't use CON and BLK mapping if KFENCE is enabled
2021-05-24 · Acked-by -
DORMANTno replies
REVIEWED: 5 (5M) Re: [PATCH] kasan: fix per-page tags for non-page_alloc pages
2021-03-11 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) [PATCH v3 1/5] arm64: kasan: allow to init memory when setting tags
2021-03-09 · Acked-by -
DORMANTno replies
REVIEWED: 5 (5M) [PATCH v3 2/5] kasan: init memory in kasan_(un)poison for HW_TAGS
2021-03-09 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) [PATCH v3 3/5] kasan, mm: integrate page_alloc init with HW_TAGS
2021-03-09 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) [PATCH v3 5/5] kasan, mm: integrate slab init_on_free with HW_TAGS
2021-03-09 · Reviewed-by -
DORMANTno replies
REVIEWED: 5 (5M) [PATCH v3 4/5] kasan, mm: integrate slab init_on_alloc with HW_TAGS
2021-03-09 · Reviewed-by -
STALE1975d
REVIEWED: 5 (5M) Re: [PATCH v2 5/5] kasan, mm: integrate slab init_on_free with HW_TAGS
2021-03-08 · Reviewed-by -
STALE1975d
REVIEWED: 5 (5M) Re: [PATCH v2 4/5] kasan, mm: integrate slab init_on_alloc with HW_TAGS
2021-03-08 · Reviewed-by -
STALE1975d
REVIEWED: 5 (5M) Re: [PATCH v2 3/5] kasan, mm: integrate page_alloc init with HW_TAGS
2021-03-08 · Reviewed-by -
STALE1975d
REVIEWED: 5 (5M) [PATCH v2 1/5] arm64: kasan: allow to init memory when setting tags
2021-03-08 · Acked-by -
STALE1975d
REVIEWED: 5 (5M) [PATCH v2 2/5] kasan: init memory in kasan_(un)poison for HW_TAGS
2021-03-08 · Reviewed-by -
STALE1976d
REVIEWED: 5 (5M) Re: [PATCH 2/5] kasan: init memory in kasan_(un)poison for HW_TAGS
2021-03-08 · Reviewed-by -
STALE1976d
REVIEWED: 5 (5M) Re: [PATCH 1/5] arm64: kasan: allow to init memory when setting tags
2021-03-08 · Acked-by -
DORMANTno replies
REVIEWED: 5 (5M) Re: [PATCH] kasan: fix stack traces dependency for HW_TAGS
2021-02-08 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) Re: [PATCH v3 mm 13/13] kasan: clarify that only first bug is reported in HW_TAGS
2021-02-08 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) Re: [PATCH v3 mm 11/13] kasan: inline HW_TAGS helper functions
2021-02-08 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) Re: [PATCH v3 mm 08/13] kasan, mm: optimize krealloc poisoning
2021-02-08 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v2 03/12] kasan: optimize large kmalloc poisoning
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v2 09/12] kasan: ensure poisoning size alignment
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v2 05/12] kasan: unify large kfree checks
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v2 07/12] kasan, mm: fail krealloc on freed objects
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v2 01/12] kasan, mm: don't save alloc stacks twice
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v2 02/12] kasan, mm: optimize kmalloc poisoning
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v2 06/12] kasan: rework krealloc tests
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v2 04/12] kasan: clean up setting free info in kasan_slab_free
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v3 mm 09/13] kasan: ensure poisoning size alignment
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v3 mm 02/13] kasan, mm: optimize kmalloc poisoning
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v3 mm 03/13] kasan: optimize large kmalloc poisoning
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v3 mm 04/13] kasan: clean up setting free info in kasan_slab_free
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v3 mm 05/13] kasan: unify large kfree checks
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v3 mm 07/13] kasan, mm: fail krealloc on freed objects
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v3 mm 06/13] kasan: rework krealloc tests
2021-02-05 · Reviewed-by -
STALE2003d
REVIEWED: 5 (5M) [PATCH v3 mm 01/13] kasan, mm: don't save alloc stacks twice
2021-02-05 · Reviewed-by -
STALE2008d
REVIEWED: 5 (5M) Re: [PATCH 09/12] kasan: ensure poisoning size alignment
2021-02-03 · Reviewed-by -
STALE2008d
REVIEWED: 5 (5M) Re: [PATCH 07/12] kasan, mm: remove krealloc side-effect
2021-02-03 · Reviewed-by -
STALE2008d
REVIEWED: 5 (5M) Re: [PATCH 06/12] kasan: rework krealloc tests
2021-02-03 · Reviewed-by -
STALE2008d
REVIEWED: 5 (5M) Re: [PATCH 05/12] kasan: unify large kfree checks
2021-02-03 · Reviewed-by -
STALE2008d
REVIEWED: 5 (5M) Re: [PATCH 02/12] kasan, mm: optimize kmalloc poisoning
2021-02-02 · Reviewed-by -
STALE2008d
REVIEWED: 5 (5M) Re: [PATCH 04/12] kasan: clean up setting free info in kasan_slab_free
2021-02-02 · Reviewed-by -
STALE2008d
REVIEWED: 5 (5M) Re: [PATCH 03/12] kasan: optimize large kmalloc poisoning
2021-02-02 · Reviewed-by