From: Cai Huoqing <hidden> Date: 2021-09-02 06:37:17
Since provide the helper function devm_platform_ioremap_resource_byname()
which is wrap platform_get_resource_byname() and devm_ioremap_resource().
But sometimes, many drivers still need to use the resource variables obtained
by platform_get_resource(). In these case, provide this helper function
devm_platform_get_and_ioremap_resource_byname().
devm_platform_get_and_ioremap_resource_byname will be used:
.../platform/sti/c8sectpfe/c8sectpfe-core.c | 7 ++---
drivers/pci/controller/pcie-mediatek-gen3.c | 5 +---
Cai Huoqing (3):
driver core: platform: Add the helper function
devm_platform_get_and_ioremap_resource_byname()
media: sti/c8sectpfe: Make use of the helper function
devm_platform_get_and_ioremap_resource_byname()
PCI: mediatek-gen3: Make use of the helper function
devm_platform_get_and_ioremap_resource_byname()
drivers/base/platform.c | 30 ++++++++++++++++---
.../platform/sti/c8sectpfe/c8sectpfe-core.c | 7 ++---
drivers/pci/controller/pcie-mediatek-gen3.c | 5 +---
include/linux/platform_device.h | 3 ++
4 files changed, 32 insertions(+), 13 deletions(-)
--
2.25.1
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Cai Huoqing <hidden> Date: 2021-09-02 06:37:19
Use the devm_platform_get_and_ioremap_resource_byname() helper
instead of calling platform_get_resource_byname() and
devm_ioremap_resource() separately.
Signed-off-by: Cai Huoqing <redacted>
---
v1->v2: Use devm_platform_get_and_ioremap_resource_byname()
instead of devm_platform_ioremap_resource_byname().
drivers/pci/controller/pcie-mediatek-gen3.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
From: Cai Huoqing <hidden> Date: 2021-09-02 06:37:21
Since provide the helper function devm_platform_ioremap_resource_byname()
which is wrap platform_get_resource_byname() and devm_ioremap_resource().
But sometimes, many drivers still need to use the resource variables
obtained by platform_get_resource(). In these cases, provide this helper
function devm_platform_get_and_ioremap_resource_byname().
Signed-off-by: Cai Huoqing <redacted>
---
v1->v2: Resend this patch as part of a patch series that uses
the new function.
drivers/base/platform.c | 30 ++++++++++++++++++++++++++----
include/linux/platform_device.h | 3 +++
2 files changed, 29 insertions(+), 4 deletions(-)
From: Cai Huoqing <hidden> Date: 2021-09-02 06:37:22
Use the devm_platform_get_and_ioremap_resource_byname() helper
instead of calling platform_get_resource_byname() and
devm_ioremap_resource() separately.
Signed-off-by: Cai Huoqing <redacted>
---
v1->v2: Use devm_platform_get_and_ioremap_resource_byname()
instead of devm_platform_ioremap_resource_byname().
drivers/media/platform/sti/c8sectpfe/c8sectpfe-core.c | 7 ++-----
1 file changed, 2 insertions(+), 5 deletions(-)
On Thu, Sep 02, 2021 at 02:37:00PM +0800, Cai Huoqing wrote:
quoted hunk
Since provide the helper function devm_platform_ioremap_resource_byname()
which is wrap platform_get_resource_byname() and devm_ioremap_resource().
But sometimes, many drivers still need to use the resource variables
obtained by platform_get_resource(). In these cases, provide this helper
function devm_platform_get_and_ioremap_resource_byname().
Signed-off-by: Cai Huoqing <redacted>
---
v1->v2: Resend this patch as part of a patch series that uses
the new function.
drivers/base/platform.c | 30 ++++++++++++++++++++++++++----
include/linux/platform_device.h | 3 +++
2 files changed, 29 insertions(+), 4 deletions(-)
You forgot to check the return value of this call :(
Which means you did not test this? Why not?
But step back, _WHY_ is this needed at all? How deep are we going to
get with the "devm_platform_get_and_do_this_and_that_and_that" type
functions here?
You show 2 users of this call, and they save what, 1-2 lines of code
here?
What is the real need for this?
thanks,
greg k-h
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
From: Cai Huoqing <hidden> Date: 2021-09-02 08:07:29
On 02 Sep 21 08:52:45, Greg KH wrote:
On Thu, Sep 02, 2021 at 02:37:00PM +0800, Cai Huoqing wrote:
quoted
Since provide the helper function devm_platform_ioremap_resource_byname()
which is wrap platform_get_resource_byname() and devm_ioremap_resource().
But sometimes, many drivers still need to use the resource variables
obtained by platform_get_resource(). In these cases, provide this helper
function devm_platform_get_and_ioremap_resource_byname().
Signed-off-by: Cai Huoqing <redacted>
---
v1->v2: Resend this patch as part of a patch series that uses
the new function.
drivers/base/platform.c | 30 ++++++++++++++++++++++++++----
include/linux/platform_device.h | 3 +++
2 files changed, 29 insertions(+), 4 deletions(-)
You forgot to check the return value of this call :(
devm_ioremap_resource wiil check it and print error message, here:
./lib/devres.c:136:__devm_ioremap_resource(
if (!res || resource_type(res) != IORESOURCE_MEM) {
dev_err(dev, "invalid resource\n");
return IOMEM_ERR_PTR(-EINVAL);
Which means you did not test this? Why not?
But step back, _WHY_ is this needed at all? How deep are we going to
get with the "devm_platform_get_and_do_this_and_that_and_that" type
functions here?
the function name seems too long, how can I rename it:)
You show 2 users of this call, and they save what, 1-2 lines of code
here?
What is the real need for this?
thanks,
greg k-h
On Thu, Sep 02, 2021 at 04:05:39PM +0800, Cai Huoqing wrote:
On 02 Sep 21 08:52:45, Greg KH wrote:
quoted
On Thu, Sep 02, 2021 at 02:37:00PM +0800, Cai Huoqing wrote:
quoted
Since provide the helper function devm_platform_ioremap_resource_byname()
which is wrap platform_get_resource_byname() and devm_ioremap_resource().
But sometimes, many drivers still need to use the resource variables
obtained by platform_get_resource(). In these cases, provide this helper
function devm_platform_get_and_ioremap_resource_byname().
Signed-off-by: Cai Huoqing <redacted>
---
v1->v2: Resend this patch as part of a patch series that uses
the new function.
drivers/base/platform.c | 30 ++++++++++++++++++++++++++----
include/linux/platform_device.h | 3 +++
2 files changed, 29 insertions(+), 4 deletions(-)
You forgot to check the return value of this call :(
devm_ioremap_resource wiil check it and print error message, here:
./lib/devres.c:136:__devm_ioremap_resource(
if (!res || resource_type(res) != IORESOURCE_MEM) {
dev_err(dev, "invalid resource\n");
return IOMEM_ERR_PTR(-EINVAL);
And then you move on and use the resource :(
Please properly test your code.
quoted
Which means you did not test this? Why not?
But step back, _WHY_ is this needed at all? How deep are we going to
get with the "devm_platform_get_and_do_this_and_that_and_that" type
functions here?
the function name seems too long, how can I rename it:)
You have not shown a requirement that this new function is needed at
all.
Why are you making this change? Why do you want to do this? What is it
helping out with?
thanks,
greg k-h
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel