Macro 'CLIDR_LOUU_SHIFT' and 'CLIDR_LOUIS_SHIFT' are defined, so use
these to replace the magic numbers.
Cc: Catalin Marinas <catalin.marinas@arm.com>
Cc: Will Deacon <will@kernel.org>
Cc: Marc Zyngier <maz@kernel.org>
Signed-off-by: Shaokun Zhang <redacted>
---
arch/arm64/kernel/cpufeature.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
From: Will Deacon <will@kernel.org> Date: 2021-07-15 16:33:20
On Wed, Jul 14, 2021 at 02:13:03PM +0800, Shaokun Zhang wrote:
quoted hunk
Macro 'CLIDR_LOUU_SHIFT' and 'CLIDR_LOUIS_SHIFT' are defined, so use
these to replace the magic numbers.
Cc: Catalin Marinas <catalin.marinas@arm.com>
Cc: Will Deacon <will@kernel.org>
Cc: Marc Zyngier <maz@kernel.org>
Signed-off-by: Shaokun Zhang <redacted>
---
arch/arm64/kernel/cpufeature.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
@@ -1733,7 +1733,7 @@ static void cpu_has_fwb(const struct arm64_cpu_capabilities *__unused)u64val=read_sysreg_s(SYS_CLIDR_EL1);/* Check that CLIDR_EL1.LOU{U,IS} are both 0 */-WARN_ON(val&(7<<27|7<<21));+WARN_ON(val&(7<<CLIDR_LOUU_SHIFT|7<<CLIDR_LOUIS_SHIFT));}
I think this would be even better as:
WARN_ON(CLIDR_LOUU(val) || CLIDR_LOUIS(val));
Will
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
On Wed, Jul 14, 2021 at 02:13:03PM +0800, Shaokun Zhang wrote:
quoted
Macro 'CLIDR_LOUU_SHIFT' and 'CLIDR_LOUIS_SHIFT' are defined, so use
these to replace the magic numbers.
Cc: Catalin Marinas <catalin.marinas@arm.com>
Cc: Will Deacon <will@kernel.org>
Cc: Marc Zyngier <maz@kernel.org>
Signed-off-by: Shaokun Zhang <redacted>
---
arch/arm64/kernel/cpufeature.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)