Re: [PATCH v2] tty/serial: at91: restore dynamic driver binding

4 messages, 3 authors, 2016-02-25 · open the first message on its own page

Re: [PATCH v2] tty/serial: at91: restore dynamic driver binding

From: Nicolas Ferre <hidden>
Date: 2016-02-25 10:01:05

Le 25/02/2016 10:23, Romain Izard a ?crit :
In commit c39dfebc7798956fd2140ae6321786ff35da30c3, the modular support
code for atmel_serial was removed, as the driver cannot be built as a
module. Because no use case was proposed, the dynamic driver binding
support was removed as well.

The atmel_serial driver can manage up to 7 serial controllers, which are
multiplexed with other functions. For example, in the Atmel SAMA5D2, the
Flexcom controllers can work as USART, SPI or I2C controllers, and on
all Atmel devices serial lines can be reconfigured as GPIOs.

My use case uses GPIOs to transfer a firmware update using a custom
protocol on the lines used as a serial port during the normal life of
the device. If it is not possible to unbind the atmel_serial driver, the
GPIO lines remain reserved and prevent this case from working.

This patch reinstates the atmel_serial_remove function, and fixes it as
it failed to clear the "clk" field on removal, triggering an oops when
a device was bound again after being unbound.

Signed-off-by: Romain Izard <redacted>
Even if you didn't follow my advice for not including unneeded changes
in of the last patch chunk, there's no use delaying the patch just for
this. So, here is my:

Acked-by: Nicolas Ferre <redacted>

Thanks, bye.

PS: another advice: please include linux-arm-kernel as well in your CC
list for work on the AT91 platforms: most of the reviewers are there.
quoted hunk
---
Changelog:
v2: Add the rationale for keeping the "remove" function as a comment.


 drivers/tty/serial/atmel_serial.c | 39 ++++++++++++++++++++++++++++++++++++---
 1 file changed, 36 insertions(+), 3 deletions(-)
diff --git a/drivers/tty/serial/atmel_serial.c b/drivers/tty/serial/atmel_serial.c
index 1c0884d8ef32..b1f3a5b26830 100644
--- a/drivers/tty/serial/atmel_serial.c
+++ b/drivers/tty/serial/atmel_serial.c
@@ -2759,14 +2759,47 @@ err:
 	return ret;
 }
 
+/*
+ * Even if the driver is not modular, it makes sense to be able to
+ * unbind a device: there can be many bound devices, and there are
+ * situations where dynamic binding and unbinding can be useful.
+ *
+ * For example, a connected device can require a specific firmware update
+ * protocol that needs bitbanging on IO lines, but use the regular serial
+ * port in the normal case.
+ */
+static int atmel_serial_remove(struct platform_device *pdev)
+{
+	struct uart_port *port = platform_get_drvdata(pdev);
+	struct atmel_uart_port *atmel_port = to_atmel_uart_port(port);
+	int ret = 0;
+
+	tasklet_kill(&atmel_port->tasklet);
+
+	device_init_wakeup(&pdev->dev, 0);
+
+	ret = uart_remove_one_port(&atmel_uart, port);
+
+	kfree(atmel_port->rx_ring.buf);
+
+	/* "port" is allocated statically, so we shouldn't free it */
+
+	clear_bit(port->line, atmel_ports_in_use);
+
+	clk_put(atmel_port->clk);
+	atmel_port->clk = NULL;
+
+	return ret;
+}
+
 static struct platform_driver atmel_serial_driver = {
 	.probe		= atmel_serial_probe,
+	.remove		= atmel_serial_remove,
 	.suspend	= atmel_serial_suspend,
 	.resume		= atmel_serial_resume,
 	.driver		= {
-		.name			= "atmel_usart",
-		.of_match_table		= of_match_ptr(atmel_serial_dt_ids),
-		.suppress_bind_attrs    = true,
+		.name	= "atmel_usart",
+		.of_match_table	= of_match_ptr(atmel_serial_dt_ids),
 	},
 };
 

-- 
Nicolas Ferre

Re: [PATCH v2] tty/serial: at91: restore dynamic driver binding

From: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Date: 2016-02-25 16:24:33

On Thu, Feb 25, 2016 at 11:01:07AM +0100, Nicolas Ferre wrote:
Le 25/02/2016 10:23, Romain Izard a ?crit :
quoted
In commit c39dfebc7798956fd2140ae6321786ff35da30c3, the modular support
code for atmel_serial was removed, as the driver cannot be built as a
module. Because no use case was proposed, the dynamic driver binding
support was removed as well.

The atmel_serial driver can manage up to 7 serial controllers, which are
multiplexed with other functions. For example, in the Atmel SAMA5D2, the
Flexcom controllers can work as USART, SPI or I2C controllers, and on
all Atmel devices serial lines can be reconfigured as GPIOs.

My use case uses GPIOs to transfer a firmware update using a custom
protocol on the lines used as a serial port during the normal life of
the device. If it is not possible to unbind the atmel_serial driver, the
GPIO lines remain reserved and prevent this case from working.

This patch reinstates the atmel_serial_remove function, and fixes it as
it failed to clear the "clk" field on removal, triggering an oops when
a device was bound again after being unbound.

Signed-off-by: Romain Izard <redacted>
Even if you didn't follow my advice for not including unneeded changes
in of the last patch chunk, there's no use delaying the patch just for
this. So, here is my:
Yes there is, I'm not going to take this, Romain please fix it properly.

greg k-h

Re: [PATCH v2] tty/serial: at91: restore dynamic driver binding

From: Romain Izard <hidden>
Date: 2016-02-25 17:08:41

2016-02-25 17:09 GMT+01:00 Greg Kroah-Hartman
[off-list ref]:
On Thu, Feb 25, 2016 at 11:01:07AM +0100, Nicolas Ferre wrote:
quoted
Le 25/02/2016 10:23, Romain Izard a ?crit :
quoted
In commit c39dfebc7798956fd2140ae6321786ff35da30c3, the modular
support code for atmel_serial was removed, as the driver cannot be
built as a module. Because no use case was proposed, the dynamic
driver binding support was removed as well.

The atmel_serial driver can manage up to 7 serial controllers,
which are multiplexed with other functions. For example, in the
Atmel SAMA5D2, the Flexcom controllers can work as USART, SPI or
I2C controllers, and on all Atmel devices serial lines can be
reconfigured as GPIOs.

My use case uses GPIOs to transfer a firmware update using a custom
protocol on the lines used as a serial port during the normal life
of the device. If it is not possible to unbind the atmel_serial
driver, the GPIO lines remain reserved and prevent this case from
working.

This patch reinstates the atmel_serial_remove function, and fixes
it as it failed to clear the "clk" field on removal, triggering an
oops when a device was bound again after being unbound.

Signed-off-by: Romain Izard <redacted>
Even if you didn't follow my advice for not including unneeded
changes in of the last patch chunk, there's no use delaying the patch
just for this. So, here is my:
Yes there is, I'm not going to take this, Romain please fix it
properly.
Are we really arguing about the alignement of of_match_table in the
platform_driver initializer?

Among other things, Paul's patch changed the alignment to match the
width of the "suppress_bind_attrs" member. As I simply used 'git revert
-p' to revert the parts of the patch that bothered me, the alignment
returned to what it was before.

Or am I missing something else ?

-- 
Romain Izard

Re: [PATCH v2] tty/serial: at91: restore dynamic driver binding

From: Nicolas Ferre <hidden>
Date: 2016-02-25 17:24:12

Le 25/02/2016 18:08, Romain Izard a ?crit :
2016-02-25 17:09 GMT+01:00 Greg Kroah-Hartman
[off-list ref]:
quoted
On Thu, Feb 25, 2016 at 11:01:07AM +0100, Nicolas Ferre wrote:
quoted
Le 25/02/2016 10:23, Romain Izard a ?crit :
quoted
In commit c39dfebc7798956fd2140ae6321786ff35da30c3, the modular
support code for atmel_serial was removed, as the driver cannot be
built as a module. Because no use case was proposed, the dynamic
driver binding support was removed as well.

The atmel_serial driver can manage up to 7 serial controllers,
which are multiplexed with other functions. For example, in the
Atmel SAMA5D2, the Flexcom controllers can work as USART, SPI or
I2C controllers, and on all Atmel devices serial lines can be
reconfigured as GPIOs.

My use case uses GPIOs to transfer a firmware update using a custom
protocol on the lines used as a serial port during the normal life
of the device. If it is not possible to unbind the atmel_serial
driver, the GPIO lines remain reserved and prevent this case from
working.

This patch reinstates the atmel_serial_remove function, and fixes
it as it failed to clear the "clk" field on removal, triggering an
oops when a device was bound again after being unbound.

Signed-off-by: Romain Izard <redacted>
Even if you didn't follow my advice for not including unneeded
changes in of the last patch chunk, there's no use delaying the patch
just for this. So, here is my:
Yes there is, I'm not going to take this, Romain please fix it
properly.
Are we really arguing about the alignement of of_match_table in the
platform_driver initializer?

Among other things, Paul's patch changed the alignment to match the
width of the "suppress_bind_attrs" member. As I simply used 'git revert
-p' to revert the parts of the patch that bothered me, the alignment
returned to what it was before.

Or am I missing something else ?
Romain,

We are just saying that a patch with:

-		.name			= "atmel_usart",
-		.of_match_table		= of_match_ptr(atmel_serial_dt_ids),
-		.suppress_bind_attrs    = true,
+		.name	= "atmel_usart",
+		.of_match_table	= of_match_ptr(atmel_serial_dt_ids),

Is less readable than a patch with only the relevant part, the single line:

-		.suppress_bind_attrs = true,

So, whichever is the history of the patch, it has to simply modify the needed
lines so that we don't even ask ourselves what is the purpose of some of the changes.

Bye,
-- 
Nicolas Ferre
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help