[PATCH] dts: add specific compatible type for Terasic DE0-NANO-SoC Board

Subsystems: the rest

STALE3809d

7 messages, 3 authors, 2016-02-25 · open the first message on its own page

[PATCH] dts: add specific compatible type for Terasic DE0-NANO-SoC Board

From: Tim Sander <hidden>
Date: 2016-02-12 13:35:38

From: Tim Sander <redacted>

Add a more specific compatible string:"terasic,de0-nano-soc" for respective board.
Background: when checking for bootspec entries, some board specific fixups
                         are not apropriate for board of the same platform ("altr,socfpga-cyclone5").
                        The same aproach is taken with the EBV-Socrates board.

Signed-off-by: Tim Sander <redacted>
---
 arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
index 555e9caf21e1..3a427423168e 100644
--- a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
+++ b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
@@ -18,7 +18,7 @@
 
 / {
        model = "Terasic DE-0(Atlas)";
-       compatible = "altr,socfpga-cyclone5", "altr,socfpga";
+       compatible = "terasic,de0-nano-soc"," altr,socfpga-cyclone5", "altr,socfpga";
 
        chosen {
                bootargs = "earlyprintk";
-- 
1.9.1

Re: [PATCH] dts: add specific compatible type for Terasic DE0-NANO-SoC Board

From: Dinh Nguyen <hidden>
Date: 2016-02-24 16:57:39

Hi Tim,

On Fri, 12 Feb 2016, Tim Sander wrote:
From: Tim Sander <redacted>

Add a more specific compatible string:"terasic,de0-nano-soc" for respective board.
Background: when checking for bootspec entries, some board specific fixups
                         are not apropriate for board of the same platform ("altr,socfpga-cyclone5").
                        The same aproach is taken with the EBV-Socrates board.
Please fix up the spacing in the commit message.
quoted hunk
Signed-off-by: Tim Sander <redacted>
---
 arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
index 555e9caf21e1..3a427423168e 100644
--- a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
+++ b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
@@ -18,7 +18,7 @@
 
 / {
        model = "Terasic DE-0(Atlas)";
-       compatible = "altr,socfpga-cyclone5", "altr,socfpga";
+       compatible = "terasic,de0-nano-soc"," altr,socfpga-cyclone5", "altr,socfpga";
"terasic" is not listed in Documentation/devicetree/bindings/vendor-prefixes.txt.
 
BR,
Dinh

[PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board

From: Tim Sander <hidden>
Date: 2016-02-25 10:05:17

From: Tim Sander <redacted>

Add a more specific compatible string:"terasic,de0-nano-soc" for respective board.
Background: when checking for bootspec entries, some board specific fixups are
not apropriate for board of the same platform ("altr,socfpga-cyclone5").
The same aproach is taken with the EBV-Socrates board.

Signed-off-by: Tim Sander <redacted>
---
 Documentation/devicetree/bindings/vendor-prefixes.txt | 1 +
 arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts     | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/Documentation/devicetree/bindings/vendor-prefixes.txt b/Documentation/devicetree/bindings/vendor-prefixes.txt
index 72e2c5a..d1f7803 100644
--- a/Documentation/devicetree/bindings/vendor-prefixes.txt
+++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
@@ -230,6 +230,7 @@ synology	Synology, Inc.
 tbs	TBS Technologies
 tcl	Toby Churchill Ltd.
 technologic	Technologic Systems
+terasic	Terasic Inc.
 thine	THine Electronics, Inc.
 ti	Texas Instruments
 tlm	Trusted Logic Mobility
diff --git a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
index afea364..704aa9d 100644
--- a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
+++ b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
@@ -18,7 +18,7 @@
 
 / {
 	model = "Terasic DE-0(Atlas)";
-	compatible = "altr,socfpga-cyclone5", "altr,socfpga";
+	compatible = "terasic,de0-nano-soc","altr,socfpga-cyclone5", "altr,socfpga";
 
 	chosen {
 		bootargs = "earlyprintk";
-- 
1.9.1

Re: [PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board

From: Steffen Trumtrar <hidden>
Date: 2016-02-25 10:38:38

Hi Tim!

On Thu, Feb 25, 2016 at 11:05:05AM +0100, Tim Sander wrote:
quoted hunk
From: Tim Sander <redacted>

Add a more specific compatible string:"terasic,de0-nano-soc" for respective board.
Background: when checking for bootspec entries, some board specific fixups are
not apropriate for board of the same platform ("altr,socfpga-cyclone5").
The same aproach is taken with the EBV-Socrates board.

Signed-off-by: Tim Sander <redacted>
---
 Documentation/devicetree/bindings/vendor-prefixes.txt | 1 +
 arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts     | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/Documentation/devicetree/bindings/vendor-prefixes.txt b/Documentation/devicetree/bindings/vendor-prefixes.txt
index 72e2c5a..d1f7803 100644
--- a/Documentation/devicetree/bindings/vendor-prefixes.txt
+++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
@@ -230,6 +230,7 @@ synology	Synology, Inc.
 tbs	TBS Technologies
 tcl	Toby Churchill Ltd.
 technologic	Technologic Systems
+terasic	Terasic Inc.
 thine	THine Electronics, Inc.
 ti	Texas Instruments
 tlm	Trusted Logic Mobility
You should IMHO split this up in two patches.
First patch: add terasic
quoted hunk
diff --git a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
index afea364..704aa9d 100644
--- a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
+++ b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
@@ -18,7 +18,7 @@
 
 / {
 	model = "Terasic DE-0(Atlas)";
-	compatible = "altr,socfpga-cyclone5", "altr,socfpga";
+	compatible = "terasic,de0-nano-soc","altr,socfpga-cyclone5", "altr,socfpga";
Second patch: this.
 
 	chosen {
 		bootargs = "earlyprintk";
The naming of this board still confuses me though.
It has 3 different names now:

	- de0_sockit.dts
	- Terasic DE-0(Atlas)
	- de0-nano-soc

And according to Terasic DE0-Nano-SoC is the same as Atlas-SoC with a different software?!
So all three names are actually correct ?! Weird.

Regards,
Steffen

-- 
Pengutronix e.K.                           |                             |
Industrial Linux Solutions                 | http://www.pengutronix.de/  |
Peiner Str. 6-8, 31137 Hildesheim, Germany | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

Re: [PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board

From: Dinh Nguyen <hidden>
Date: 2016-02-25 17:03:52

On 02/25/2016 04:38 AM, Steffen Trumtrar wrote:
Hi Tim!

On Thu, Feb 25, 2016 at 11:05:05AM +0100, Tim Sander wrote:
quoted
From: Tim Sander <redacted>

Add a more specific compatible string:"terasic,de0-nano-soc" for respective board.
Background: when checking for bootspec entries, some board specific fixups are
not apropriate for board of the same platform ("altr,socfpga-cyclone5").
The same aproach is taken with the EBV-Socrates board.

Signed-off-by: Tim Sander <redacted>
---
 Documentation/devicetree/bindings/vendor-prefixes.txt | 1 +
 arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts     | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/Documentation/devicetree/bindings/vendor-prefixes.txt b/Documentation/devicetree/bindings/vendor-prefixes.txt
index 72e2c5a..d1f7803 100644
--- a/Documentation/devicetree/bindings/vendor-prefixes.txt
+++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
@@ -230,6 +230,7 @@ synology	Synology, Inc.
 tbs	TBS Technologies
 tcl	Toby Churchill Ltd.
 technologic	Technologic Systems
+terasic	Terasic Inc.
 thine	THine Electronics, Inc.
 ti	Texas Instruments
 tlm	Trusted Logic Mobility
You should IMHO split this up in two patches.
First patch: add terasic
That's right. That patch will go through the DTS maintainer's tree.
quoted
diff --git a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
index afea364..704aa9d 100644
--- a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
+++ b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
@@ -18,7 +18,7 @@
 
 / {
 	model = "Terasic DE-0(Atlas)";
-	compatible = "altr,socfpga-cyclone5", "altr,socfpga";
+	compatible = "terasic,de0-nano-soc","altr,socfpga-cyclone5", "altr,socfpga";
So perhaps, "terasic,de0-sockit"?
Second patch: this.
And I can take this one.
quoted
 
 	chosen {
 		bootargs = "earlyprintk";
The naming of this board still confuses me though.
It has 3 different names now:

	- de0_sockit.dts
	- Terasic DE-0(Atlas)
	- de0-nano-soc

And according to Terasic DE0-Nano-SoC is the same as Atlas-SoC with a different software?!
So all three names are actually correct ?! Weird.
I had a hard time understanding this myself. But from what I gather
from[1], I just name the file de0_sockit.

Dinh

[1]
http://www.terasic.com.tw/cgi-bin/page/archive.pl?Language=English&CategoryNo=13&List=Simple#Category167

Re: [PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board

From: Tim Sander <hidden>
Date: 2016-02-25 23:35:12

Hi Dinh

On Thursday 25 February 2016 10:56:28 Dinh Nguyen wrote:
On 02/25/2016 04:38 AM, Steffen Trumtrar wrote:
quoted
Hi Tim!

On Thu, Feb 25, 2016 at 11:05:05AM +0100, Tim Sander wrote:
quoted
From: Tim Sander <redacted>

Add a more specific compatible string:"terasic,de0-nano-soc" for
respective board. Background: when checking for bootspec entries, some
board specific fixups are not apropriate for board of the same platform
("altr,socfpga-cyclone5"). The same aproach is taken with the
EBV-Socrates board.

Signed-off-by: Tim Sander <redacted>
---

 Documentation/devicetree/bindings/vendor-prefixes.txt | 1 +
 arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts     | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/Documentation/devicetree/bindings/vendor-prefixes.txt
b/Documentation/devicetree/bindings/vendor-prefixes.txt index
72e2c5a..d1f7803 100644
--- a/Documentation/devicetree/bindings/vendor-prefixes.txt
+++ b/Documentation/devicetree/bindings/vendor-prefixes.txt
@@ -230,6 +230,7 @@ synology	Synology, Inc.

 tbs	TBS Technologies
 tcl	Toby Churchill Ltd.
 technologic	Technologic Systems

+terasic	Terasic Inc.

 thine	THine Electronics, Inc.
 ti	Texas Instruments
 tlm	Trusted Logic Mobility
You should IMHO split this up in two patches.
First patch: add terasic
That's right. That patch will go through the DTS maintainer's tree.
Ah well for such a simple patch it turns out more complicated than thought :-)
Will do as soon as there is agreement on a name which does not seem that 
easy...
quoted
quoted
diff --git a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts index
afea364..704aa9d 100644
--- a/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
+++ b/arch/arm/boot/dts/socfpga_cyclone5_de0_sockit.dts
@@ -18,7 +18,7 @@

 / {
 
 	model = "Terasic DE-0(Atlas)";

-	compatible = "altr,socfpga-cyclone5", "altr,socfpga";
+	compatible = "terasic,de0-nano-soc","altr,socfpga-cyclone5",
"altr,socfpga";
So perhaps, "terasic,de0-sockit"?
quoted
Second patch: this.
And I can take this one.
quoted
quoted
 	chosen {
 	
 		bootargs = "earlyprintk";
The naming of this board still confuses me though.

It has 3 different names now:
	- de0_sockit.dts
	- Terasic DE-0(Atlas)
	- de0-nano-soc

And according to Terasic DE0-Nano-SoC is the same as Atlas-SoC with a
different software?! So all three names are actually correct ?! Weird.
I had a hard time understanding this myself. But from what I gather
from[1], I just name the file de0_sockit.
As far as i remember there are different de0 and different sockit boards, so 
the name does not seem to be as concise? I don't care but i would say that
de0-nano-soc is the most concise and easier to search for than atlas which
might turn up more false postives?

But as long as there is a more selective name than cyclone5 everthing is fine
with me.

Best regards
Tim

Re: [PATCH v2] dts: add specific compatible type for Terasic DE0-NANO-SoC Board

From: Dinh Nguyen <hidden>
Date: 2016-02-25 23:45:42

On 02/25/2016 05:34 PM, Tim Sander wrote:
As far as i remember there are different de0 and different sockit boards, so 
the name does not seem to be as concise? I don't care but i would say that
de0-nano-soc is the most concise and easier to search for than atlas which
might turn up more false postives?
I'm fine with "terasic,de0-nano-soc".

Dinh
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help