From: Paul Gortmaker <hidden> Date: 2012-03-21 02:15:28
Commit bf4289cba02b8cf770ecd7959ca70839f0dd9d3c (linux-next)
"ATMEL: fix nand ecc support"
indicated that it wanted to "Move platform data to a common
header include/linux/platform_data/atmel_nand.h" and the new
header even had re-include protectors with:
#ifndef __ATMEL_NAND_H__
However, the file that was added was simply called atmel.h
and this caused avr32 defconfig to fail with:
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:10:44: error: linux/platform_data/atmel_nand.h: No such file or directory
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: 'struct atmel_nand_data' declared inside parameter list
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: its scope is only this definition or declaration, which is probably not what you want
make[2]: *** [arch/avr32/boards/atstk1000/setup.o] Error 1
Rename the file to match the original intention, and fix up the
users who reference the bad name without the _nand suffix.
Signed-off-by: Paul Gortmaker <redacted>
CC: Jean-Christophe PLAGNIOL-VILLARD <redacted>
CC: Hans-Christian Egtvedt <redacted>
CC: David Woodhouse <dwmw2@infradead.org>
---
arch/arm/mach-at91/include/mach/board.h | 2 +-
drivers/mtd/nand/atmel_nand.c | 2 +-
.../linux/platform_data/{atmel.h => atmel_nand.h} | 0
3 files changed, 2 insertions(+), 2 deletions(-)
rename include/linux/platform_data/{atmel.h => atmel_nand.h} (100%)
diff --git a/include/linux/platform_data/atmel.h b/include/linux/platform_data/atmel_nand.hsimilarity index 100%rename from include/linux/platform_data/atmel.hrename to include/linux/platform_data/atmel_nand.h
--
1.7.9.1
Around Tue 20 Mar 2012 22:15:28 -0400 or thereabout, Paul Gortmaker wrote:
Commit bf4289cba02b8cf770ecd7959ca70839f0dd9d3c (linux-next)
"ATMEL: fix nand ecc support"
indicated that it wanted to "Move platform data to a common
header include/linux/platform_data/atmel_nand.h" and the new
header even had re-include protectors with:
#ifndef __ATMEL_NAND_H__
However, the file that was added was simply called atmel.h
and this caused avr32 defconfig to fail with:
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:10:44: error: linux/platform_data/atmel_nand.h: No such file or directory
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: 'struct atmel_nand_data' declared inside parameter list
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: its scope is only this definition or declaration, which is probably not what you want
make[2]: *** [arch/avr32/boards/atstk1000/setup.o] Error 1
Rename the file to match the original intention, and fix up the
users who reference the bad name without the _nand suffix.
Thanks fixing this.
Signed-off-by: Paul Gortmaker <redacted>
CC: Jean-Christophe PLAGNIOL-VILLARD <redacted>
CC: Hans-Christian Egtvedt <redacted>
CC: David Woodhouse <dwmw2@infradead.org>
diff --git a/include/linux/platform_data/atmel.h b/include/linux/platform_data/atmel_nand.hsimilarity index 100%rename from include/linux/platform_data/atmel.hrename to include/linux/platform_data/atmel_nand.h
From: Nicolas Ferre <hidden> Date: 2012-03-21 08:26:23
On 03/21/2012 08:26 AM, Hans-Christian Egtvedt :
Around Tue 20 Mar 2012 22:15:28 -0400 or thereabout, Paul Gortmaker wrote:
quoted
Commit bf4289cba02b8cf770ecd7959ca70839f0dd9d3c (linux-next)
"ATMEL: fix nand ecc support"
indicated that it wanted to "Move platform data to a common
header include/linux/platform_data/atmel_nand.h" and the new
header even had re-include protectors with:
#ifndef __ATMEL_NAND_H__
However, the file that was added was simply called atmel.h
and this caused avr32 defconfig to fail with:
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:10:44: error: linux/platform_data/atmel_nand.h: No such file or directory
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: 'struct atmel_nand_data' declared inside parameter list
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: its scope is only this definition or declaration, which is probably not what you want
make[2]: *** [arch/avr32/boards/atstk1000/setup.o] Error 1
Rename the file to match the original intention, and fix up the
users who reference the bad name without the _nand suffix.
Thanks fixing this.
Yes, we need to fix this. But I would not like to see this
"platform_data/atmel.h" renamed: I think that this file was designed to
collect several common platform data (ie: not just NAND related).
So maybe we should just rename the entry that exists in
mach-at32ap/include/mach/board.h
and remove all occurrences of platform_data/atmel_nand.h
quoted
Signed-off-by: Paul Gortmaker <redacted>
CC: Jean-Christophe PLAGNIOL-VILLARD <redacted>
CC: Hans-Christian Egtvedt <redacted>
CC: David Woodhouse <dwmw2@infradead.org>
diff --git a/include/linux/platform_data/atmel.h b/include/linux/platform_data/atmel_nand.hsimilarity index 100%rename from include/linux/platform_data/atmel.hrename to include/linux/platform_data/atmel_nand.h
From: Paul Gortmaker <hidden> Date: 2012-03-22 05:18:40
[Re: [PATCH] avr32: fix build failures from mis-naming of atmel_nand.h] On 21/03/2012 (Wed 09:26) Nicolas Ferre wrote:
On 03/21/2012 08:26 AM, Hans-Christian Egtvedt :
quoted
Around Tue 20 Mar 2012 22:15:28 -0400 or thereabout, Paul Gortmaker wrote:
quoted
Commit bf4289cba02b8cf770ecd7959ca70839f0dd9d3c (linux-next)
"ATMEL: fix nand ecc support"
indicated that it wanted to "Move platform data to a common
header include/linux/platform_data/atmel_nand.h" and the new
header even had re-include protectors with:
#ifndef __ATMEL_NAND_H__
However, the file that was added was simply called atmel.h
and this caused avr32 defconfig to fail with:
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:10:44: error: linux/platform_data/atmel_nand.h: No such file or directory
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: 'struct atmel_nand_data' declared inside parameter list
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: its scope is only this definition or declaration, which is probably not what you want
make[2]: *** [arch/avr32/boards/atstk1000/setup.o] Error 1
Rename the file to match the original intention, and fix up the
users who reference the bad name without the _nand suffix.
Thanks fixing this.
Yes, we need to fix this. But I would not like to see this
"platform_data/atmel.h" renamed: I think that this file was designed to
collect several common platform data (ie: not just NAND related).
So maybe we should just rename the entry that exists in
mach-at32ap/include/mach/board.h
and remove all occurrences of platform_data/atmel_nand.h
Funny, since this is what I did 1st before I re-read the original commit
log in more detail. :) Oh well. Here is the alternate solution. You
guys can pick whichever one you like best. I compile tested this one
as well.
Thanks,
Paul.
---
From 73c01b7ed8fd2732661fa1ca726c48096f4651f2 Mon Sep 17 00:00:00 2001
From: Paul Gortmaker <redacted>
Date: Tue, 20 Mar 2012 21:55:46 -0400
Subject: [PATCH] avr32: fix build failures from mis-naming of atmel_nand.h
Commit bf4289cba02b8cf770ecd7959ca70839f0dd9d3c (linux-next)
"ATMEL: fix nand ecc support"
indicated that it wanted to "Move platform data to a common
header include/linux/platform_data/atmel_nand.h" and the new
header even had re-include protectors with:
#ifndef __ATMEL_NAND_H__
However, the file that was added was simply called atmel.h
and this caused avr32 defconfig to fail with:
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:10:44: error: linux/platform_data/atmel_nand.h: No such file or directory
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: 'struct atmel_nand_data' declared inside parameter list
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: its scope is only this definition or declaration, which is probably not what you want
make[2]: *** [arch/avr32/boards/atstk1000/setup.o] Error 1
It seems the scope of the file contents will expand beyond
just nand, so ignore the original intention, and fix up the
users who reference the bad name with the _nand suffix.
Signed-off-by: Paul Gortmaker <redacted>
CC: Jean-Christophe PLAGNIOL-VILLARD <redacted>
CC: Hans-Christian Egtvedt <redacted>
CC: David Woodhouse <dwmw2@infradead.org>
Around Thu 22 Mar 2012 01:18:40 -0400 or thereabout, Paul Gortmaker wrote:
[Re: [PATCH] avr32: fix build failures from mis-naming of atmel_nand.h] On 21/03/2012 (Wed 09:26) Nicolas Ferre wrote:
quoted
On 03/21/2012 08:26 AM, Hans-Christian Egtvedt :
quoted
Around Tue 20 Mar 2012 22:15:28 -0400 or thereabout, Paul Gortmaker wrote:
quoted
Commit bf4289cba02b8cf770ecd7959ca70839f0dd9d3c (linux-next)
"ATMEL: fix nand ecc support"
indicated that it wanted to "Move platform data to a common
header include/linux/platform_data/atmel_nand.h" and the new
header even had re-include protectors with:
#ifndef __ATMEL_NAND_H__
However, the file that was added was simply called atmel.h
and this caused avr32 defconfig to fail with:
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:10:44: error: linux/platform_data/atmel_nand.h: No such file or directory
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: 'struct atmel_nand_data' declared inside parameter list
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: its scope is only this definition or declaration, which is probably not what you want
make[2]: *** [arch/avr32/boards/atstk1000/setup.o] Error 1
Rename the file to match the original intention, and fix up the
users who reference the bad name without the _nand suffix.
Thanks fixing this.
Yes, we need to fix this. But I would not like to see this
"platform_data/atmel.h" renamed: I think that this file was designed to
collect several common platform data (ie: not just NAND related).
So maybe we should just rename the entry that exists in
mach-at32ap/include/mach/board.h
and remove all occurrences of platform_data/atmel_nand.h
Funny, since this is what I did 1st before I re-read the original commit
log in more detail. :) Oh well. Here is the alternate solution. You
guys can pick whichever one you like best. I compile tested this one
as well.
I'll leave it to Nicolas to sign-off on this, but the changes look fine for
me.
---
From 73c01b7ed8fd2732661fa1ca726c48096f4651f2 Mon Sep 17 00:00:00 2001
From: Paul Gortmaker <redacted>
Date: Tue, 20 Mar 2012 21:55:46 -0400
Subject: [PATCH] avr32: fix build failures from mis-naming of atmel_nand.h
Commit bf4289cba02b8cf770ecd7959ca70839f0dd9d3c (linux-next)
"ATMEL: fix nand ecc support"
indicated that it wanted to "Move platform data to a common
header include/linux/platform_data/atmel_nand.h" and the new
header even had re-include protectors with:
#ifndef __ATMEL_NAND_H__
However, the file that was added was simply called atmel.h
and this caused avr32 defconfig to fail with:
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:10:44: error: linux/platform_data/atmel_nand.h: No such file or directory
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: 'struct atmel_nand_data' declared inside parameter list
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: its scope is only this definition or declaration, which is probably not what you want
make[2]: *** [arch/avr32/boards/atstk1000/setup.o] Error 1
It seems the scope of the file contents will expand beyond
just nand, so ignore the original intention, and fix up the
users who reference the bad name with the _nand suffix.
Signed-off-by: Paul Gortmaker <redacted>
CC: Jean-Christophe PLAGNIOL-VILLARD <redacted>
CC: Hans-Christian Egtvedt <redacted>
CC: David Woodhouse <dwmw2@infradead.org>
From: Nicolas Ferre <hidden> Date: 2012-03-22 14:04:31
On 03/22/2012 01:33 PM, Hans-Christian Egtvedt :
Around Thu 22 Mar 2012 01:18:40 -0400 or thereabout, Paul Gortmaker wrote:
quoted
[Re: [PATCH] avr32: fix build failures from mis-naming of atmel_nand.h] On 21/03/2012 (Wed 09:26) Nicolas Ferre wrote:
quoted
On 03/21/2012 08:26 AM, Hans-Christian Egtvedt :
quoted
Around Tue 20 Mar 2012 22:15:28 -0400 or thereabout, Paul Gortmaker wrote:
quoted
Commit bf4289cba02b8cf770ecd7959ca70839f0dd9d3c (linux-next)
"ATMEL: fix nand ecc support"
indicated that it wanted to "Move platform data to a common
header include/linux/platform_data/atmel_nand.h" and the new
header even had re-include protectors with:
#ifndef __ATMEL_NAND_H__
However, the file that was added was simply called atmel.h
and this caused avr32 defconfig to fail with:
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:10:44: error: linux/platform_data/atmel_nand.h: No such file or directory
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: 'struct atmel_nand_data' declared inside parameter list
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: its scope is only this definition or declaration, which is probably not what you want
make[2]: *** [arch/avr32/boards/atstk1000/setup.o] Error 1
Rename the file to match the original intention, and fix up the
users who reference the bad name without the _nand suffix.
Thanks fixing this.
Yes, we need to fix this. But I would not like to see this
"platform_data/atmel.h" renamed: I think that this file was designed to
collect several common platform data (ie: not just NAND related).
So maybe we should just rename the entry that exists in
mach-at32ap/include/mach/board.h
and remove all occurrences of platform_data/atmel_nand.h
Funny, since this is what I did 1st before I re-read the original commit
log in more detail. :) Oh well. Here is the alternate solution. You
guys can pick whichever one you like best. I compile tested this one
as well.
I'll leave it to Nicolas to sign-off on this, but the changes look fine for
me.
Ok, which way do you want to follow for inclusion in mainline? I take it
through arm-soc?
quoted
---
From 73c01b7ed8fd2732661fa1ca726c48096f4651f2 Mon Sep 17 00:00:00 2001
From: Paul Gortmaker <redacted>
Date: Tue, 20 Mar 2012 21:55:46 -0400
Subject: [PATCH] avr32: fix build failures from mis-naming of atmel_nand.h
Commit bf4289cba02b8cf770ecd7959ca70839f0dd9d3c (linux-next)
"ATMEL: fix nand ecc support"
indicated that it wanted to "Move platform data to a common
header include/linux/platform_data/atmel_nand.h" and the new
header even had re-include protectors with:
#ifndef __ATMEL_NAND_H__
However, the file that was added was simply called atmel.h
and this caused avr32 defconfig to fail with:
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:10:44: error: linux/platform_data/atmel_nand.h: No such file or directory
In file included from arch/avr32/boards/atstk1000/setup.c:22:
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: 'struct atmel_nand_data' declared inside parameter list
arch/avr32/mach-at32ap/include/mach/board.h:121: warning: its scope is only this definition or declaration, which is probably not what you want
make[2]: *** [arch/avr32/boards/atstk1000/setup.o] Error 1
It seems the scope of the file contents will expand beyond
just nand, so ignore the original intention, and fix up the
users who reference the bad name with the _nand suffix.
Signed-off-by: Paul Gortmaker <redacted>
CC: Jean-Christophe PLAGNIOL-VILLARD <redacted>
CC: Hans-Christian Egtvedt <redacted>
CC: David Woodhouse <dwmw2@infradead.org>
Around Thu 22 Mar 2012 15:04:31 +0100 or thereabout, Nicolas Ferre wrote:
On 03/22/2012 01:33 PM, Hans-Christian Egtvedt :
quoted
Around Thu 22 Mar 2012 01:18:40 -0400 or thereabout, Paul Gortmaker wrote:
<snipp Atmel NAND cleanup>
quoted
quoted
quoted
Yes, we need to fix this. But I would not like to see this
"platform_data/atmel.h" renamed: I think that this file was designed to
collect several common platform data (ie: not just NAND related).
So maybe we should just rename the entry that exists in
mach-at32ap/include/mach/board.h
and remove all occurrences of platform_data/atmel_nand.h
Funny, since this is what I did 1st before I re-read the original commit
log in more detail. :) Oh well. Here is the alternate solution. You
guys can pick whichever one you like best. I compile tested this one
as well.
I'll leave it to Nicolas to sign-off on this, but the changes look fine for
me.
Ok, which way do you want to follow for inclusion in mainline? I take it
through arm-soc?
I have not gotten my key signed by any kernel developers yet, so typically
I've asked people to take it through Andrew's tree.
<snipp>
--
HcE