[PATCH v2 1/2] ARM: OMAP2+: id: Add am33xx SoC type detection

Subsystems: arm port, omap2+ support, the rest

STALE5271d

2 messages, 2 authors, 2012-03-05 · open the first message on its own page

[PATCH v2 1/2] ARM: OMAP2+: id: Add am33xx SoC type detection

From: Afzal Mohammed <hidden>
Date: 2012-02-13 06:14:45

Determine SoC type, i.e. whether GP or HS

Note: cpu_is_34xx() is true for am33xx also. Doing
cpu_is_am33xx() check after cpu_is_34xx() will not
achieve what we want due to the above reason.
Hence cpu_is_am33xx() is done before cpu_is_34xx()

Signed-off-by: Afzal Mohammed <redacted>
Signed-off-by: Vaibhav Hiremath <redacted>
---

v2: Use OMAP naming conventions for subject

 arch/arm/mach-omap2/control.h |    5 +++++
 arch/arm/mach-omap2/id.c      |    2 ++
 2 files changed, 7 insertions(+), 0 deletions(-)
diff --git a/arch/arm/mach-omap2/control.h b/arch/arm/mach-omap2/control.h
index 0ba68d3..96c4bcc 100644
--- a/arch/arm/mach-omap2/control.h
+++ b/arch/arm/mach-omap2/control.h
@@ -339,6 +339,11 @@
 #define AM35XX_VPFE_PCLK_SW_RST		BIT(4)
 
 /*
+ * CONTROL AM33XX STATUS register
+ */
+#define AM33XX_CONTROL_STATUS		0x040
+
+/*
  * CONTROL OMAP STATUS register to identify OMAP3 features
  */
 #define OMAP3_CONTROL_OMAP_STATUS	0x044c
diff --git a/arch/arm/mach-omap2/id.c b/arch/arm/mach-omap2/id.c
index 92e4d55..2879c7b 100644
--- a/arch/arm/mach-omap2/id.c
+++ b/arch/arm/mach-omap2/id.c
@@ -44,6 +44,8 @@ int omap_type(void)
 
 	if (cpu_is_omap24xx()) {
 		val = omap_ctrl_readl(OMAP24XX_CONTROL_STATUS);
+	} else if (cpu_is_am33xx()) {
+		val = omap_ctrl_readl(AM33XX_CONTROL_STATUS);
 	} else if (cpu_is_omap34xx()) {
 		val = omap_ctrl_readl(OMAP343X_CONTROL_STATUS);
 	} else if (cpu_is_omap44xx()) {
-- 
1.7.1

[PATCH v2 1/2] ARM: OMAP2+: id: Add am33xx SoC type detection

From: tony@atomide.com (Tony Lindgren)
Date: 2012-03-05 23:08:13

* Afzal Mohammed [off-list ref] [120212 22:00]:
Determine SoC type, i.e. whether GP or HS

Note: cpu_is_34xx() is true for am33xx also. Doing
cpu_is_am33xx() check after cpu_is_34xx() will not
achieve what we want due to the above reason.
Hence cpu_is_am33xx() is done before cpu_is_34xx()
Thanks, applying into fixes-non-critical-part2.

Tony
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help