documentation · Maintained
Maintainers
- M Jonathan Corbet <corbet@lwn.net>
- R Shuah Khan <skhan@linuxfoundation.org>
- R Randy Dunlap <rdunlap@infradead.org>
Paths
- F
Documentation/ - F
tools/lib/python/ - F
tools/docs/ - F
tools/net/ynl/pyynl/lib/doc_generator.py - X
Documentation/ABI/ - X
Documentation/admin-guide/media/ - X
Documentation/devicetree/ - X
Documentation/driver-api/media/ - X
Documentation/firmware-guide/acpi/ - X
Documentation/i2c/ - X
Documentation/netlink/ - X
Documentation/power/ - X
Documentation/spi/ - X
Documentation/userspace-api/media/
Last 30 days
Most active threads (last 7 days)
-
HOTtoday
[PATCH v2 0/4] kho: rename "scratch" to "bootmem"
2026-09-08 15:57 · 2 replies in 7d · Pratyush Yadav <pratyush@kernel.org> -
HOTtoday
[PATCH v2 00/12] mm: make userland page table freeing RCU-safe
2026-09-08 12:36 · 1 reply in 7d · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM3d
[PATCH v8 00/43] dyndbg: fix classmaps API for DRM, query extensions, and selftests
2026-09-05 18:14 · 4 replies in 7d · Jim Cromie via B4 Relay <devnull+jim.cromie.gmail.com@kernel.org> -
WARM2d
[PATCH v10 0/2] module: Extend module_blacklist parameter to built-in modules
2026-09-03 18:56 · 1 reply in 7d · Aaron Tomlin <atomlin@atomlin.com> -
WARM1d
[PATCH RFC v3 00/21] mm: change behavior of pXdp_get()/pXd_page() in compile-time folded pgtable
2026-09-02 11:59 · 1 reply in 7d · Yeoreum Yun <hidden>
Active reviewers (last 30 days)
-
Louis Chauvet <louis.chauvet@bootlin.com>
1 attestation (1 Reviewed-by) · last on 2026-09-05 -
Catalin Marinas <catalin.marinas@arm.com>
1 attestation (1 Acked-by) · last on 2026-08-31
Recent patches
Most-recent 30 patches in this subsystem on linux-arch (capped at 30), ordered by date desc.
-
HOTtoday
[PATCH v2 4/4] kho: rename kho_scratch= commandline parameter to kho_bootmem=
2026-09-08 · Pratyush Yadav <pratyush@kernel.org> -
HOTtoday
[PATCH v2 3/4] kho: rename KHO scratch to KHO bootmem
2026-09-08 · Pratyush Yadav <pratyush@kernel.org> -
HOTtoday
[PATCH v2 12/12] mm: change the contract for free_pgtables(), update docs
2026-09-08 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
WARM3d
[PATCH v8 33/43] dyndbg: control-parser: treat comma as a token separator
2026-09-05 · Jim Cromie via B4 Relay <devnull+jim.cromie.gmail.com@kernel.org> -
WARM3d
[PATCH v8 35/43] dyndbg: split multi-query strings with @
2026-09-05 · Jim Cromie via B4 Relay <devnull+jim.cromie.gmail.com@kernel.org> -
WARM3d
REVIEWED: 1 (1M) [PATCH v8 38/43] docs/dyndbg: add classmap info to howto
2026-09-05 · Jim Cromie via B4 Relay <devnull+jim.cromie.gmail.com@kernel.org> -
WARM3d
[PATCH v8 18/43] kbuild, dyndbg: clean up builtin module-name ambiguities
2026-09-05 · Jim Cromie via B4 Relay <devnull+jim.cromie.gmail.com@kernel.org> -
WARM2d
[PATCH v10 2/2] module: Rename module_blacklist to module_denylist
2026-09-03 · Aaron Tomlin <atomlin@atomlin.com> -
WARM1d
[PATCH RFC v3 21/21] Documentation: mm: clarify behaviour of compile-time folded page tables
2026-09-02 · Yeoreum Yun <hidden> -
HOTtoday
[PATCH 12/12] mm: change the contract for free_pgtables(), update docs
2026-09-01 · "Lorenzo Stoakes (ARM)" <ljs@kernel.org> -
COOLING7d
REVIEWED: 3 (3M) [PATCH v15 07/16] atomic: Add atomic_cond_read_*_timeout()
2026-08-31 · Ankur Arora <hidden> -
COLD22d
[PATCH v3 4/4] Test: Added self-testing and documentation
2026-08-16 · mathura kumar <hidden> -
COLD21d
[PATCH 4/4] kho: rename kho_scratch= commandline parameter to kho_bootmem=
2026-08-11 · Pratyush Yadav <pratyush@kernel.org> -
COLD21d
[PATCH 3/4] kho: rename KHO scratch to KHO bootmem
2026-08-11 · Pratyush Yadav <pratyush@kernel.org> -
COOLING14d
[PATCH v8] coredump: Add bit 9 of coredump_filter for pre-exit files before dumping
2026-08-08 · Xin Zhao <hidden> -
COLD32d
[PATCH v7] coredump: Add bit 9 of coredump_filter for pre-exit files before dumping
2026-08-07 · Xin Zhao <hidden> -
COOLING7d
[PATCH v9 2/2] module: Rename module_blacklist to module_denylist
2026-08-07 · Aaron Tomlin <atomlin@atomlin.com> -
COLD28d
[PATCH v6] coredump: Add bit 9 of coredump_filter for pre-exit files before dumping
2026-08-04 · Xin Zhao <hidden> -
COLD33d
[PATCH v8 2/2] module: Rename module_blacklist to module_denylist
2026-07-24 · Aaron Tomlin <atomlin@atomlin.com> -
COLD46d
[PATCH v7 2/2] module: Rename module_blacklist to module_denylist
2026-07-24 · Aaron Tomlin <atomlin@atomlin.com> -
COLD47d
[PATCH v7 19/29] dyndbg: use KBUILD_MODFILE for unique builtin module names
2026-07-21 · Jim Cromie <jim.cromie@gmail.com> -
COLD46d
[PATCH v6 2/2] module: Rename module_blacklist to module_denylist
2026-07-18 · Aaron Tomlin <atomlin@atomlin.com> -
WARM2d
[RFC PATCH 24/24] Documentation: describe pidfd spawn builders
2026-07-16 · Li Chen <hidden> -
COLD21d
REVIEWED: 3 (3M) [PATCH v14 07/15] atomic: Add atomic_cond_read_*_timeout()
2026-07-14 · Ankur Arora <hidden> -
COLD59d
[PATCH v3 01/26] kernel: Introduce meminspect
2026-07-08 · Mukesh Ojha <hidden> -
STALE61d
[PATCH v6 14/24] dyndbg: use KBUILD_MODFILE for unique builtin module names
2026-07-08 · Jim Cromie <jim.cromie@gmail.com> -
COOLING8d
[PATCH v19 25/40] dept: add documents for dept
2026-07-06 · Byungchul Park <byungchul@sk.com> -
STALE68d
[PATCH v5 09/18] dyndbg: use KBUILD_MODFILE for unique builtin module names
2026-07-02 · Jim Cromie <jim.cromie@gmail.com> -
STALE64d
REVIEWED: 3 (3M) [PATCH v13 07/15] atomic: Add atomic_cond_read_*_timeout()
2026-07-02 · Ankur Arora <hidden> -
COLD35d
[PATCH v5] coredump: Add bit 9 of coredump_filter for pre-exit files before dumping
2026-06-30 · Xin Zhao <hidden>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
STALE174d
REVIEWED: 4 (0M) [PATCH v6 5/5] kunit: Add documentation for warning backtrace suppression API
2026-03-17 · Albert Esteve <hidden> · 2 Reviewed-by, 1 Acked-by, 1 Tested-by -
STALE137d
REVIEWED: 4 (0M) [PATCH v7 5/5] kunit: Add documentation for warning backtrace suppression API
2026-04-20 · Albert Esteve <hidden> · 2 Reviewed-by, 1 Acked-by, 1 Tested-by -
STALE118d
REVIEWED: 6 (2M) [PATCH v8 4/4] kunit: Add documentation for warning backtrace suppression API
2026-05-04 · Albert Esteve <hidden> · 3 Reviewed-by, 1 Acked-by, 1 Tested-by -
STALE119d
REVIEWED: 5 (2M) [PATCH v9 4/4] kunit: Add documentation for warning backtrace suppression API
2026-05-08 · Albert Esteve <hidden> · 2 Reviewed-by, 1 Acked-by, 1 Tested-by -
STALE117d
REVIEWED: 5 (2M) [PATCH v10 4/4] kunit: Add documentation for warning backtrace suppression API
2026-05-13 · Albert Esteve <hidden> · 2 Reviewed-by, 1 Acked-by, 1 Tested-by -
STALE116d
REVIEWED: 5 (2M) [PATCH v12 4/4] kunit: Add documentation for warning backtrace suppression API
2026-05-15 · Albert Esteve <hidden> · 2 Reviewed-by, 1 Acked-by, 1 Tested-by -
STALE74d
REVIEWED: 5 (2M) [PATCH v13 4/4] kunit: Add documentation for warning backtrace suppression API
2026-05-15 · Albert Esteve <hidden> · 2 Reviewed-by, 1 Acked-by, 1 Tested-by -
STALE106d
REVIEWED: 2 (2M) [PATCH v2 01/24] docs/dyndbg: update examples \012 to \n
2026-05-23 · Jim Cromie <jim.cromie@gmail.com> · 1 Reviewed-by, 1 Tested-by -
STALE106d
REVIEWED: 1 (1M) [PATCH v2 02/24] docs/dyndbg: explain flags parse 1st
2026-05-23 · Jim Cromie <jim.cromie@gmail.com> · 1 Reviewed-by -
STALE99d
REVIEWED: 2 (2M) [PATCH v3 01/24] docs/dyndbg: update examples \012 to \n
2026-06-01 · Jim Cromie <jim.cromie@gmail.com> · 1 Reviewed-by, 1 Tested-by
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
DORMANTno replies
[PATCH v4 8/8] documentation: remove references to *_gpl sections
2026-03-05 · Siddharth Nayyar <hidden> -
STALE165d
[PATCH v4 8/8] documentation: remove references to *_gpl sections
2026-03-05 · Siddharth Nayyar <hidden> -
STALE158d
[PATCH v1 3/4] IPC: Prepared Documentation and test
2026-03-15 · Mathura_Kumar <hidden> -
STALE174d
[PATCH v2 3/4]IPC: Prepared Documentation and test
2026-03-15 · Mathura_Kumar <hidden> -
STALE161d
[PATCH RESEND v2 3/4]IPC: Prepared Documentation and test
2026-03-20 · Mathura_Kumar <hidden> -
STALE166d
[PATCH 07/17] raid6: improve the public interface
2026-03-24 · Christoph Hellwig <hch@lst.de> -
DORMANTno replies
[PATCH v5 7/7] documentation: remove references to *_gpl sections
2026-03-26 · Siddharth Nayyar <hidden> -
STALE160d
[PATCH v5 7/7] documentation: remove references to *_gpl sections
2026-03-26 · Siddharth Nayyar <hidden> -
COLD18d
[PATCH v5 6/8] uapi: Replace __ASSEMBLY__ with __ASSEMBLER__ in uapi headers
2026-04-09 · Thomas Huth <hidden> -
STALE108d
[PATCH 2/5] mm: add pmd level THP COW parameter in sysfs
2026-05-01 · Luka Bai <hidden>