Reviews by mark.rutland@arm.com
· linux-arch
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the linux-arch archive.
100 attestations · capped at 100 most-recent. (70 Acked-by, 1 Reported-by, 17 Reviewed-by, 8 Suggested-by, 4 Tested-by)
-
WARM1d
[patch 11/18] seccomp, treewide: Rename and convert __secure_computing() to return boolean
2026-07-07 · Suggested-by -
STALE124d
REVIEWED: 1 (0M) [PATCH v13 RESEND 09/14] arm64: entry: Convert to generic entry
2026-03-17 · Suggested-by -
STALE128d
REVIEWED: 1 (0M) [PATCH v13 08/12] arm64: entry: Convert to generic entry
2026-03-13 · Suggested-by -
STALE639d
LANDED: 7 (7M) [PATCH v16 02/18] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-10-15 · Acked-by -
STALE580d
REVIEWED: 7 (7M) Re: [RFC PATCH 02/28] Documentation: Bump minimum GCC version to 8.1
2024-09-27 · Acked-by -
STALE651d
REVIEWED: 7 (7M) [PATCH v15 02/19] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-09-15 · Acked-by -
STALE651d
REVIEWED: 7 (7M) [PATCH v15 01/19] tracing: Add a comment about ftrace_regs definition
2024-09-15 · Acked-by -
STALE658d
REVIEWED: 7 (7M) [PATCH v14 02/19] tracing: Rename ftrace_regs_return_value to ftrace_regs_get_return_value
2024-09-12 · Acked-by -
STALE658d
REVIEWED: 7 (7M) [PATCH v14 01/19] tracing: Add a comment about ftrace_regs definition
2024-09-12 · Acked-by -
STALE798d
REVIEWED: 8 (8M) [PATCH memory-model 3/4] Documentation/atomic_t: Emphasize that failed atomic operations give no ordering
2024-05-01 · Acked-by -
STALE798d
REVIEWED: 8 (8M) [PATCH memory-model 3/3] Documentation/atomic_t: Emphasize that failed atomic operations give no ordering
2024-04-04 · Acked-by -
STALE904d
REVIEWED: 7 (7M) Re: [PATCH doc] Emphasize that failed atomic operations give no ordering
2024-01-30 · Acked-by -
STALE1139d
REVIEWED: 7 (7M) Re: [PATCH v2 07/12] parisc/percpu: Work around the lack of __SIZEOF_INT128__
2023-06-02 · Tested-by -
STALE1139d
REVIEWED: 14 (14M) Re: [PATCH 00/12] Introduce cmpxchg128() -- aka. the demise of cmpxchg_double()
2023-05-31 · Reviewed-by -
STALE1139d
REVIEWED: 14 (14M) Re: [PATCH 00/12] Introduce cmpxchg128() -- aka. the demise of cmpxchg_double()
2023-05-31 · Tested-by -
STALE1139d
LANDED: 12 (12M) [PATCH 04/12] instrumentation: Wire up cmpxchg128()
2023-05-31 · Acked-by -
STALE1139d
LANDED: 14 (14M) [PATCH 03/12] arch: Introduce arch_{,try_}_cmpxchg128{,_local}()
2023-05-31 · Acked-by -
STALE1149d
REVIEWED: 7 (7M) [PATCH v3 04/11] instrumentation: Wire up cmpxchg128()
2023-05-15 · Acked-by -
STALE1149d
REVIEWED: 9 (9M) [PATCH v3 03/11] arch: Introduce arch_{,try_}_cmpxchg128{,_local}()
2023-05-15 · Acked-by -
STALE1162d
REVIEWED: 7 (7M) Re: [PATCH v2 2/5] locking/generic: Wire up local{,64}_try_cmpxchg
2023-04-11 · Acked-by -
STALE1162d
REVIEWED: 7 (7M) Re: [PATCH v2 1/5] locking/atomic: Add generic try_cmpxchg{,64}_local support
2023-04-11 · Acked-by -
STALE1260d
REVIEWED: 7 (7M) Re: [PATCH v2 05/10] percpu: Wire up cmpxchg128
2023-02-03 · Acked-by -
STALE1260d
REVIEWED: 7 (7M) Re: [PATCH v2 04/10] instrumentation: Wire up cmpxchg128()
2023-02-03 · Acked-by -
STALE1260d
REVIEWED: 7 (7M) Re: [PATCH v2 03/10] arch: Introduce arch_{,try_}_cmpxchg128{,_local}()
2023-02-03 · Acked-by -
STALE1267d
[PATCH] locking/atomic: atomic: Use arch_atomic_{read,set} in generic atomic ops
2023-01-26 · Suggested-by -
STALE1220d
REVIEWED: 14 (14M) Re: [PATCH v3 00/51] cpuidle,rcu: Clean up the mess
2023-01-17 · Reviewed-by -
STALE1220d
REVIEWED: 14 (14M) Re: [PATCH v3 00/51] cpuidle,rcu: Clean up the mess
2023-01-17 · Tested-by -
STALE1220d
LANDED: 25 (23M) [PATCH v3 24/51] arm64,smp: Remove trace_.*_rcuidle() usage
2023-01-12 · Acked-by -
STALE1220d
LANDED: 20 (18M) [PATCH v3 26/51] time/tick-broadcast: Remove RCU_NONIDLE usage
2023-01-12 · Acked-by -
STALE1220d
LANDED: 21 (18M) [PATCH v3 14/51] cpuidle,cpu_pm: Remove RCU fiddling from cpu_pm_{enter,exit}()
2023-01-12 · Acked-by -
STALE1338d
REVIEWED: 7 (7M) [PATCH v2 26/44] time/tick-broadcast: Remove RCU_NONIDLE usage
2022-09-19 · Acked-by -
STALE1338d
REVIEWED: 12 (12M) [PATCH v2 24/44] arm64,smp: Remove trace_.*_rcuidle() usage
2022-09-19 · Acked-by -
STALE1338d
REVIEWED: 7 (7M) [PATCH v2 14/44] cpuidle,cpu_pm: Remove RCU fiddling from cpu_pm_{enter,exit}()
2022-09-19 · Acked-by -
STALE1297d
REVIEWED: 22 (22M) [PATCH v5 3/9] bitops: unify non-atomic bitops prototypes across architectures
2022-06-24 · Acked-by -
STALE1491d
REVIEWED: 22 (22M) [PATCH v4 3/8] bitops: unify non-atomic bitops prototypes across architectures
2022-06-21 · Acked-by -
STALE1477d
REVIEWED: 15 (15M) [PATCH v3 3/7] bitops: unify non-atomic bitops prototypes across architectures
2022-06-17 · Acked-by -
STALE1286d
REVIEWED: 7 (7M) Re: [PATCH 15/36] cpuidle,cpu_pm: Remove RCU fiddling from cpu_pm_{enter,exit}()
2022-06-14 · Acked-by -
STALE1286d
REVIEWED: 7 (7M) Re: [PATCH 25/36] time/tick-broadcast: Remove RCU_NONIDLE usage
2022-06-14 · Acked-by -
STALE1286d
REVIEWED: 7 (7M) Re: [PATCH 16/36] rcu: Fix rcu_idle_exit()
2022-06-14 · Acked-by -
STALE1498d
REVIEWED: 15 (15M) [PATCH v2 3/6] bitops: unify non-atomic bitops prototypes across architectures
2022-06-10 · Acked-by -
STALE1505d
REVIEWED: 7 (7M) Re: [PATCH 4/6] bitops: unify non-atomic bitops prototypes across architectures
2022-06-06 · Acked-by -
STALE1505d
REVIEWED: 7 (7M) Re: [PATCH 3/6] bitops: define gen_test_bit() the same way as the rest of functions
2022-06-06 · Acked-by -
STALE1608d
REVIEWED: 13 (13M) [PATCH v2 11/18] arm64: simplify access_ok()
2022-02-16 · Acked-by -
STALE1617d
REVIEWED: 7 (7M) Re: [PATCH 08/14] arm64: simplify access_ok()
2022-02-15 · Acked-by -
STALE1689d
REVIEWED: 7 (7M) [PATCH v3 02/25] kcsan: Remove redundant zero-initialization of globals
2021-11-30 · Acked-by -
STALE1689d
REVIEWED: 7 (7M) [PATCH v3 01/25] kcsan: Refactor reading of instrumented memory
2021-11-30 · Acked-by -
STALE1696d
REVIEWED: 7 (7M) Re: [PATCH v2 02/23] kcsan: Remove redundant zero-initialization of globals
2021-11-18 · Acked-by -
STALE1696d
REVIEWED: 7 (7M) Re: [PATCH v2 01/23] kcsan: Refactor reading of instrumented memory
2021-11-18 · Acked-by -
STALE1730d
REVIEWED: 14 (14M) Re: [PATCH 4/7] arch: Make ARCH_STACKWALK independent of STACKTRACE
2021-10-22 · Reviewed-by -
STALE1730d
REVIEWED: 14 (14M) Re: [PATCH 4/7] arch: Make ARCH_STACKWALK independent of STACKTRACE
2021-10-22 · Tested-by -
STALE1860d
LANDED: 7 (7M) [PATCH v2 3/7] sched,perf,kvm: Fix preemption condition
2021-06-11 · Acked-by -
STALE1867d
LANDED: 10 (10M) [PATCH v9 01/20] arm64: cpuinfo: Split AArch32 registers out into a separate struct
2021-06-08 · Acked-by -
STALE1868d
REVIEWED: 7 (7M) Re: [PATCH v8 01/19] arm64: cpuinfo: Split AArch32 registers out into a separate struct
2021-06-03 · Acked-by -
STALE1930d
LANDED: 12 (12M) [PATCH v6 16/18] arm64: ftrace: use function_nocfi for ftrace_call
2021-04-08 · Acked-by -
STALE1930d
LANDED: 13 (12M) [PATCH v6 13/18] arm64: use function_nocfi with __pa_symbol
2021-04-08 · Acked-by -
STALE1930d
LANDED: 13 (12M) [PATCH v6 12/18] arm64: implement function_nocfi
2021-04-08 · Acked-by -
STALE1930d
LANDED: 13 (12M) [PATCH v6 11/18] psci: use function_nocfi for cpu_resume
2021-04-08 · Acked-by -
STALE1930d
LANDED: 13 (12M) [PATCH v6 03/18] mm: add generic function_nocfi macro
2021-04-08 · Acked-by -
STALE1933d
REVIEWED: 7 (7M) Re: [PATCH v5 16/18] arm64: ftrace: use function_nocfi for ftrace_call
2021-04-06 · Acked-by -
STALE1933d
REVIEWED: 7 (7M) Re: [PATCH v5 13/18] arm64: use function_nocfi with __pa_symbol
2021-04-06 · Acked-by -
STALE1933d
REVIEWED: 7 (7M) Re: [PATCH v5 12/18] arm64: implement function_nocfi
2021-04-06 · Acked-by -
STALE1933d
REVIEWED: 7 (7M) Re: [PATCH v5 11/18] psci: use function_nocfi for cpu_resume
2021-04-06 · Acked-by -
STALE1933d
REVIEWED: 7 (7M) Re: [PATCH v5 03/18] mm: add generic function_nocfi macro
2021-04-06 · Acked-by -
STALE2192d
REVIEWED: 10 (9M) [PATCH 5/6] uaccess: add force_uaccess_{begin,end} helpers
2020-07-14 · Acked-by -
STALE2191d
REVIEWED: 7 (7M) Re: [PATCH 5/6] uaccess: add force_uaccess_{begin,end} helpers
2020-07-13 · Acked-by -
STALE2280d
REVIEWED: 7 (7M) Re: [PATCH v4 06/11] READ_ONCE: Simplify implementations of {READ,WRITE}_ONCE()
2020-04-22 · Acked-by -
STALE2280d
REVIEWED: 7 (7M) Re: [PATCH v4 05/11] arm64: csum: Disable KASAN for do_csum()
2020-04-22 · Acked-by -
STALE2280d
REVIEWED: 7 (7M) [PATCH v4 10/11] arm64: barrier: Use '__unqual_scalar_typeof' for acquire/release macros
2020-04-21 · Acked-by -
STALE2288d
REVIEWED: 7 (7M) [PATCH v3 10/12] arm64: barrier: Use '__unqual_scalar_typeof' for acquire/release macros
2020-04-15 · Acked-by -
STALE2288d
REVIEWED: 7 (7M) Re: [PATCH 26/28] arm64: use __vmalloc_node in arch_alloc_vmap_stack
2020-04-08 · Acked-by -
STALE2273d
REVIEWED: 8 (7M) [PATCH v10 07/13] arm64: unify native/compat instruction skipping
2020-03-16 · Reviewed-by -
STALE2320d
REVIEWED: 8 (7M) [PATCH v9 07/13] arm64: unify native/compat instruction skipping
2020-03-11 · Reviewed-by -
STALE2322d
REVIEWED: 8 (7M) [PATCH v8 07/11] arm64: unify native/compat instruction skipping
2020-02-27 · Reviewed-by -
STALE2337d
REVIEWED: 7 (7M) [PATCH v7 07/11] arm64: unify native/compat instruction skipping
2020-02-26 · Reviewed-by -
STALE2315d
REVIEWED: 7 (7M) [PATCH v4 20/27] asm-generic/atomic: Use __always_inline for pure wrappers
2020-02-21 · Acked-by -
STALE2315d
REVIEWED: 7 (7M) [PATCH v4 19/27] locking/atomics, kcsan: Add KCSAN instrumentation
2020-02-21 · Reviewed-by -
STALE2315d
REVIEWED: 7 (7M) [PATCH v4 21/27] asm-generic/atomic: Use __always_inline for fallback wrappers
2020-02-21 · Suggested-by -
STALE2315d
REVIEWED: 7 (7M) [PATCH v4 21/27] asm-generic/atomic: Use __always_inline for fallback wrappers
2020-02-21 · Acked-by -
STALE2344d
REVIEWED: 7 (7M) [PATCH v3 18/22] asm-generic/atomic: Use __always_inline for fallback wrappers
2020-02-19 · Suggested-by -
STALE2344d
REVIEWED: 7 (7M) [PATCH v3 18/22] asm-generic/atomic: Use __always_inline for fallback wrappers
2020-02-19 · Acked-by -
STALE2344d
REVIEWED: 7 (7M) [PATCH v3 16/22] locking/atomics, kcsan: Add KCSAN instrumentation
2020-02-19 · Reviewed-by -
STALE2344d
REVIEWED: 7 (7M) [PATCH v3 17/22] asm-generic/atomic: Use __always_inline for pure wrappers
2020-02-19 · Acked-by -
STALE2338d
REVIEWED: 7 (7M) [PATCH v6 07/11] arm64: unify native/compat instruction skipping
2020-02-12 · Reviewed-by -
STALE2354d
REVIEWED: 7 (7M) [PATCH v2 08/10] arm64: barrier: Use '__unqual_scalar_typeof' for acquire/release macros
2020-01-23 · Acked-by -
STALE2370d
REVIEWED: 7 (7M) [PATCH v5 08/12] arm64: unify native/compat instruction skipping
2020-01-22 · Reviewed-by -
STALE2380d
REVIEWED: 7 (7M) Re: [RFC PATCH 8/8] arm64: barrier: Use '__unqual_scalar_typeof' for acquire/release macros
2020-01-10 · Acked-by -
STALE2381d
REVIEWED: 7 (7M) [PATCH v4 08/12] arm64: unify native/compat instruction skipping
2019-12-11 · Reviewed-by -
STALE2413d
REVIEWED: 7 (7M) [PATCH v3 2/3] asm-generic/atomic: Use __always_inline for fallback wrappers
2019-11-26 · Suggested-by -
STALE2413d
REVIEWED: 7 (7M) [PATCH v3 2/3] asm-generic/atomic: Use __always_inline for fallback wrappers
2019-11-26 · Acked-by -
STALE2413d
REVIEWED: 7 (7M) [PATCH v3 1/3] asm-generic/atomic: Use __always_inline for pure wrappers
2019-11-26 · Acked-by -
STALE2430d
REVIEWED: 7 (7M) Re: [PATCH v2 2/3] asm-generic/atomic: Use __always_inline for fallback wrappers
2019-11-26 · Acked-by -
STALE2430d
REVIEWED: 7 (7M) Re: [PATCH v2 1/3] asm-generic/atomic: Use __always_inline for pure wrappers
2019-11-26 · Acked-by -
STALE2430d
[PATCH v2 2/3] asm-generic/atomic: Use __always_inline for fallback wrappers
2019-11-26 · Suggested-by -
STALE2380d
REVIEWED: 15 (15M) [PATCH v4 09/10] locking/atomics, kcsan: Add KCSAN instrumentation
2019-11-14 · Reviewed-by -
STALE2442d
REVIEWED: 7 (7M) [PATCH v3 8/9] locking/atomics, kcsan: Add KCSAN instrumentation
2019-11-04 · Reviewed-by -
STALE2463d
REVIEWED: 7 (7M) Re: [PATCH v2 7/8] locking/atomics, kcsan: Add KCSAN instrumentation
2019-10-22 · Reviewed-by -
STALE2465d
REVIEWED: 7 (7M) Re: [PATCH v2 09/12] arm64: traps: Fix inconsistent faulting instruction skipping
2019-10-15 · Reviewed-by -
STALE2518d
REVIEWED: 7 (7M) Re: [PATCH 0/6] Fix TLB invalidation on arm64
2019-08-27 · Reviewed-by -
STALE2518d
[PATCH 3/6] arm64: mm: Add ISB instruction to set_pgd()
2019-08-27 · Reported-by -
STALE2596d
REVIEWED: 7 (7M) [PATCH v4 1/3] lib/test_kasan: Add bitops tests
2019-06-13 · Acked-by