# Re: \[PATCH for 4.16 v7 02/11\] powerpc: membarrier: Skip memory barrier in switch\_mm()

- From: Ingo Molnar \<mingo@kernel.org\>
- Date: 2018-02-05 20:22:49 
- List: linux-api
- Page: https://ratatoskr.run/linux-api/2018/02/5200673
- Thread: https://ratatoskr.run/linux-api/2018/01/5184393/t.md

```text

* Mathieu Desnoyers [ref] wrote:

>  
> +config ARCH_HAS_MEMBARRIER_HOOKS
> +	bool

Yeah, so I have renamed this to ARCH_HAS_MEMBARRIER_CALLBACKS, and propagated it 
through the rest of the patches. "Callback" is the canonical name, and I also 
cringe every time I see 'hook'.

Please let me know if there are any big objections against this minor cleanup.

Thanks,

	Ingo
```
