Re: [PATCH 7/9] rfkill: Create "rfkill-airplane_mode" LED trigger

2 messages, 2 authors, 2016-02-22 · open the first message on its own page

Re: [PATCH 7/9] rfkill: Create "rfkill-airplane_mode" LED trigger

From: Johannes Berg <johannes@sipsolutions.net>
Date: 2016-02-18 20:08:50

On Mon, 2016-02-08 at 10:41 -0500, João Paulo Rechi Vita wrote:
This creates a new LED trigger to be used by platform drivers as a
default trigger for airplane-mode indicator LEDs.

By default this trigger will fire when RFKILL_OP_CHANGE_ALL is called
for all types (RFKILL_TYPE_ALL), setting the LED brightness to
LED_FULL
when the changing the state to blocked, and to LED_OFF when the
changing
the state to unblocked. In the future there will be a mechanism for
userspace to override the default policy, so it can implement its
own.

This trigger will be used by the asus-wireless x86 platform driver.
Just one comment - I think you should be consistent with the _ vs - and
just use "rfkill-airplane-mode" as the name.

johannes

Re: [PATCH 7/9] rfkill: Create "rfkill-airplane_mode" LED trigger

From: João Paulo Rechi Vita <jprvita@gmail.com>
Date: 2016-02-22 16:11:33

On 18 February 2016 at 15:08, Johannes Berg [off-list ref] wrote:
On Mon, 2016-02-08 at 10:41 -0500, João Paulo Rechi Vita wrote:
quoted
This creates a new LED trigger to be used by platform drivers as a
default trigger for airplane-mode indicator LEDs.

By default this trigger will fire when RFKILL_OP_CHANGE_ALL is called
for all types (RFKILL_TYPE_ALL), setting the LED brightness to
LED_FULL
when the changing the state to blocked, and to LED_OFF when the
changing
the state to unblocked. In the future there will be a mechanism for
userspace to override the default policy, so it can implement its
own.

This trigger will be used by the asus-wireless x86 platform driver.
Just one comment - I think you should be consistent with the _ vs - and
just use "rfkill-airplane-mode" as the name.
Ok, no problem. I'll change for the next version.

--
João Paulo Rechi Vita
http://about.me/jprvita
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help