tracing · Maintained
Maintainers
- M Steven Rostedt <rostedt@goodmis.org>
- M Masami Hiramatsu <mhiramat@kernel.org>
- R Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
Paths
- F
Documentation/core-api/tracepoint.rst - F
Documentation/trace/* - F
fs/tracefs/ - F
include/linux/trace*.h - F
include/trace/ - F
kernel/trace/ - F
kernel/tracepoint.c - F
scripts/tracing/ - F
scripts/tracepoint-update.c - F
tools/testing/selftests/ftrace/
Last 30 days
Most active threads (last 7 days)
-
WARM3d
[PATCH v7 00/23] KVM: s390: Introduce arm64 KVM
2026-09-02 16:14 · 2 replies in 7d · Steffen Eiden <seiden@linux.ibm.com>
Active reviewers (last 30 days)
-
Fuad Tabba <hidden>
4 attestations (4 Reviewed-by) · last on 2026-08-31 -
Shivank Garg <hidden>
4 attestations (4 Tested-by) · last on 2026-08-31 -
Xiaoyao Li <hidden>
4 attestations (4 Reviewed-by) · last on 2026-08-31 -
Binbin Wu <hidden>
4 attestations (4 Reviewed-by) · last on 2026-08-31
Recent patches
Most-recent 30 patches in this subsystem on kvm (capped at 30), ordered by date desc.
-
WARM3d
Re: [PATCH v7 02/23] KVM: Make device name configurable
2026-09-02 · Sean Christopherson <seanjc@google.com> -
WARM3d
Re: [PATCH v7 02/23] KVM: Make device name configurable
2026-09-02 · Steffen Eiden <seiden@linux.ibm.com> -
COOLING5d
REVIEWED: 4 (0M) [PATCH v12 06/45] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
2026-08-31 · Ackerley Tng via B4 Relay <devnull+ackerleytng.google.com@kernel.org> -
COOLING5d
REVIEWED: 4 (0M) [PATCH v12 04/45] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-08-31 · Ackerley Tng via B4 Relay <devnull+ackerleytng.google.com@kernel.org> -
COOLING10d
REVIEWED: 4 (0M) [PATCH v11 06/46] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
2026-08-26 · Ackerley Tng <hidden> -
COOLING10d
REVIEWED: 4 (0M) [PATCH v11 04/46] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-08-26 · Ackerley Tng <hidden> -
COOLING10d
REVIEWED: 3 (0M) [PATCH v10 05/41] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
2026-08-07 · Ackerley Tng <hidden> -
COOLING10d
REVIEWED: 4 (0M) [PATCH v10 03/41] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-08-07 · Ackerley Tng <hidden> -
COLD31d
[PATCH 4/5] tracing/lock: Use TRACE_EVENT_FN() for contended_release
2026-08-04 · Dmitry Ilvokhin <hidden> -
COLD28d
REVIEWED: 4 (0M) [PATCH v9 02/41] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-07-29 · Ackerley Tng <hidden> -
COLD28d
REVIEWED: 2 (0M) [PATCH v9 04/41] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
2026-07-29 · Ackerley Tng <hidden> -
COLD52d
[PATCH 14/24] KVM: Introduce a generation number for memory attributes
2026-07-16 · Paolo Bonzini <pbonzini@redhat.com> -
COLD46d
IN MM: 2 (2M) [PATCH v2 19/33] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
2026-07-10 · Lorenzo Stoakes <ljs@kernel.org> -
COLD60d
IN MM: 21 (21M) [PATCH v10 05/15] mm: add VM_UFFD_RWP VMA flag
2026-07-08 · Kiryl Shutsemau <hidden> -
COLD60d
IN MM: 12 (12M) [PATCH v10 03/15] mm: rename uffd-wp PTE accessors to uffd
2026-07-08 · Kiryl Shutsemau <hidden> -
STALE63d
REVIEWED: 21 (21M) [PATCH v9 05/15] mm: add VM_UFFD_RWP VMA flag
2026-07-06 · Kiryl Shutsemau <hidden> -
STALE63d
REVIEWED: 12 (12M) [PATCH v9 03/15] mm: rename uffd-wp PTE accessors to uffd
2026-07-06 · Kiryl Shutsemau <hidden> -
STALE66d
REVIEWED: 21 (21M) [PATCH v8 05/15] mm: add VM_UFFD_RWP VMA flag
2026-07-03 · Kiryl Shutsemau <hidden> -
STALE66d
REVIEWED: 12 (12M) [PATCH v8 03/15] mm: rename uffd-wp PTE accessors to uffd
2026-07-03 · Kiryl Shutsemau <hidden> -
COLD58d
[PATCH 17/30] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
2026-06-29 · Lorenzo Stoakes <ljs@kernel.org> -
STALE70d
REVIEWED: 21 (21M) [PATCH v7 05/15] mm: add VM_UFFD_RWP VMA flag
2026-06-29 · Kiryl Shutsemau <hidden> -
STALE70d
REVIEWED: 12 (12M) [PATCH v7 03/15] mm: rename uffd-wp PTE accessors to uffd
2026-06-29 · Kiryl Shutsemau <hidden> -
STALE67d
REVIEWED: 9 (9M) [PATCH v4 1/2] tracing: Move non-trace_printk prototypes into trace_controls.h
2026-06-25 · Steven Rostedt <rostedt@kernel.org> -
STALE67d
REVIEWED: 9 (9M) [PATCH v4 2/2] tracing: Remove trace_printk.h from kernel.h
2026-06-25 · Steven Rostedt <rostedt@kernel.org> -
STALE67d
[PATCH 2/2] tracing: Add CONFIG_TRACE_PRINTK_DEBUGGING to clean up kernel.h
2026-06-21 · Steven Rostedt <rostedt@kernel.org> -
COLD42d
REVIEWED: 1 (0M) [PATCH v8 02/46] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-06-19 · Ackerley Tng via B4 Relay <devnull+ackerleytng.google.com@kernel.org> -
STALE96d
REVIEWED: 12 (12M) [PATCH v6 05/15] mm: add VM_UFFD_RWP VMA flag
2026-05-29 · "Kiryl Shutsemau (Meta)" <kas@kernel.org> -
STALE96d
REVIEWED: 12 (12M) [PATCH v6 03/15] mm: rename uffd-wp PTE accessors to uffd
2026-05-29 · "Kiryl Shutsemau (Meta)" <kas@kernel.org> -
STALE98d
REVIEWED: 12 (12M) [PATCH v5 08/18] mm: add VM_UFFD_RWP VMA flag
2026-05-26 · Kiryl Shutsemau <hidden> -
STALE98d
REVIEWED: 12 (12M) [PATCH v5 07/18] mm: rename uffd-wp PTE accessors to uffd
2026-05-26 · Kiryl Shutsemau <hidden>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
STALE74d
REVIEWED: 1 (0M) [PATCH v7 02/42] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-05-23 · Ackerley Tng <hidden> · 1 Reviewed-by -
COLD42d
REVIEWED: 1 (0M) [PATCH v8 02/46] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-06-19 · Ackerley Tng via B4 Relay <devnull+ackerleytng.google.com@kernel.org> · 1 Reviewed-by -
COLD28d
REVIEWED: 4 (0M) [PATCH v9 02/41] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-07-29 · Ackerley Tng <hidden> · 3 Reviewed-by, 1 Tested-by -
COLD28d
REVIEWED: 2 (0M) [PATCH v9 04/41] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
2026-07-29 · Ackerley Tng <hidden> · 1 Reviewed-by, 1 Tested-by -
COOLING10d
REVIEWED: 4 (0M) [PATCH v10 03/41] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-08-07 · Ackerley Tng <hidden> · 3 Reviewed-by, 1 Tested-by -
COOLING10d
REVIEWED: 3 (0M) [PATCH v10 05/41] KVM: Rename memory attribute APIs to prepare for in-place gmem conversion
2026-08-07 · Ackerley Tng <hidden> · 2 Reviewed-by, 1 Tested-by
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE174d
[PATCH RFC v3 02/43] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-03-13 · Ackerley Tng <hidden> -
COLD24d
[PATCH RFC v4 02/44] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-03-26 · Ackerley Tng <hidden> -
STALE133d
[RFC, PATCH 07/12] sched/numa: skip scanning anonymous VM_UFFD_MINOR VMAs
2026-04-14 · "Kiryl Shutsemau (Meta)" <kas@kernel.org> -
DORMANTno replies
LANDED [PATCH] tracing: Make undefsyms_base.c a first-class citizen
2026-04-21 · Marc Zyngier <maz@kernel.org> -
STALE126d
[PATCH 04/14] mm: add VM_UFFD_RWP VMA flag
2026-04-27 · "Kiryl Shutsemau (Meta)" <kas@kernel.org> -
STALE117d
[PATCH RFC v5 02/53] KVM: Rename KVM_GENERIC_MEMORY_ATTRIBUTES to KVM_VM_MEMORY_ATTRIBUTES
2026-04-28 · Ackerley Tng via B4 Relay <devnull+ackerleytng.google.com@kernel.org>