# Re: \[PATCH 0/4\] test-tool: split up "read-cache" tool

- From: Junio C Hamano \<hidden\>
- Date: 2021-06-08 23:26:26 
- List: git
- Page: https://ratatoskr.run/git/2021/06/7891407
- Thread: https://ratatoskr.run/git/2021/06/7891407/t.md

```text
Ævar Arnfjörð Bjarmason [ref] writes:

>>> Ævar Arnfjörð Bjarmason (4):
>>>   test-tool: split up test-tool read-cache
>>>   test-tools: migrate read-cache-perf to parse_options()
>>>   test-tools: migrate read-cache-again to parse_options()
>>>   read-cache perf: add a perf test for refresh_index()
>>
>> Is the contrast between tool and tools deliberate?
>
> Yes, I figured "test-tool:" describes the main entry point of the
> "test-tool somecmd", so if I split up "somecmd" into "othercmd" that's a
> "test-tool" change.
>
> But "test-tools:" when I'm modifying particular tools, I can change 2/4
> and 3/4 it to "test-tool read-cache-perf:" and "test-tool
> read-cache-again" (or another thing you suggest) if you think this
> warrants a re-roll.

I actually meant s/test-tools:/test-tool:/ and nothing else, as
changes to read-cache-perf and changes to read-cache-again both fall
into the same test-tool umbrella.  It's not like we benefit from
having two separate <area> (as in "<area>: <description>")
designators for read-cache-perf and read-cache-again---in a larger
picture, they are both things around test-tool helper.

Thanks.


```
