A couple of minor fixes for the already-landed recent sparse-index.c
work. The sparse setup code is (re-)setting variables it's already set
for no reason, and re-doing work it doesn't need to.
Ævar Arnfjörð Bjarmason (2):
sparse-index.c: remove set_index_sparse_config()
sparse-index.c: don't call prepare_repo_settings() twice in a row
sparse-index.c | 14 +++-----------
1 file changed, 3 insertions(+), 11 deletions(-)
--
2.31.1.838.g7ac6e98bb53
Remove the set_index_sparse_config() function by folding it into
set_sparse_index_config(), which was its only user.
Since 122ba1f7b52 (sparse-checkout: toggle sparse index from builtin,
2021-03-30) the flow of this code hasn't made much sense, we'd get
"enabled" in set_sparse_index_config(), proceed to call
set_index_sparse_config() with it.
There we'd call prepare_repo_settings() and set
"repo->settings.sparse_index = 1", only to needlessly call
prepare_repo_settings() again in set_sparse_index_config() (where it
would early abort), and finally setting "repo->settings.sparse_index =
enabled".
Instead we can just call prepare_repo_settings() once, and set the
variable to "enabled" in the first place.
Signed-off-by: Ævar Arnfjörð Bjarmason <redacted>
---
sparse-index.c | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)
Change code added in 58300f47432 (sparse-index: add index.sparse
config option, 2021-03-30) to only call prepare_repo_settings()
once. We know that our own set_sparse_index_config() has just finished
calling it, so we don't need to call it if we're acting on "test_env".
Signed-off-by: Ævar Arnfjörð Bjarmason <redacted>
---
sparse-index.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
On 5/5/2021 8:11 AM, Ævar Arnfjörð Bjarmason wrote:
Change code added in 58300f47432 (sparse-index: add index.sparse
config option, 2021-03-30) to only call prepare_repo_settings()
once. We know that our own set_sparse_index_config() has just finished
calling it, so we don't need to call it if we're acting on "test_env".
I'm not sure about the value here. prepare_repo_settings() returns
quickly if the settings have already been prepared, so a second call
is negligible in cost.
quoted hunk
@@ -133,11 +133,12 @@ int convert_to_sparse(struct index_state *istate) test_env = git_env_bool("GIT_TEST_SPARSE_INDEX", -1); if (test_env >= 0) set_sparse_index_config(istate->repo, test_env);+ else+ prepare_repo_settings(istate->repo);
The change presented here to either call set_sparse_index_config()
_or_ prepare_repo_settings() seems like it knows too much about
how set_sparse_index_config() works.
Thanks,
-Stolee
On 5/5/2021 8:11 AM, Ævar Arnfjörð Bjarmason wrote:
quoted hunk
Remove the set_index_sparse_config() function by folding it into
set_sparse_index_config(), which was its only user.
Since 122ba1f7b52 (sparse-checkout: toggle sparse index from builtin,
2021-03-30) the flow of this code hasn't made much sense, we'd get
"enabled" in set_sparse_index_config(), proceed to call
set_index_sparse_config() with it.
There we'd call prepare_repo_settings() and set
"repo->settings.sparse_index = 1", only to needlessly call
prepare_repo_settings() again in set_sparse_index_config() (where it
would early abort), and finally setting "repo->settings.sparse_index =
enabled".
Instead we can just call prepare_repo_settings() once, and set the
variable to "enabled" in the first place.
Signed-off-by: Ævar Arnfjörð Bjarmason <redacted>
---
sparse-index.c | 11 +----------
1 file changed, 1 insertion(+), 10 deletions(-)
On 5/5/2021 8:11 AM, Ævar Arnfjörð Bjarmason wrote:
quoted
Change code added in 58300f47432 (sparse-index: add index.sparse
config option, 2021-03-30) to only call prepare_repo_settings()
once. We know that our own set_sparse_index_config() has just finished
calling it, so we don't need to call it if we're acting on "test_env".
I'm not sure about the value here. prepare_repo_settings() returns
quickly if the settings have already been prepared, so a second call
is negligible in cost.
I changed that while I was at it to make it easier to read, it's not an
optimization. I.e. one wonders what the side-effect is of calling
prepare_repo_settings() twice, discovers there isn't one...
quoted
@@ -133,11 +133,12 @@ int convert_to_sparse(struct index_state *istate) test_env = git_env_bool("GIT_TEST_SPARSE_INDEX", -1); if (test_env >= 0) set_sparse_index_config(istate->repo, test_env);+ else+ prepare_repo_settings(istate->repo);
The change presented here to either call set_sparse_index_config()
_or_ prepare_repo_settings() seems like it knows too much about
how set_sparse_index_config() works.
It seems reasonable to assume that a function to set config has
initialized (or died, if it couldn't) enough of our config state to do
its job.
Besides, it's a few lines above the changed code in the same file.
But looking at this again 2/3 callers of set_sparse_index_config()
aren't checking the return value. Wouldn't something like [1] on top be
a good idea here?
Also, is GIT_TEST_SPARSE_INDEX=true itself supposed to work? Running the
test suite with it fails 3 test files for me, all /sparse/, i.e. tests
that (presumably) assume it's not already turned on by this code.
1.
@@ -280,8 +280,9 @@ static int set_config(enum sparse_checkout_mode mode)"core.sparseCheckoutCone",mode==MODE_CONE_PATTERNS?"true":NULL);-if(mode==MODE_NO_PATTERNS)-set_sparse_index_config(the_repository,0);+if(mode==MODE_NO_PATTERNS&&+set_sparse_index_config(the_repository,0)<0)+die(_("could not set index.sparse=0"));return0;}
@@ -131,10 +131,13 @@ int convert_to_sparse(struct index_state *istate)*index.sparseconfigvariabletobeon.*/test_env=git_env_bool("GIT_TEST_SPARSE_INDEX",-1);-if(test_env>=0)-set_sparse_index_config(istate->repo,test_env);-else+if(test_env>=0){+if(set_sparse_index_config(istate->repo,test_env)<0)+die(_("could not set index.sparse based on GIT_TEST_SPARSE_INDEX=%d"),+test_env);+}else{prepare_repo_settings(istate->repo);+}/**Onlyconverttosparseifindex.sparseisset.
On 5/6/2021 4:49 AM, Ævar Arnfjörð Bjarmason wrote:
On Wed, May 05 2021, Derrick Stolee wrote:
quoted
On 5/5/2021 8:11 AM, Ævar Arnfjörð Bjarmason wrote:
quoted
Change code added in 58300f47432 (sparse-index: add index.sparse
config option, 2021-03-30) to only call prepare_repo_settings()
once. We know that our own set_sparse_index_config() has just finished
calling it, so we don't need to call it if we're acting on "test_env".
I'm not sure about the value here. prepare_repo_settings() returns
quickly if the settings have already been prepared, so a second call
is negligible in cost.
I changed that while I was at it to make it easier to read, it's not an
optimization. I.e. one wonders what the side-effect is of calling
prepare_repo_settings() twice, discovers there isn't one...
This is typical of the "prepare_" pattern, such as prepare_packed_git()
or prepare_commit_graph(). It's saying "be sure this is initialized"
and that initialization only needs to happen once.
quoted
quoted
@@ -133,11 +133,12 @@ int convert_to_sparse(struct index_state *istate) test_env = git_env_bool("GIT_TEST_SPARSE_INDEX", -1); if (test_env >= 0) set_sparse_index_config(istate->repo, test_env);+ else+ prepare_repo_settings(istate->repo);
The change presented here to either call set_sparse_index_config()
_or_ prepare_repo_settings() seems like it knows too much about
how set_sparse_index_config() works.
It seems reasonable to assume that a function to set config has
initialized (or died, if it couldn't) enough of our config state to do
its job.
Besides, it's a few lines above the changed code in the same file.
But looking at this again 2/3 callers of set_sparse_index_config()
aren't checking the return value. Wouldn't something like [1] on top be
a good idea here?
Also, is GIT_TEST_SPARSE_INDEX=true itself supposed to work? Running the
test suite with it fails 3 test files for me, all /sparse/, i.e. tests
that (presumably) assume it's not already turned on by this code.
I haven't ensured that this works in all cases. I was going to try and
find a way to make the tests be better about having a meaningful data
shape that applies to the sparse-index, but I should go and verify that
the tests work with this enabled.
@@ -280,8 +280,9 @@ static int set_config(enum sparse_checkout_mode mode)"core.sparseCheckoutCone",mode==MODE_CONE_PATTERNS?"true":NULL);-if(mode==MODE_NO_PATTERNS)-set_sparse_index_config(the_repository,0);+if(mode==MODE_NO_PATTERNS&&+set_sparse_index_config(the_repository,0)<0)+die(_("could not set index.sparse=0"));
This seems reasonable, because we are in a builtin saying "please disable
the sparse-index". Is there not an instance here that _enables_ it?
I would change the string to be "could not disable index.sparse" or
something similar.
@@ -131,10 +131,13 @@ int convert_to_sparse(struct index_state *istate)*index.sparseconfigvariabletobeon.*/test_env=git_env_bool("GIT_TEST_SPARSE_INDEX",-1);-if(test_env>=0)-set_sparse_index_config(istate->repo,test_env);-else+if(test_env>=0){+if(set_sparse_index_config(istate->repo,test_env)<0)+die(_("could not set index.sparse based on GIT_TEST_SPARSE_INDEX=%d"),+test_env);+}else{prepare_repo_settings(istate->repo);+}
This one, I'm not so sure. There might be reasons why the GIT_TEST_*
variable won't work to set the config and we don't want that to be
a reason the test fails. There is no need for a translated string
here, either.
Thanks,
-Stolee