# Re: \[PATCH v3 0/7\] Refactor fetch negotiation into its own API

- From: Brandon Williams \<hidden\>
- Date: 2018-06-25 18:24:40 
- List: git
- Page: https://ratatoskr.run/git/2018/06/7771513
- Thread: https://ratatoskr.run/git/2018/06/7769921/t.md

```text
On 06/14, Jonathan Tan wrote:
> Thanks, Brandon and Junio, for your comments.
> 
> Updates since v2:
>  - nothing new in patches 1 and 2
>  - patch 3: now clear priority queue unconditionally once we are done
>    with it (as requested by Brandon in a comment for a later patch)
>  - patch 4: updated commit message to not mention everything_local() (as
>    pointed out by Brandon), updated test to not rely on the fact that
>    fetch-pack uses prefix matching (thanks, Junio, for the observation)
>  - patch 5: used a more descriptive name ("struct negotiation_state")
>    for the struct, instead of "struct data"
>  - squashed patch 8 into patch 7; this means that the comments are not
>    moved verbatim, but for the reviewer, verbatim-ness of comments is
>    probably not that important anyway

Thanks this series looks good now.

Reviewed-by: Brandon Williams <redacted>

-- 
Brandon Williams
```
