Re: [PATCH 0/6] git-rm absorbs submodule git directory before deletion

2 messages, 2 authors, 2016-12-13 · open the first message on its own page

Re: [PATCH 0/6] git-rm absorbs submodule git directory before deletion

From: Junio C Hamano <hidden>
Date: 2016-12-13 07:28:37

Stefan Beller [off-list ref] writes:
The "checkout --recurse-submodules" series got too large to comfortably send
it out for review, so I had to break it up into smaller series'; this is the
first subseries, but it makes sense on its own.

This series teaches git-rm to absorb the git directory of a submodule instead
of failing and complaining about the git directory preventing deletion.
 
It applies on origin/sb/submodule-embed-gitdir.
Thanks.  I probably should rename the topic again with s/embed/absorb/;
Any feedback welcome!

Thanks,
Stefan

Stefan Beller (6):
  submodule.h: add extern keyword to functions
  submodule: modernize ok_to_remove_submodule to use argv_array
  submodule: add flags to ok_to_remove_submodule
  ok_to_remove_submodule: absorb the submodule git dir
  t3600: slightly modernize style
  rm: add absorb a submodules git dir before deletion

 builtin/rm.c  |  21 +++-----
 cache.h       |   2 +
 entry.c       |   5 ++
 submodule.c   |  77 +++++++++++++++++++++++-----
 submodule.h   |  64 ++++++++++++++---------
 t/t3600-rm.sh | 159 +++++++++++++++++++++++----------------------------------
 6 files changed, 182 insertions(+), 146 deletions(-)

Re: [PATCH 0/6] git-rm absorbs submodule git directory before deletion

From: Stefan Beller <hidden>
Date: 2016-12-13 17:55:47

On Mon, Dec 12, 2016 at 11:28 PM, Junio C Hamano [off-list ref] wrote:
Stefan Beller [off-list ref] writes:
quoted
The "checkout --recurse-submodules" series got too large to comfortably send
it out for review, so I had to break it up into smaller series'; this is the
first subseries, but it makes sense on its own.

This series teaches git-rm to absorb the git directory of a submodule instead
of failing and complaining about the git directory preventing deletion.

It applies on origin/sb/submodule-embed-gitdir.
Thanks.  I probably should rename the topic again with s/embed/absorb/;
I mostly renamed it in the hope to settle our dispute what embedding means. ;)
So in case we want to further discuss on the name of the function, we should
do that before doing actual work such as renaming.

Note that sb/t3600-cleanup is part of this series now,
(The first commit of that series is in patch 6/6 of this series, and patch 5 is
the modernization effort.)

Thanks,
Stefan
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help