Re: [PATCH v2] git-checkout.txt: Document "git checkout <pathspec>" better

2 messages, 2 authors, 2016-06-15 · open the first message on its own page

Re: [PATCH v2] git-checkout.txt: Document "git checkout <pathspec>" better

From: Junio C Hamano <hidden>
Date: 2016-06-15 23:05:21

Matthieu Moy [off-list ref] writes:
Torsten Bögershausen [off-list ref] writes:
quoted
My v3 will probably use the original line:
git-checkout - Checkout a branch or paths to the working tree
I think mentionning "Switch branch" was a real improvement. For someone
not familiar with the version control vocabulary, "checkout" does not
mean much (just looked in a dictionary, it talks about payment and
leaving a room in a hotel ...). And someone not understanding what
"checkout" means in this context won't be helped much reading the
description and getting "checkout" there.
Or, borrow a book from a library, which I think is the closest
analogy for this operation.  But you are right.  It is suboptimal to
explain "checkout" in terms of "checkout" ;-).
But as you say, it copies into the workspace, so "copy a previous
version into the workspace" sounds good to me.
I am afraid that "previous" would lead to "Ah, you mean HEAD~1?"
confusion.  In any case, you cannot copy what hasn't yet been
created, "previous" is superfluous.

I think "restore" also by definition has to go back to _some_
existing version, not a future yet-to-be-created one, so "restore to
some previous state" is superfluous; in that sense, I find that
"restore working tree files" may still be the one that makes most
sense, at least to me, among the phrases floated in this thread so
far.
Basically, I'm fine with anything starting with "Switch branches or",
but please do change the headline ;-).
Likewise; I agree "switch branches or" part is good.

Re: [PATCH v2] git-checkout.txt: Document "git checkout <pathspec>" better

From: Torsten Bögershausen <hidden>
Date: 2016-06-15 23:05:21

On 2015-06-17 21.23, Junio C Hamano wrote:
[]
quoted
Basically, I'm fine with anything starting with "Switch branches or",
but please do change the headline ;-).
Likewise; I agree "switch branches or" part is good.
How about this:

git-checkout - Switch branches or restore changes to the working tree
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help