[PATCH] Receive-pack: include entire SHA1 in nonce
From: Brian Gernhardt <hidden>
Date: 2016-06-15 23:02:35
Subsystem:
the rest · Maintainer:
Linus Torvalds
From: Brian Gernhardt <hidden>
Date: 2016-06-15 23:02:35
Subsystem:
the rest · Maintainer:
Linus Torvalds
clang gives the following warning:
builtin/receive-pack.c:327:35: error: sizeof on array function
parameter will return size of 'unsigned char *' instead of 'unsigned
char [20]' [-Werror,-Wsizeof-array-argument]
git_SHA1_Update(&ctx, out, sizeof(out));
^
builtin/receive-pack.c:292:37: note: declared here
static void hmac_sha1(unsigned char out[20],
^
---
I dislike changing sizeof to a magic constant, but clang informs me that
sizeof is doing the wrong thing. Perhaps there's an appropriate constant
#defined in the code somewhere?
builtin/receive-pack.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/builtin/receive-pack.c b/builtin/receive-pack.c
index aab3df7..92388e5 100644
--- a/builtin/receive-pack.c
+++ b/builtin/receive-pack.c@@ -324,7 +324,7 @@ static void hmac_sha1(unsigned char out[20], /* RFC 2104 2. (6) & (7) */ git_SHA1_Init(&ctx); git_SHA1_Update(&ctx, k_opad, sizeof(k_opad)); - git_SHA1_Update(&ctx, out, sizeof(out)); + git_SHA1_Update(&ctx, out, 20); git_SHA1_Final(out, &ctx); }
--
2.1.1.445.gb8dfbef.dirty