From: Junio C Hamano <hidden> Date: 2016-06-15 23:01:59
Erik Faye-Lund [off-list ref] writes:
On Thu, Jul 17, 2014 at 5:37 PM, Stepan Kasal [off-list ref] wrote:
quoted
From: Pat Thoyts <redacted>
On Windows the application command line is provided as unicode and in
mingw-git we convert that to utf-8. So these tests that require a iso-8859-1
input are being subverted by the encoding transformations we perform and
should be skipped.
...
-test_expect_success 'log --grep searches in log output encoding (latin1)' '
+test_expect_success NOT_MINGW 'log --grep searches in log output encoding (latin1)' '
cat >expect <<-\EOF &&
latin1
utf8
@@ -43,7 +43,7 @@ test_expect_success 'log --grep searches in log output encoding (latin1)' ' test_cmp expect actual '-test_expect_success 'log --grep does not find non-reencoded values (utf8)' '+test_expect_success NOT_MINGW 'log --grep does not find non-reencoded values (utf8)' '
Perhaps these checks would be more readable a few years in the future,
if we make a separate capability along the lines of
NON_UNICODE_LOCALE?
I do agree that having "unicode" and possibly also "locale" and
dropping "mingw" from the prerequisite makes sense, especially in
the longer term. Please make it so _after_ the dust settles.
I however suspect that NON_UNICODE_LOCALE does not read quite well;
isn't the trouble that mingw allows nothing but unicode strings on
the command line (there is no trouble for non unicode strings that
appear as payload)?
Oh by the way, can somebody remind me why we spell these as
NOT_MINGW, instead of !MINGW?
--
--
*** Please reply-to-all at all times ***
*** (do not pretend to know who is subscribed and who is not) ***
*** Please avoid top-posting. ***
The msysGit Wiki is here: https://github.com/msysgit/msysgit/wiki - Github accounts are free.
You received this message because you are subscribed to the Google
Groups "msysGit" group.
To post to this group, send email to msysgit@googlegroups.com
To unsubscribe from this group, send email to
msysgit+unsubscribe@googlegroups.com
For more options, and view previous threads, visit this group at
http://groups.google.com/group/msysgit?hl=en_US?hl=en
---
You received this message because you are subscribed to the Google Groups "msysGit" group.
To unsubscribe from this group and stop receiving emails from it, send an email to msysgit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
From: Johannes Schindelin <hidden> Date: 2016-06-15 23:01:59
Hi Junio,
On Mon, 21 Jul 2014, Junio C Hamano wrote:
Oh by the way, can somebody remind me why we spell these as
NOT_MINGW, instead of !MINGW?
I guess that is my mistake; when I introduced the use of NOT_MINGW I was
simply unaware of the !MINGW syntax.
Let's use the latter consistently?
Ciao,
Johannes
--
--
*** Please reply-to-all at all times ***
*** (do not pretend to know who is subscribed and who is not) ***
*** Please avoid top-posting. ***
The msysGit Wiki is here: https://github.com/msysgit/msysgit/wiki - Github accounts are free.
You received this message because you are subscribed to the Google
Groups "msysGit" group.
To post to this group, send email to msysgit@googlegroups.com
To unsubscribe from this group, send email to
msysgit+unsubscribe@googlegroups.com
For more options, and view previous threads, visit this group at
http://groups.google.com/group/msysgit?hl=en_US?hl=en
---
You received this message because you are subscribed to the Google Groups "msysGit" group.
To unsubscribe from this group and stop receiving emails from it, send an email to msysgit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
From: Johannes Sixt <hidden> Date: 2016-06-15 23:01:59
Am 21.07.2014 19:45, schrieb Johannes Schindelin:
Hi Junio,
On Mon, 21 Jul 2014, Junio C Hamano wrote:
quoted
Oh by the way, can somebody remind me why we spell these as
NOT_MINGW, instead of !MINGW?
I guess that is my mistake; when I introduced the use of NOT_MINGW I was
simply unaware of the !MINGW syntax.
You can hardly be blamed. The first occurrence of NOT_MINGW was added
much earlier than the ability to negate prerequisite tokens.
Let's use the latter consistently?
Of course!
-- Hannes
--
--
*** Please reply-to-all at all times ***
*** (do not pretend to know who is subscribed and who is not) ***
*** Please avoid top-posting. ***
The msysGit Wiki is here: https://github.com/msysgit/msysgit/wiki - Github accounts are free.
You received this message because you are subscribed to the Google
Groups "msysGit" group.
To post to this group, send email to msysgit@googlegroups.com
To unsubscribe from this group, send email to
msysgit+unsubscribe@googlegroups.com
For more options, and view previous threads, visit this group at
http://groups.google.com/group/msysgit?hl=en_US?hl=en
---
You received this message because you are subscribed to the Google Groups "msysGit" group.
To unsubscribe from this group and stop receiving emails from it, send an email to msysgit+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.