Re: [PATCH 1/2] test-lib: tests skipped by GIT_SKIP_TESTS say so

2 messages, 2 authors, 2016-06-15 · open the first message on its own page

Re: [PATCH 1/2] test-lib: tests skipped by GIT_SKIP_TESTS say so

From: Eric Sunshine <hidden>
Date: 2016-06-15 23:00:10

On Mon, Mar 3, 2014 at 6:12 PM, Ilya Bobyr [off-list ref] wrote:
On 3/3/2014 2:59 PM, Eric Sunshine wrote:
quoted
On Mon, Mar 3, 2014 at 5:24 AM, Ilya Bobyr [off-list ref] wrote:
quoted
We used to show "(missing )" next to tests skipped because they are
specified in GIT_SKIP_TESTS.  Use "(matched by GIT_SKIP_TESTS)" instead.
Bikeshedding: That's pretty verbose. Perhaps just say "(excluded)"?

The next patch adds another reason for the test to be skipped, so it seems
reasonable to say why exactly.
The patch actually makes it say "matched GIT_SKIP_TESTS".
It looks OK on the console.
Still just bikeshedding:

That new message in patch #2 says "not in GIT_TEST_ONLY", but isn't
"(excluded)" also applicable to that case? Is it important to be able
to distinguish between the two "excluded" reasons?

(No more bikeshedding for me.)

Re: [PATCH 1/2] test-lib: tests skipped by GIT_SKIP_TESTS say so

From: Ilya Bobyr <hidden>
Date: 2016-06-15 23:00:10

On 3/3/2014 3:18 PM, Eric Sunshine wrote:
On Mon, Mar 3, 2014 at 6:12 PM, Ilya Bobyr [off-list ref] wrote:
quoted
On 3/3/2014 2:59 PM, Eric Sunshine wrote:
quoted
On Mon, Mar 3, 2014 at 5:24 AM, Ilya Bobyr [off-list ref] wrote:
quoted
We used to show "(missing )" next to tests skipped because they are
specified in GIT_SKIP_TESTS.  Use "(matched by GIT_SKIP_TESTS)" instead.
Bikeshedding: That's pretty verbose. Perhaps just say "(excluded)"?
The next patch adds another reason for the test to be skipped, so it seems
reasonable to say why exactly.
The patch actually makes it say "matched GIT_SKIP_TESTS".
It looks OK on the console.
Still just bikeshedding:

That new message in patch #2 says "not in GIT_TEST_ONLY", but isn't
"(excluded)" also applicable to that case? Is it important to be able
to distinguish between the two "excluded" reasons?

(No more bikeshedding for me.)
Makes sense.  I guess it is unlikely you would want to use both include 
and exclude filters in one run.
On the other hand it seems nice to see the reason why it was skipped.

Here are both options for comparison.  "Longer":

     $ GIT_SKIP_TESTS='t0000.[236789] t0001.??' ./t0001-init.sh
     ok 1 - plain
     ok 2 # skip plain nested in bare (matched GIT_SKIP_TESTS)
     ok 3 # skip plain through aliased command, outside any git repo 
(matched GIT_SKIP_TESTS)
     not ok 4 - plain nested through aliased command # TODO known breakage
     not ok 5 - plain nested in bare through aliased command # TODO 
known breakage
     ok 6 # skip plain with GIT_WORK_TREE (matched GIT_SKIP_TESTS)

and changed to "excluded":

     $ GIT_SKIP_TESTS='t0000.[236789] t0001.??' ./t0001-init.sh
     ok 1 - plain
     ok 2 # skip plain nested in bare (excluded)
     ok 3 # skip plain through aliased command, outside any git repo 
(excluded)
     not ok 4 - plain nested through aliased command # TODO known breakage
     not ok 5 - plain nested in bare through aliased command # TODO 
known breakage
     ok 6 # skip plain with GIT_WORK_TREE (excluded)

P.S. It seems that now the whole interface may change :)
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help