[PATCH 1/2] test: rename $satisfied to $satisfied_prereq
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:54:21
Subsystem:
the rest · Maintainer:
Linus Torvalds
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:54:21
Subsystem:
the rest · Maintainer:
Linus Torvalds
All other shell variables that globally keep track of prerequisite related states have "prereq" somewhere in their names. Be consistent and avoid name crashes. Signed-off-by: Junio C Hamano <redacted> --- * Just a preparatory clean-up. t/test-lib-functions.sh | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/t/test-lib-functions.sh b/t/test-lib-functions.sh
index 80daaca..4dc027d 100644
--- a/t/test-lib-functions.sh
+++ b/t/test-lib-functions.sh@@ -221,9 +221,9 @@ write_script () { # capital letters by convention). test_set_prereq () { - satisfied="$satisfied$1 " + satisfied_prereq="$satisfied_prereq$1 " } -satisfied=" " +satisfied_prereq=" " test_have_prereq () { # prerequisites can be concatenated with ','
@@ -239,7 +239,7 @@ test_have_prereq () { for prerequisite do total_prereq=$(($total_prereq + 1)) - case $satisfied in + case "$satisfied_prereq" in *" $prerequisite "*) ok_prereq=$(($ok_prereq + 1)) ;;
--
1.7.12.rc0.44.gc69a8ad