[PATCH v5 5/5] http: rename HTTP_REAUTH to HTTP_RETRY
From: Nelson Benitez Leon <hidden>
Date: 2016-06-15 22:53:17
Subsystem:
the rest · Maintainer:
Linus Torvalds
After adding the proxy authentication support in http, the semantics of HTTP_REAUTH changed more to a retry rather than a re-authentication, so we rename it to HTTP_RETRY. Signed-off-by: Nelson Benitez Leon <redacted> --- http.c | 6 +++--- http.h | 2 +- 2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/http.c b/http.c
index 12dcaa1..bc470e8 100644
--- a/http.c
+++ b/http.c@@ -837,7 +837,7 @@ static int http_request(const char *url, void *result, int target, int options) } else { credential_fill(&http_auth); init_curl_http_auth(slot->curl); - ret = HTTP_REAUTH; + ret = HTTP_RETRY; } } else if (results.http_code == 407) { /* Proxy authentication failure */ if (proxy_auth.username && proxy_auth.password) {
@@ -846,7 +846,7 @@ static int http_request(const char *url, void *result, int target, int options) } else { credential_fill(&proxy_auth); set_proxy_auth(slot->curl); - ret = HTTP_REAUTH; + ret = HTTP_RETRY; } } else { if (!curl_errorstr[0])
@@ -876,7 +876,7 @@ static int http_request_reauth(const char *url, void *result, int target, do { ret = http_request(url, result, target, options); - } while (ret == HTTP_REAUTH); + } while (ret == HTTP_RETRY); return ret; }
diff --git a/http.h b/http.h
index 303eafb..3936f7f 100644
--- a/http.h
+++ b/http.h@@ -123,7 +123,7 @@ extern char *get_remote_object_url(const char *url, const char *hex, #define HTTP_MISSING_TARGET 1 #define HTTP_ERROR 2 #define HTTP_START_FAILED 3 -#define HTTP_REAUTH 4 +#define HTTP_RETRY 4 #define HTTP_NOAUTH 5 /*
--
1.7.7.6