Re: [PATCH 3/3] rename git_path() to git_path_unsafe()

2 messages, 2 authors, 2016-06-15 · open the first message on its own page

Re: [PATCH 3/3] rename git_path() to git_path_unsafe()

From: Junio C Hamano <hidden>
Date: 2016-06-15 22:52:29

Given that other functions like real_path() and mkpath() share the same
"perishable, use it immediately" property, and also git_path() is such a
short and sweet name, I am beginning to think that we probably should
leave these alone but document that *path() are "unsafe" somewhere and
just add *path_cpy() or your strbuf_addpath() function.

In any case, I do not like seeing many list regulars throwing too many
non-regression-fix patches during prerelease freeze period on the
list. Continuing development for the next cycle is encouraged and trying
to do so using workflows that you do not usually use is even more
encouraged, though. You would make more use of the release candidate Git
for such activities, and may uncover regressions before the final.

Thanks.

Re: [PATCH 3/3] rename git_path() to git_path_unsafe()

From: Jonathan Nieder <hidden>
Date: 2016-06-15 22:52:29

Junio C Hamano wrote:
In any case, I do not like seeing many list regulars throwing too many
non-regression-fix patches during prerelease freeze period on the
list.
Fine, but what about the buffer overflow (not an incredibly recent
regression, but certainly a fix) addressed in patch 2 of the series?
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help