Re: [PATCH] block-sha1: Windows declares ntohl() in winsock2.h
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:47:16
Junio C Hamano [off-list ref] writes:
Nicolas Pitre [off-list ref] writes:quoted
On Tue, 18 Aug 2009, Junio C Hamano wrote:quoted
To reduce confusion, you may want to rename compat/bswap.h to something like compat/ntohl-htonl-fix.h ;-)Bah. If you wish, you can edit the patch directly for this, unless you really prefer me to repost. Maybe we might want to add a 8-byte versions of those as well eventually, which is why I chose a more generic name.Ok, here is what I came up with after many squashing...
Meh, our mails crossed. I'll chuck this one and use your
[PATCH] make sure byte swapping is optimal for git
patch. Do you want default_swab32 be mmoved inside the
#if defined(__GNUC__) && (defined(__i386__) || defined(__x86_64__))
block?