Petr Baudis [off-list ref] writes:
On Fri, May 30, 2008 at 10:27:50PM +0200, Lea Wiemann wrote:
quoted
The parse_rev method takes a revision name and returns a SHA1 hash,
like the git-rev-parse command.
Signed-off-by: Lea Wiemann <redacted>
Nice, this looks quite sane!
Perhaps, but except for the use of nonstandard try...catch. I have been
wondering if we can move away from it, with the goal of eventually getting
rid of the construct altogether.
Didn't we hear from Randal that the construct is known to be leaky?
On Fri, May 30, 2008 at 02:25:58PM -0700, Junio C Hamano wrote:
Perhaps, but except for the use of nonstandard try...catch. I have been
wondering if we can move away from it, with the goal of eventually getting
rid of the construct altogether.
It's consistent with the rest of the code; we may want to remove it,
but we should either do it everywhere or not at all and I think it's
an issue independent on this patch.
Didn't we hear from Randal that the construct is known to be leaky?
I agree that in hindsight, using this construct was probably not the
best idea, and I'm in principle not against removing it as long as there
is no functionality lost - the ability to let the program just fail
if I don't care in my code, or catch specifically for nonzero exit codes
and let the program fail in other cases, is very useful and I do use it
in some of my code; I would hate to lose this flexibility.
If there is an alternative (perhaps even slightly more clumsy) way to
solve this, I have no problem with switching over; however, I don't have
much time or interest to research this myself. If Lea wants to figure
something out, she (*) is welcome as far as I'm concerned.
(*) Lea, I hope I figured this out right - sorry if not. :-)
--
Petr "Pasky" Baudis
Whatever you can do, or dream you can, begin it.
Boldness has genius, power, and magic in it. -- J. W. von Goethe