What's in git.git (stable)
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:43:48
On 'master' front:
- git-p4 in contrib/ has updates. As I cannot test it myself
and did not hear any success/failure stories from the list,
the only way to make sure is to push it out and see if
anybody screams.
- "git lost-found" is going to be deprecated (not removed) in
the next feature release.
- Unspecified clean.requireForce defaults to true; this would
make "git clean" require "-f" by default.
- "git send-email --suppress-from" does not CC yourself even
when your name is on S-o-b: or Cc: lines in the body of the
message.
----------------------------------------------------------------
* The 'maint' branch has these fixes since the last announcement.
Ask Bjørn Hansen (1):
When exec() fails include the failing command in the error message
David D Kilzer (2):
RelNotes-1.5.3.5: fix typo
RelNotes-1.5.3.5: fix another typo
Eric Wong (2):
git-svn: fix dcommit clobbering when committing a series of diffs
git-svn: t9114: verify merge commit message in test
Gerrit Pape (3):
git-diff.txt: add section "output format" describing the diff
formats
git-cvsimport: really convert underscores in branch names to dots
with -u
git-daemon: fix remote port number in log entry
Johannes Schindelin (1):
Add Documentation/CodingGuidelines
Junio C Hamano (1):
grep with unmerged index
Marco Costalba (1):
Remove a couple of duplicated include
Mike Hommey (1):
Delay pager setup in git blame
* The 'master' branch has these since the last announcement
in addition to the above.
Benoit Sigoure (1):
git-svn: sort the options in the --help message.
Brian Gernhardt (1):
t3502: Disambiguate between file and rev by adding --
Chris Pettitt (2):
git-p4: Add a helper function to parse the full git diff-tree
output.
git-p4: Detect changes to executable bit and include them in p4
submit.
Daniel Barkalow (1):
Use parseopts in builtin-push
David Symonds (1):
Improve accuracy of check for presence of deflateBound.
Gerrit Pape (4):
git-reset: add -q option to operate quietly
contrib/hooks/post-receive-email: fix typo
contrib/hooks/post-receive-email: reformat to wrap comments at 76
chars
contrib/hooks/post-receive-email: make subject prefix configurable
Heikki Orsila (1):
git-clone: honor "--" to end argument parsing
J. Bruce Fields (1):
errors: "strict subset" -> "ancestor"
Jakub Narebski (9):
gitweb: Always set 'from_file' and 'to_file' in
parse_difftree_raw_line
gitweb: Add 'status_str' to parse_difftree_raw_line output
gitweb: Remove CGI::Carp::set_programname() call from t9500 gitweb
test
gitweb: Easier adding/changing parameters to current URL
gitweb: Use href(-replay=>1, page=>...) to generate pagination
links
gitweb: Use href(-replay=>1, action=>...) to generate alternate
views
gitweb: Add tests for overriding gitweb config with repo config
gitweb: Read repo config using 'git config -z -l'
gitweb: Use config file for repository description and URLs
Johannes Schindelin (3):
git-reset: do not be confused if there is nothing to reset
Split off the pretty print stuff into its own file
Deprecate git-lost-found
Johannes Sixt (1):
Fix an infinite loop in sq_quote_buf().
Junio C Hamano (6):
revert/cherry-pick: work on merge commits as well
format-patch -s: add MIME encoding header if signer's name requires
so
cherry-pick/revert -m: add tests
test format-patch -s: make sure MIME content type is shown as
needed
clean: require -f to do damage by default
gc: --prune prunes unreferenced objects.
Mike Hommey (5):
Refactor working tree setup
Use setup_work_tree() in builtin-ls-files.c
Don't always require working tree for git-rm
Make git-blame fail when working tree is needed and we're not in
one
Small code readability improvement in show_reference() in
builtin-tag.c
Nicolas Pitre (4):
make the pack index version configurable
pack-objects: get rid of an ugly cast
git-fetch: more terse fetch output
restore fetching with thin-pack capability
Pierre Habouzit (1):
Some better parse-options documentation.
Ralf Wildenhues (1):
Fix minor nits in configure.ac
Shawn Bohrer (1):
Add more tests for git-clean
Simon Sasburg (1):
Make mailsplit and mailinfo strip whitespace from the start of the
input
Steffen Prohaska (1):
Fix comment in strbuf.h to use correct name strbuf_avail()
Steven Grimm (1):
builtin-fetch: Add "-q" as a synonym for "--quiet"
Uwe Kleine-König (1):
send-email: apply --suppress-from to S-o-b and cc-cmd