Re: [PATCH 8/6] Teach directory traversal about subprojects
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:43:04
Linus Torvalds [off-list ref] writes:
Yes, this adds many more lines than it removes, but 40 of the added lines really are just added comments about what we're doing. And the end result really is more readable too even if ignoring the comments, I think.
Much nicer to read.
quoted hunk
diff --git a/dir.h b/dir.h index 33c31f2..1931609 100644 --- a/dir.h +++ b/dir.h@@ -33,7 +33,8 @@ struct dir_struct { int nr, alloc; unsigned int show_ignored:1, show_other_directories:1, - hide_empty_directories:1; + hide_empty_directories:1, + no_dirlinks; struct dir_entry **entries; /* Exclude info */
Did you mean a bitfield here?