DORMANTno replies

[PATCH 2/2] Replace open-coded version of hash_sha1_file()

From: Rene Scharfe <hidden>
Date: 2016-06-15 22:42:43
Subsystem: the rest · Maintainer: Linus Torvalds

Signed-off-by: Rene Scharfe <redacted>
---
 sha1_file.c |    8 +-------
 1 files changed, 1 insertions(+), 7 deletions(-)
diff --git a/sha1_file.c b/sha1_file.c
index 66cc767..716aef3 100644
--- a/sha1_file.c
+++ b/sha1_file.c
@@ -671,14 +671,8 @@ static void reprepare_packed_git(void)
 
 int check_sha1_signature(const unsigned char *sha1, void *map, unsigned long size, const char *type)
 {
-	char header[100];
 	unsigned char real_sha1[20];
-	SHA_CTX c;
-
-	SHA1_Init(&c);
-	SHA1_Update(&c, header, 1+sprintf(header, "%s %lu", type, size));
-	SHA1_Update(&c, map, size);
-	SHA1_Final(real_sha1, &c);
+	hash_sha1_file(map, size, type, real_sha1);
 	return hashcmp(sha1, real_sha1) ? -1 : 0;
 }
 
-- 
1.4.3.rc2.gdce3
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help