DORMANTno replies

[PATCH 0/5] sha1_file.c pack reading cleanups

From: Shawn Pearce <hidden>
Date: 2016-06-15 22:42:38

This is a 5 patch series built on `master`.  I discovered these
cleanups when I lifted code from sha1_file.c for fast-import.c
(as I needed to read the pack I was writing and thus didn't have
a nice sorted index to work with).

I'll probably follow this series with another one which libifies
more of these functions to the point that I can actually use them
from within fast-import.c, without having an index file.  But I
might first send partial pack mapping as I'm also doing that in
fast-import.c right now.

In this series:

  1/5 Reorganize/rename unpack_non_delta_entry to unpack_compressed_entry.
  2/5 Reuse compression code in unpack_compressed_entry.
  3/5 Cleanup unpack_entry_gently and friends to use type_name array.
  4/5 Cleanup unpack_object_header to use only offsets.
  5/5 Convert unpack_entry_gently and friends to use offsets.

-- 
Shawn.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help