Reviews by dakr@kernel.org
· driver-core
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the driver-core archive.
100 attestations · capped at 100 most-recent. (41 Acked-by, 4 Co-developed-by, 40 Reviewed-by, 15 Suggested-by)
-
HOTtoday
REVIEWED: 16 (16M) [PATCH v3 4/9] mlxsw: don't store pci_device_id
2026-07-06 · Reviewed-by -
HOTtoday
REVIEWED: 15 (15M) [PATCH v3 3/9] ipack: tpci200: don't store pci_device_id
2026-07-06 · Reviewed-by -
HOTtoday
REVIEWED: 15 (15M) [PATCH v3 7/9] pci: make pci_match_one_device match on ID instead of device
2026-07-06 · Reviewed-by -
HOTtoday
REVIEWED: 15 (15M) [PATCH v3 2/9] nsp32: don't store pci_device_id
2026-07-06 · Reviewed-by -
HOTtoday
REVIEWED: 15 (15M) [PATCH v3 1/9] ata: don't store pci_device_id
2026-07-06 · Reviewed-by -
HOTtoday
REVIEWED: 5 (5M) [PATCH v6 12/20] rust: io: move `Io` methods to extension trait
2026-07-06 · Suggested-by -
HOTtoday
[PATCH v6 00/20] rust: I/O type generalization and projection
2026-07-06 · Suggested-by -
DORMANTno replies
REVIEWED: 15 (15M) Re: [PATCH v1 2/2] ACPI: scan: Set power.no_pm for all struct acpi_device objects
2026-07-03 · Reviewed-by -
WARM3d
REVIEWED: 15 (15M) Re: [PATCH v1 1/2] 1/2] ACPI: bus: Eliminate struct acpi_driver
2026-07-03 · Reviewed-by -
DORMANTno replies
REVIEWED: 15 (15M) Re: [PATCH v2] driver core: add driver name to probe debug print
2026-07-03 · Acked-by -
COOLING5d
REVIEWED: 15 (15M) Re: [PATCH 3/4] usb: serial: spcp8x5: don't keep usb_device_id
2026-06-30 · Reviewed-by -
COOLING5d
REVIEWED: 15 (15M) Re: [PATCH 2/4] usb: usbtmc: don't keep usb_device_id
2026-06-30 · Reviewed-by -
COOLING5d
REVIEWED: 15 (15M) Re: [PATCH 1/4] wifi: ath9k_htc: don't keep usb_device_id
2026-06-30 · Reviewed-by -
COOLING5d
REVIEWED: 15 (15M) Re: [PATCH v2 5/7] pci: make pci_match_one_device match on ID instead of device
2026-06-30 · Reviewed-by -
COOLING5d
REVIEWED: 15 (15M) Re: [PATCH v2 4/7] mlxsw: don't keep pci_device_id
2026-06-30 · Reviewed-by -
COOLING5d
REVIEWED: 15 (15M) Re: [PATCH v2 3/7] ipack: tpci200: don't keep pci_device_id
2026-06-30 · Reviewed-by -
COOLING5d
REVIEWED: 15 (15M) Re: [PATCH v2 2/7] nsp32: don't keep pci_device_id
2026-06-30 · Reviewed-by -
COOLING5d
REVIEWED: 15 (15M) Re: [PATCH v2 1/7] ata: don't keep pci_device_id
2026-06-30 · Reviewed-by -
COOLING7d
REVIEWED: 53 (53M) [PATCH v4 03/17] driver: core: Include headers for acpi_device_id and of_device_id for struct device_driver
2026-06-30 · Acked-by -
COOLING5d
REVIEWED: 33 (33M) [PATCH v3 03/16] driver: core: Include headers for acpi_device_id and of_device_id for struct device_driver
2026-06-28 · Acked-by -
COOLING5d
REVIEWED: 15 (15M) Re: [PATCH v2 00/17] mod_devicetable.h: Split into per subsystem headers
2026-06-27 · Acked-by -
DORMANTno replies
REVIEWED: 25 (25M) [PATCH v7 06/10] rust: miscdevice: set fops.owner from driver module pointer
2026-06-27 · Acked-by -
DORMANTno replies
REVIEWED: 21 (21M) [PATCH v7 07/10] rust: configfs: use `LocalModule` for `THIS_MODULE`
2026-06-27 · Acked-by -
DORMANTno replies
REVIEWED: 19 (19M) [PATCH v7 08/10] rust: binder: use `LocalModule` for `THIS_MODULE`
2026-06-27 · Acked-by -
DORMANTno replies
REVIEWED: 25 (25M) [PATCH v7 09/10] rust: macros: remove `THIS_MODULE` static from `module!`
2026-06-27 · Acked-by -
COOLING10d
REVIEWED: 25 (25M) [PATCH v7 02/10] rust: module: add `THIS_MODULE` const to `ModuleMetadata` trait
2026-06-27 · Acked-by -
COOLING10d
REVIEWED: 15 (15M) [PATCH v7 01/10] rust: module: move module types into `module.rs`
2026-06-27 · Acked-by -
COOLING10d
REVIEWED: 25 (25M) [PATCH v7 04/10] rust: macros: auto-insert OwnerModule in #[vtable]
2026-06-27 · Acked-by -
COOLING10d
REVIEWED: 25 (25M) [PATCH v7 03/10] rust: doctest: add LocalModule fallback for #[vtable] ThisModule
2026-06-27 · Acked-by -
COOLING10d
REVIEWED: 25 (25M) [PATCH v7 05/10] rust: drm: set fops.owner from driver module pointer
2026-06-27 · Acked-by -
WARM1d
[PATCH v5 12/20] rust: io: move `Io` methods to extension trait
2026-06-26 · Suggested-by -
WARM1d
[PATCH v5 00/20] rust: I/O type generalization and projection
2026-06-26 · Suggested-by -
COOLING10d
REVIEWED: 34 (33M) [PATCH v19 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-26 · Acked-by -
COOLING11d
REVIEWED: 34 (33M) [PATCH v18 5/8] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-25 · Acked-by -
COOLING9d
REVIEWED: 21 (21M) [PATCH v6 07/10] rust: configfs: use `LocalModule` for `THIS_MODULE`
2026-06-24 · Acked-by -
COOLING9d
REVIEWED: 19 (19M) [PATCH v6 08/10] rust: binder: use `LocalModule` for `THIS_MODULE`
2026-06-24 · Acked-by -
COOLING9d
REVIEWED: 25 (25M) [PATCH v6 09/10] rust: macros: remove `THIS_MODULE` static from `module!`
2026-06-24 · Acked-by -
COOLING9d
REVIEWED: 15 (15M) [PATCH v6 01/10] rust: module: move module types into `module.rs`
2026-06-24 · Acked-by -
COOLING9d
REVIEWED: 25 (25M) [PATCH v6 02/10] rust: module: add `THIS_MODULE` const to `ModuleMetadata` trait
2026-06-24 · Acked-by -
COOLING9d
REVIEWED: 25 (25M) [PATCH v6 03/10] rust: doctest: add LocalModule fallback for #[vtable] ThisModule
2026-06-24 · Acked-by -
COOLING9d
REVIEWED: 25 (25M) [PATCH v6 05/10] rust: drm: set fops.owner from driver module pointer
2026-06-24 · Acked-by -
COOLING9d
REVIEWED: 25 (25M) [PATCH v6 04/10] rust: macros: auto-insert OwnerModule in #[vtable]
2026-06-24 · Acked-by -
COOLING9d
REVIEWED: 25 (25M) [PATCH v6 06/10] rust: miscdevice: set fops.owner from driver module pointer
2026-06-24 · Acked-by -
COOLING12d
REVIEWED: 15 (15M) Re: [PATCH v5 0/9] Fix missing fops.owner in Rust DRM/misc abstractions
2026-06-24 · Acked-by -
COOLING11d
REVIEWED: 20 (20M) [PATCH v21 4/4] rust: drm: gem: Introduce shmem::Object::sg_table()
2026-06-12 · Acked-by -
COOLING11d
REVIEWED: 32 (32M) [PATCH v21 3/4] rust: faux: Allow retrieving a bound Device
2026-06-12 · Acked-by -
COOLING11d
REVIEWED: 32 (32M) [PATCH v21 2/4] rust: drm: gem: shmem: Add vmap functions
2026-06-12 · Acked-by -
COOLING11d
REVIEWED: 27 (27M) [PATCH v21 1/4] rust: drm: gem: shmem: Add DmaResvGuard helper
2026-06-12 · Acked-by -
COLD15d
[PATCH v4 11/20] rust: io: move `Io` methods to extension trait
2026-06-11 · Suggested-by -
COLD15d
[PATCH v4 00/20] rust: I/O type generalization and projection
2026-06-11 · Suggested-by -
COLD24d
REVIEWED: 15 (15M) Re: [PATCH v20 0/4] Rust bindings for gem shmem
2026-06-11 · Acked-by -
COLD23d
REVIEWED: 46 (46M) [PATCH v4] rust: make `build_assert` module the home of related macros
2026-06-09 · Acked-by -
COLD26d
Re: [PATCH v3 00/19] rust: I/O type generalization and projection
2026-06-08 · Suggested-by -
COLD26d
[PATCH v3 11/19] rust: io: move `Io` methods to extension trait
2026-06-08 · Suggested-by -
COLD26d
REVIEWED: 15 (15M) Re: [PATCH v19 0/4] Rust bindings for gem shmem
2026-06-08 · Acked-by -
COLD27d
REVIEWED: 23 (23M) [PATCH v5 3/3] rust: io: use the `bitfield!` macro in `register!`
2026-06-06 · Acked-by -
COLD27d
REVIEWED: 16 (15M) [PATCH v5 2/3] rust: bitfield: Add KUnit tests for bitfield
2026-06-06 · Acked-by -
COLD27d
REVIEWED: 16 (15M) [PATCH v5 1/3] rust: extract `bitfield!` macro from `register!`
2026-06-06 · Acked-by -
COLD30d
REVIEWED: 15 (15M) Re: [PATCH v4 0/7] rust: add `bitfield!` macro
2026-06-06 · Acked-by -
COOLING12d
REVIEWED: 34 (33M) [PATCH v17 06/10] rust: rename `AlwaysRefCounted` to `RefCounted`.
2026-06-04 · Acked-by -
COLD32d
REVIEWED: 15 (15M) Re: [PATCH v2 0/6] Rework index projection syntax
2026-06-02 · Acked-by -
COLD37d
REVIEWED: 15 (15M) Re: [PATCH v8 3/5] rust: add basic serial device bus abstractions
2026-05-30 · Reviewed-by -
COLD37d
REVIEWED: 15 (15M) Re: [PATCH v8 1/5] rust: devres: return reference in `devres::register`
2026-05-30 · Acked-by -
COLD40d
REVIEWED: 23 (23M) [PATCH v5 03/24] rust: driver: move 'static bounds to constructor
2026-05-25 · Co-developed-by -
COLD42d
REVIEWED: 5 (5M) [PATCH v4 02/27] rust: driver: move 'static bounds to constructor
2026-05-21 · Co-developed-by -
DORMANTno replies
REVIEWED: 15 (15M) Re: [PATCH] sysfs: don't remove existing directory on update failure
2026-05-20 · Reviewed-by -
COLD46d
REVIEWED: 15 (15M) Re: [PATCH] sysfs: clamp show() return value in sysfs_kf_read()
2026-05-20 · Reviewed-by -
COLD48d
[PATCH v3 02/27] rust: driver: move 'static bounds to constructor
2026-05-17 · Co-developed-by -
COLD60d
REVIEWED: 15 (15M) Re: [PATCH] sysfs: upgrade OOB write by buggy .show hook into WARNing
2026-05-07 · Reviewed-by -
STALE61d
REVIEWED: 15 (15M) Re: [PATCH v4 0/2] firmware_loader/ALSA: Fix TAS2781 async firmware teardown
2026-05-06 · Acked-by -
DORMANTno replies
REVIEWED: 15 (15M) Re: [PATCH v2] sysfs: return -ENOENT from move/rename when kobj->sd is NULL
2026-05-04 · Reviewed-by -
COOLING11d
REVIEWED: 41 (41M) [PATCH v5 9/9] driver core: Replace dev->offline + ->offline_disabled with accessors
2026-04-06 · Reviewed-by -
COOLING11d
REVIEWED: 41 (41M) [PATCH v5 8/9] driver core: Replace dev->of_node_reused with dev_of_node_reused()
2026-04-06 · Reviewed-by -
COOLING11d
REVIEWED: 37 (37M) [PATCH v5 7/9] driver core: Replace dev->dma_coherent with dev_dma_coherent()
2026-04-06 · Reviewed-by -
COOLING11d
REVIEWED: 33 (33M) [PATCH v5 6/9] driver core: Replace dev->state_synced with dev_state_synced()
2026-04-06 · Reviewed-by -
COOLING11d
REVIEWED: 33 (33M) [PATCH v5 5/9] driver core: Replace dev->dma_ops_bypass with dev_dma_ops_bypass()
2026-04-06 · Reviewed-by -
COOLING11d
REVIEWED: 33 (33M) [PATCH v5 4/9] driver core: Replace dev->dma_skip_sync with dev_dma_skip_sync()
2026-04-06 · Reviewed-by -
COOLING11d
REVIEWED: 33 (33M) [PATCH v5 3/9] driver core: Replace dev->dma_iommu with dev_dma_iommu()
2026-04-06 · Reviewed-by -
COOLING11d
REVIEWED: 33 (33M) [PATCH v5 2/9] driver core: Replace dev->can_match with dev_can_match()
2026-04-06 · Reviewed-by -
COOLING11d
REVIEWED: 38 (38M) [PATCH v5 1/9] driver core: Don't let a device probe until it's ready
2026-04-06 · Reviewed-by -
STALE91d
REVIEWED: 15 (15M) Re: [PATCH v4 0/9] driver core: Fix some race conditions
2026-04-05 · Reviewed-by -
STALE100d
REVIEWED: 15 (15M) Re: [PATCH v2 0/7] rust: dma: add from-slice constructors and use them in nova-core
2026-03-26 · Reviewed-by -
STALE104d
[PATCH v2 8/8] gpu: nova-core: convert to new dma::Coherent API
2026-03-20 · Co-developed-by -
STALE99d
REVIEWED: 15 (15M) Re: [PATCH v3 4/4] rust: make `build_assert` module the home of related macros
2026-03-19 · Acked-by -
DORMANTno replies
REVIEWED: 15 (15M) Re: [PATCH v2 1/8] driver core: auxiliary bus: Introduce dev_is_auxiliary()
2026-03-13 · Reviewed-by -
STALE115d
REVIEWED: 15 (15M) Re: [PATCH v2 2/8] ACPI: video: Rework checking for duplicate video bus devices
2026-03-13 · Reviewed-by -
STALE124d
[PATCH v3 09/10] rust: pci: add physfn(), to return PF device for VF device
2026-03-03 · Suggested-by -
STALE124d
[PATCH v3 04/10] rust: pci: add vtable attribute to pci::Driver trait
2026-03-03 · Suggested-by -
STALE124d
[PATCH v3 05/10] rust: pci: add bus callback sriov_configure(), to control SR-IOV from sysfs
2026-03-03 · Suggested-by -
STALE124d
[PATCH v3 03/10] rust: pci: add {enable,disable}_sriov(), to control SR-IOV capability
2026-03-03 · Suggested-by -
STALE124d
[PATCH v3 01/10] PCI: add driver flag to opt into disabling SR-IOV on remove()
2026-03-03 · Suggested-by -
DORMANTno replies
REVIEWED: 51 (51M) FAILED: Patch "driver core: enforce device_lock for driver_match_device()" failed to apply to 5.10-stable tree
2026-03-01 · Reviewed-by -
DORMANTno replies
REVIEWED: 51 (51M) FAILED: Patch "driver core: enforce device_lock for driver_match_device()" failed to apply to 5.15-stable tree
2026-03-01 · Reviewed-by -
DORMANTno replies
REVIEWED: 51 (51M) FAILED: Patch "driver core: enforce device_lock for driver_match_device()" failed to apply to 6.1-stable tree
2026-03-01 · Reviewed-by -
STALE130d
REVIEWED: 64 (64M) [PATCH v4] gpiolib: match secondary fwnode too in gpio_device_find_by_fwnode()
2026-02-26 · Reviewed-by -
STALE130d
REVIEWED: 64 (64M) [PATCH v3] gpiolib: match secondary fwnode too in gpio_device_find_by_fwnode()
2026-02-25 · Reviewed-by -
STALE131d
REVIEWED: 15 (15M) Re: [PATCH v2 2/2] gpiolib: match secondary fwnode too in gpio_device_find_by_fwnode()
2026-02-23 · Reviewed-by -
STALE111d
REVIEWED: 15 (15M) [PATCH AUTOSEL 6.19-6.18] driver core: faux: stop using static struct device
2026-02-14 · Reviewed-by -
STALE131d
[PATCH v2 09/10] rust: pci: add physfn(), to return PF device for VF device
2026-02-05 · Suggested-by -
STALE131d
[PATCH v2 05/10] rust: pci: add bus callback sriov_configure(), to control SR-IOV from sysfs
2026-02-05 · Suggested-by